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C++  KEY POINTS 
CHAPTER 2: OVERVIEW OF C++ 

Introduction to C++: 

 C++ is the successor of C language & developed by Bjarne Stroustrup at Bell Laboratories, New Jersey in 1979. 
Tokens- smallest individual unit. Following are the tokens 

 Keyword-Reserve word that can’t be used as identifier 

 Identifiers-Names given to any variable, function, class, union etc. 

 Variable- memory block of certain size where value can be stored and changed. 

 Constant- memory block where value can be stored once but can’t changed later on. The various types of constants 
are: Integer constant, floating point constant, character constant, escape sequence. 

 Literals-Value of specific data type 

 String Literals: sequence of characters surrounded by double quotes. 

 Punctuators: characters with a specific function 

 Operator – performs some action on data 
o Arithmetic(+, -, *, /, %) 
o Assignment (=) 
o Relational (<, >, <=, >=, ==, !=). 
o Logical(AND(&&),OR(||),NOT(!). 
o Conditional (? :) 
o Increment/Decrement Operators( ++/--) 
o Scope resolution (: :) 

 

 Precedence of operators: 

++(post increment),--(post decrement) Highest 
 
 
 
 
 
 
 
 
 
 
  Low   

++(pre increment),--(pre decrement),sizeof !(not),-(unary),+unary plus) 

*(multiply), / (divide), %(modulus) 

+(add),-(subtract) 

<(less than),<=(less than or  equal),>(greater than), >=(greater than or equal to) 

==(equal),!=(not equal) 

&& (logical AND) 

||(logical OR) 

?:(conditional expression) 

=(simple assignment) and other assignment operators(arithmetic assignment operator) 

, Comma operator 

Data type- A specifier to create memory block of some specific size and type. For example – int,float,double,char etc.  its 
types are User-defined data type, built-in data type and derived data type. 
Pointers: is a variable that holds a memory address. 
Modifiers: alters the base data type to yield new data type. 
Typedef: Used to define new data type name eg: typedef struct {int a; int b;} 
Enum: An enumeration is a user-defined data type that consists of integral constants. To define an enumeration, 
keyword enum is used. Eg: enum flag { const1, const2, ..., constN }; 
Type cast: is the process of changing the data type of the value stored in a variable. 

 
CHAPTER 3: Basic statements  

cout – It is an object of ostream_withassign class defined in iostream.h header file and used to display value on monitor. 
cin – It is an object of istream_withassign class defined in iostream.h header file and used to read  value from keyboard 
for specific variable. 
comment- Used for better understanding of program statements and escaped by the compiler to compile . e.g. – single 
line (//) and multi line(/*….*/) 
Declaration statements: introduces a variable name and associates it with a specific data type. 
Note: any non-zero value of an expression is treated as true and exactly 0 (i.e. all bits contain 0) is treated as false. 
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conditional 
statement 
if Statement  

conditional 
statement 
(if else) 

Nested if 
statement 

case control 
statement (switch 
case) 

Loop start loop control statement 
(while ,do… while, for) 

Syntax Syntax syntax Syntax Syntax Syntax 

if(expression) 
{ 
action block; 
} 
 

if(expression) 
{ 
 action block1; 
} 
else 
{ 
action block2; 
} 

If(expression1) 
If(expression2) 
{ 
action 1; 
} 
else 
{ 
action 2; 
} 
else 
{ 
action 3; 
} 

switch(expression) 
{case (expression1): 
statements 
break; 
case (expression2): 
statements, 
break; 
default:statements;} 

loop_start: 
control statement 
{ 
conditions/actions/
statements; 
goto loop_start; 
} 

while(expression) 
{ 
action block; 
} 

do ….while loop 
do 
{ 
action block; 
} while(expression); 

 for loop 
for(expression1;expressi
on2;expression3) 
{ action block;} 

 
Nested loop -loop within loop. 
exit()- defined in process.h and used to leave from the program. 
break- exit from the current  loop. 
continue- to skip the remaining statements of the current loop and passes control to the next loop control statement. 
goto-  control is unconditionally  transferred to the location of local label specified by <identifier>. 
Some Standard C++ libraries 

Header Name Purpose 

iostream.h Defines stream classes for input/output streams 

stdio.h  Standard input and output 

ctype.h  Character tests 

string.h  String operations 

math.h  Mathematical functions such as sin() and cos() 

stdlib.h  Utility functions such as malloc() and rand() 

Some functions 

 isalpha(c)-check whether the argument is alphabetic or not. 

 islower(c)- check whether the argument is lowecase or not. 

 isupper(c) - check whether the argument is upercase or not. 

 isdigit(c)- check whether the argument is digit or not. 

 isalnum(c)- check whether the argument is alphanumeric or not. 

 tolower()-converts argument in lowercase if its argument is a letter. 

 toupper(c)- converts argument in uppercase if its argument is a letter. 

 strcat()- concatenates two string. 

 strcmp-compare two string. 

 pow(x,y)-return x raised to power y. 

 sqrt(x)-return square root of x. 

 random(num)-return a random number between 0 and (num-1) 

 randomize- initializes the random number generator with a random value. 
 

CHAPTER 4. FUNCTIONS 
Functions are the building blocks of C++ programs.  Functions are also the executable segments in a program.   
Function prototyping:  Functions should be declared before they are used in a program.  Declaration of a function is made 
through a function prototype. 
Syntax for function prototype: <type> <function identifier> <arguments>; 
Function -Self-contained block of code that does some specific task and may return a value. 
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Function prototypes-Function declaration that specifies the function name, return type and parameter list of the 
function.  
Calling value to function- 

1. Call by value   2. Call by reference 
Local variables: Declared inside the function. 
Global variables:  Declared outside all braces { } in a program 
Actual Parameters: Variables associated with function name during function call statement. 
Formal Parameters: Variables which contains copy of actual parameters inside the function definition. 
Invoking functions: 1. Exact match (or) Best match strategy 2. Next nearest match 
Inline Function: Inline functions are functions where the call is made to inline functions, the actual code then gets placed 
in the calling program. 
What happens when an inline function is written? 
 The inline function takes the format as a normal function but when it is compiled it is compiled as inline code. The 
function is placed separately as inline function, thus adding readability to the source program. When the program is 
compiled, the code present in function body is replaced in the place of function call. 
General Format of inline Function: 
The general format of inline function is as follows: 
inline datatype function_name(arguments) 
 

CHAPTER 5. ARRAYS 
An array is a collection of variables of the same type that are referenced by a common name. 
Types: One-dimensional : comprising of finite homogenous elements 
 Multi-dimensional: comprising of elements, each of which is itself a one-dimensional array 
Syntax: data type   array identifier[ size ] ; 
SOME STRING FUNCTIONS:  
1. gets( ): syntax: gets(char array identifier) or gets(char *) 
2. getline( ): syntax: cin.getline(char * , no.of characters, delimiter); 
3. strlen(s1); - Returns the length of string s1. 
4. strcpy( s1,s2) - Copies string s2 into string s1.,  
5.strcmp(s1, s2); - Returns 0 if s1 and s2 are the same; less than 0 if s1<s2; greater than 0 if s1>s2. 
One Dimension array  

An array is a continuous memory location holding similar type of data in single row or single column 
Two dimensional array 

A two dimensional array is a continuous memory location holding similar type of data in of both rows and columns 
(like a matrix structure). 

Array of strings: Array of strings in C++ is used to store a null terminated string which is a character array. This type of 
array has a string with a null character at the end of the string. Usually array of strings are declared one character long to 
accomodate the null character.  eg: char greeting[6] = {'H', 'e', 'l', 'l', 'o', '\0'}; 
 

CHAPTER 6. CLASSES AND OBJECTS 
A class is a new way of creating and implementing a user defined data type. A class is a way to bind the data and its 
associated functions together. 
Class specifications: i. Class declaration ii. Class function definitions 
Syntax for Class declaration:   example: 
class class-name    class student 
{      { 
private:      private: 
 variable declaration   char name[10]; 
 function declaration   int rollno,mark1, mark2, total; 
protected:     protected: 
 variable declaration   void accept( ); void compute( ); 
 function declaration   void display( ); 
public:      public: 
 variable declaration   student( ); 
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 function declaration   void execute( ); 
};      }; 
 
Accessing class members:  The members of a class are accessed using the dot operator. 
Ex: stud.execute( ) 
Array of objects: Arrays of variables of type "class" is known as "Array of objects". The "identifier" used to refer the array 
of objects is an user defined data type. Eg: stud p[3]; stud – class name, p[3] – ‘p’ object name with array index 3, which 
contains 3 objects p[0], p[1], p[2]. 
 

CHAPTER 7. POLYMORPHISM 
(Poly – many,  morph – shapes). Polymorphism is achieved through function overloading.  The ability of a function to 
process the message or data in more than one form is called as function overloading.  Functions are invoked by the 
compiler through Best match strategy and the next nearest match strategy.  
Ex: float area(float radius) 
 float area(float half, float base, float height) 
 float area(float length, float breadth) 
Operator overloading: The term operator overloading refers to giving additional functionality to the normal C++ operators 
like +,-,*,/ etc. EG: a+=b, a -=b 
Function overloading: Processing of two or more functions having same name but different list of parameters 

 
CHAPTER 8. CONSTRUCTORS AND DESTRUCTORS 

Constructor: When an instance of a class comes into scope, a special function called constructor gets executed.  The 
constructor function initializes the class object. Ex: simple( ) 
TYPES:,  
1. default constructor (or)non-parameterized constructor: is a constructor that either has no parameters, or if it has 
parameters, all the parameters have default values. If no user-defined constructor exists for a class and one is needed, the 
compiler implicitly declares a default parameterless constructor . Eg: add() 
2. parameterized constructor: It is special member function of the class.Which constructor has arguments thats 
called Parameterized Constructor. Eg: add(int a, int b) 
3. Copy constructor: The copy constructor is a constructor which creates an object by initializing it with an object of the 
same class, which has been created previously. The copy constructor is used to: Initialize one object from another of the 
same type. Eg: add(&a) 
Destructor:  When a class object goes out of scope, a special function called the destructor gets executed.  A destructor is a 
function that removes the memory of an object which was allocated by the constructor at the time of creating an object.  
The constructor and destructor have the same function name but the destructor is prefixed with a ~ (tilde) symbol. 
Ex: ~simple( ) 

 
CHAPTER 9. INHERITANCE 

It is the most powerful feature of an object oriented programming language.  It is a process of creating new classes called 
derived classes, from the existing or base classes. 
Advantages: Reusability of code, code sharing, consistency of interface. 
Derived class syntax: class der_name : visibility mode base class-id 
           { 
   Data members of the derived_class 
   Functions members of derived_class 
           } 
Inheritance types:  
1. single inheritance – has one base class 
2. multiple inheritance – has two base classes 
3. multilevel inheritance – has a base class and the derived class itself behaves as a base class. (Further classes can be 
derived from derived class.) 
 

 
STAROFFICE 
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Chapter - 1 
1. New document: File→New→Text Document 
2. To save: File→Save / Ctrl+S /F2 
3. To close: File→Close 
4. To open: File→Open 
5. To (Move text)/Cut/Paste: Edit→Cut(Ctrl+x), Edit→Paste (Ctrl+v) 
6. To Copy text: Edit→Copy(Ctrl+c), Edit→Paste(Ctrl+v) 
7. Find & Replace: Edit→Find & Replace (F5) 

Chapter – 2  
 

8. Formatting options: Format→Character (for font face, font size, Highlighting) 
9. Bold: Ctrl+B, Italic: Ctrl+I, Underline: Ctrl+U 
10. Alignment: centre: Ctrl + E, left: Ctrl + L, Right: Ctrl + R, Justify: Ctrl + J 
11. To undo the change: UNDO button / Edit→Undo 
12. Indents & Spacing/Line spacing: Format→Paragraph/ Format→Paragraph →Indents& Spacing 
13. Bullets or Numbers: Format→Bullets and Numbering 
14. Staroffice help: F1 
15. Extended Tip: Shift + F1 

Chapter – 3 CORRECTING SPELLINGS 
 

16. Spell Check command: Tools→Spelling→Check / F7 
17. AutoCorrect Entry: Tools→AutoCorrect 

 
Chapter – 4 WORKING WITH TABLES 

 
18. To create a simple, default-style table: Table→Insert→Table 
19. Floating tool bar: View→Insert 
20. To move forward in the cells: Tab 
21. To move backwards in the cells: Shift + Tab 
22. To add rows: Table→Insert→Rows 
23. To add columns: Table→Insert→Columns 
24. To delete rows: Table→Delete→Rows 
25. To delete columns: Table→Delete→Columns 
26. To delete entire table: Delete 
27. To select entire table: Edit→Select→All 
28. To delete the selected table: Table→Delete→Table 
29. To get Table format dialog box: Table→Table Properties 
30. To resize the column without changing the width of the table:  Alt + Ctrl and left or right arrows 
31. To make all columns even (same size): Column→Space Equally 
32. To make all rows even (same size): Row→Space Equally 

 
CHAPTER – 5 PAGE FORMATTING 

 
1. To open page style for all formatting dialog box: Format→Page then select Page tab. 
2. To see the changes made: File→Page Preview 
3. To see margins and to enable ruler: View→Ruler 
4. To change the page orientation: Format→Page, click Page tab, Orientation→Portrait or Landscape 
5. To create header/footer: Format→Page, clickHeader→ Header on/click Footer→ Footer on 
6. To insert text/page number in header/footer area: Insert→Fields→Page number 

 
CHAPTER – 6 SPREADSHEET 

1. To enter data in the cell: F2 
2. To copy contents of a cell to another: Edit→ Fill→ Down(or Left) 
3. Fill command to generate a series of data directly from the values of the selected cells: Edit→Fill→Series 
4. To change the column width: Format→Column→Width 
5. To open Insert cell floating tool bar: View→Toolbar→Insert Cell 
6. To delete the contents of a cell: Edit→Delete contents, click on Delete all 
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7. To delete an entire row/column:Edit→Delete Cells it opens a dialog box choose: Delete entire Row(s) or 
Delete entire column(s) 
8. To insert picture: Insert→Picture→From File 
9. To insert special character: Insert→Special characters 
10. For drawing shapes like lines, circles, square…: select Show Draw Functions icon from Standard 
Toolbar, then Draw Functions bar appears. 
11. To insert objects: View→Toolbar→insert object 
12. To insert charts: Insert→Chart      otherwise click Insert Chart icon. 
13. To print the selected range: Format→Print Ranges→Edit 
14. To remove the print range: Format→Print Ranges→Delete 
15. The Selection option allows to print only the selected area  

 
CHAPTER – 7 (Database) 

 
1. To open new database: File→New→Database 
2. To create new table: <Database> pane → Table icon, Tasks pane→ ‘Create Table in Design view’ or 
Insert→Table Design 
3. Editing a record: Right click on the record pointer of the selected record, from the menu, choose Delete 
Rows to delete a record, Row height to adjust the row height, Table format to set properties for the contents 
entered in the table. 
4. To create a query, right click on Queries in the <Database> pane. On the Tasks pane, choose ‘Use wizard 
to Create Query’ 
5. To create a form: Select Form icon from the <Database> pane and then select ‘Use Wizard to Create Form’ 
6. To create a report : right click on Reports in the <Database> pane. Then click ‘Use Wizard to Create Report’ 
7. To insert a Calc cell range into a writer document:Edit→ Copy, in the text document, choose Edit→Paste 
special, in the Paste Special dialog, select DDE link, then click ok. 
8. To insert a Text Outline into a presentation: File→Send→outline to presentation 
9. To transfer each heading together with its accompanying paragraphs, select File→Send→AutoAbstract to 
Presentation 

Chapter – 9 (Presentation) 
 

1. To create a new Impress presentation: File→New→Presentations 
2. To create a new presentation using a template: File→New→Templates and Documents (or)Shift+Ctrl+N 
3. To start a presentation: Click SlideShow icon on Presentation toolbar (or) F5 (or) choose Slide Show→Slide 
Show 
4. To adjust Presentation settings: Slide Show→Slide Show Settings 
5. To run a custom slide show in the defined order: Slide show→Custom Slide Show 
6. To insert a slide: Click slide button in the presentation toolbar (or) Insert→Slide 
7. To delete a slide: Select the slide, press Delete key (or) right click and choose Delete Slide 
8. To rename a slide: select slide, right click, choose Rename Slide (or) Slide→Rename Slide 
9. To change the slide order, click slide sorter from Switching Presentation view tab 
10. To insert a picture in a slide: Insert→Picture→From File 
11. To insert a Movie in a slide: Insert→Movie and Sound (or) click Insert Movie and Sound icon from the 
Insert toolbar. 
12. To open Media Player Window: Tools→Media Player 
13. To apply the selected movie or video file into your presentation: click Apply icon 
14. To start a slide show: Slide show→Slide show (or) press F5 key 
15. To insert objects like chart, formulas: Insert→Object 
16. To insert MS Word Document into a presentation: Choose Insert OLE Object dialog box→Further 
objects→Create New→Ok, in Insert Object dialog box, select Microsoft Word Document as object type and 
click Ok. 
17. To assign slide transition effects to slides: View→Toolbars→Slide View 
18. To apply effects for objects: Normal View(View→Normal View), choose Custom Animation from Slide 
Show→Custom Animation, Click Add in Modify Effect 
19. To change slide background: Format→Page→Background 
20. To apply a new slide design: Format→Slide Design, to apply design for all slides: Choose all slides and 
select Exchange background page check box, to apply design to the current slide: Clear the Exchange 
background page check box 
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21. To activate the outline view mode: View→Outline view 
22. To open the stylist: Format→Styles and formatting (or) press F11 key 
23. To create a custom slide show: Slide show→custom slide shows→New 
24. To change the order of the slides: drag & drop the slides under Selected Slides 
25. To start a custom slide show: Slide Show→Custom Slide Show 
26. To start a slide show from the current slide: Tools→Options→StarOffice Impress→General 
27. To hide a slide: Slide Show→Show/Hide Slide 
28. To show a hidden slide: Slide Show→Show/Hide Slide 
29. To record a show with rehearse timings: Open presentation, switch to Normal view, Slide show→Rehearse 
Timings 
30. To auto-repeat the whole presentation: Slide Show→Slide show settings→Auto→Ok 
31. To set default printing options for staroffice impress: Tools→Options→Staroffice impress→Print 
32. To print a range of slides: File→Print→Print Range→pages 
33. To print the current document: Function Bar→Print File Directly 
34. To print a slide to fit a paper size: Format→Page, Page tab, Layout Settings→Fit object to paper format 
check box→Ok 
35. To create and print handouts: View bar→Handout View, Tasks Pane→Layout Pane, File→Print 
36. To organize and print notes: View bar→Notes view(enter notes), File→Print→printer options→contents 
area→notes→ok 
37. Specific settings for all presentations: Tools→Options→Staroffice impress→Print 
38. To move from slide to slide using navigator: Edit→Navigator 
39. To export presentations: File→Export, select file format as HTML, enter a file name, click save. 
40. To apply the colours supported by browsers: select Use browser colors 
 

**************** 
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