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MARCH - 2017

[Time Allowed : 3 hours] COMPUTER SCIENCE with Answers [Maximum Marks : 150]

[1]

12th

STD.

PART-I
Choose the most suitable answer from the 
given four alternatives and write the option 
code and the corresponding answer.

[75 × 1 = 75]

1.	 Which	is	embedded	in	StarOffice	Impress	to	
support	different	audio	and	video	file	formats?
a) Media player b) Outline
c) Hatching  d) Gradient

2.	 In	Presentation	window,	how	many	tabs	are	
there	in	the	center	pane?
a) Four b) Six
c) Three d) Five

3.	 	In	Database	Table,	each	column	represents:
a) Row   b) Field
c) Table   d) Record

4.	 In	StarOffice	Base,	which	command	is	used	
to	insert	a	text	outline	into	a	presentation?
a) File → Outline to presentation
b) File → Send → Outline	to	Presentation
c) Format→ Outline	to	Presentation
d) Format → Send → Outline	to	Presentation

5.	 If	 a	=	5,	b	=	4	 and	c	=	6,	 the	value	of	 the	
expression	a	=	a+	b	/	2*c;	is:
a)	 16	 b)	 17
c)	 42	 d)	 60

6.	 Which	 function	 inserts	 the	 function's	 code	
directly	into	the	calling	program?
a) void b) main
c) return d) inline

7.	 In	which	 year	 the	Real	Audio/Real	Video	
format	was	developed?
a) 1995   b) 1982
c) 1992   d) 1985

8. In	the	early	programming	languages,	the	input	
and	output	data	items	were	represented	as:
a) data   b) object
c) variables  d) class

9.	 In	 StarOffice	Writer,	which	 dialog	 box	 is	
opened when we select Format →	 Page	
command?

a)	 Header	 b)	 Page	Style
c) Format d) Footer

10.	Program	 statements	 that	 cause	 a	 jump	 of	
control from one part of a program to another 
are	called:
a) Input   b) Output
c) Control Structures d) Assignment

11.	CBT	-	stands	for	:

a)	 Computer	Based	Tools
b)	 Computer	Based	Technique
c)	 Computer	Based	Tutorials
d)	 Common	Based	Tutorials

12. Files in the QuickTime format have the 
extension:	

a) .snd b) .mov c) .swf d) .wmf
13.	In	 StarOffice	Calc,	which	 one	 is	 the	most	

commonly	used	function?

a)	 SQR	 b)	 AVG
c)	 SUM	 d)	 POW

14. Which one of the following is not a multimedia 
content	development	software?

a) Flash   b) Maya
c)	 Notepad	 	 d)	 DreamWeaver
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15. The class from which the other classes are 
derived	is	called	:
a)	 Base	class		 b)	 Object	class
c)	 Derived	class	 d)	 Function	class

16.	In	StarOffice	Writer,	which	key	combination	
is	used	to	center	align	paragraph	?
a)	 Ctrl	+	C	 	 b)	 Ctrl	+	A
c)	 Ctrl	+	E		 	 d)	 Ctrl	+	L

17.	In	C++,	data	members	are	also	called	:

a) member functions b) attributes

c) methods  d) objects

18.	In	 StarOffice	 Calc,	 which	 bar	 is	 used	 to	
display	the	current	cell	and	its	contents?

a) Object bar

b) Status bar

c) Scroll bar

d) Formula bar
19.	Which	key	is	used	to	start	presentation?

a) F2 b) F11

c)	 F5	 d)	 F7
20.	Which	is	a	repository	of	collections	of	related	

data	or	facts?
a)	 Field	 	 	 b)	 Database
c)	 Record		 	 d)	 Editing

21.	Which	 is	 a	 key	 that	 uniquely	 identifies	 a	
record	in	a	database	table	?

a)	 Primary	 b)	 Network

c)	 Flat-File	 d)	 Hierarchical

22. The mechanism by which the data and 
functions are bound together within an object 
definition	is	called	as:

a)	 Polymorphism	 b)	 Object

c)	 Class	 d)	 Encapsulation

23. Which one of the following is a sound editing 
program	?	

a)	 JPEG	 b)	 Vector		Graphics

c) Modeling d) Sound Forge
24.	In	C++,	the	range	of	int	data	type	is	:

a)	 –	32678	to	32767	

b)	 –	32678	to	32768

c)	 –	32767	to	32767

d)	 –	32768	to	32767
25.	In	C++,	the	size	of	the	array	should	always	be	:

a)	 Date	 b)	 Positive

c) Negative d) Float
26.	The	name	of	the	constructor	must	be	same	as	

that	of	what	?

a) object   b) function

c) class   d) method
27.	In	C++,	which	of	the	following	is	not	a	class	

access	specifier?

a) public b) private

c) pointer d) protected

28.	In	StarOffice	Writer,	which	 key	 is	 used	 to	
move	forward	through	the	cells	in	the	table	?
a) Shift   b) Ctrl
c)	 Alt	 	 	 d)	 Tab

29. Which keys are pressed to move the insertion 
point	to	the	end	of	a	document	?

a)	 Ctrl	+	Home	 b)	 Ctrl	+	End

c)	 Shift	+	Home	 d)	 Shift	+	End
30.	In	C++,	which	is	achieved	through	function	

overloading	and	operator	overloading	?

a)	 Encapsulation	 b)	 Polymorphism

c)	 Function	 d)	 Inheritance
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31.	How	many	destructor	can	be	given	in	a	class?

a) 1 (one) b) 2 (two)

c) 3 (three) d) 4 (four)
32.	In	StarOffice	Calc,	which	one	of	the	following	

sign	 is	 used	 to	make	 the	 cell,	 absolute	 cell	
address	?

a) $ b) #

c) ! d) &
33. The command to insert a range of Calc Cells 

into	a	text	document	:

a)	 Edit	→ Cut

b) Format → Paste

c)	 Edit	→ Paste	Special

d)	 Edit	→ Copy
34.	void	add	:	:	display(	)	in	this	example	what	is	

the	name	of	the	class	?
a) void 
b) add
c)	 add	:	:	display(	)	
d) display( )

35.	Which	is	the	inequality	operator	in	StarOffice	
Calc?
a) ! b) < >
c)	 =	=	 d)	 #

36.	How	many	times	the	loop	will	be	executed	?
for	(m	=	0;	m<6;	m++)
a)	 6	 	 	 b)	 7	
c) 5   d) 4

37.	In	the	following	snippet	what	is	the	scope	of	
the	variable	'a'?

 if (x>y)
{
	 int	a	=	x;
	 a++;
 }

a)	 file	 b)	 function
c) local d) class

38. Which permits banking from the comfort of the 
home	by	using	internet	facility	?
a) Call center
b)	 e-Learning
c)	 e-Shopping
d)	 e-Banking

39.	In	StarOffice	Writer,	which	command	is	used	
to	insert	more	than	one	row	in	a	table?
a)	 Insert	→ Table → Rows
b) Table → Insert	→ Rows
c) Table → Rows →	Insert
d) Format → Rows

40.	In	StarOffice	Writer,	which	of	the	following	
is	the	decorative	font?

a) Times New Roman

b) Symbol

c) Wingdings
d) Fajita

41.	In	StarOffice	Writer,	which	key	is	pressed	to	
select	the	spelling	check	dialog	box	?

a)	 F7	 b)	 F6
c) F5 d) F4

42.	In	C++,	the	function	that	returns	no	value	is	
declared	as	:

a) void b) int c) inline d) main

43.	A	filter	is	also	a	type	of	:

a) Table b) Query

c) Form d) Report
44.	In	C++,	which	one	 of	 the	 following	 is	 the	

extraction	or	get	from	operator	?

a) <   b) >

c) <<   d) >>
45.	GIF	is	limited	to	how	many	bit	palette	?

	 a)	 16	 	 b)	 256

 c) 8  d) 32
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46.	BPO	-	stands	for	:

a)	 Business	Processing	Outlet

b)	 Business	Process	Outsourcing

c)	 Business	Process	Output

d)	 Basic	Process	Outsourcing
47.	Which	is	used	to	create	presentation	?

a) StarOffice	Writer

b) StarOffice	Calc

c) StarOffice	Impress

d) StarOffice	Base
48.	In	C++,	each	overloaded	function	must	differ	

either by the number or their datatype of 
which	parameters	?

a) actual   b) default

c) reference  d) formal
49.	In	C++,	integral	promotions	are	purely	what	

oriented	?	
a)	 source	code	 b)	 object	file
c)	 executable	file	 d)	 compiler

50.	Which	key	combination	is	used	to	save	a	table	
in	database	?

a)	 Ctrl	+	N	 b)	 Ctrl	+	A
c)	 Ctrl	+	S	 d)	 Ctrl	+	F

51.	The	default	top,	bottom	margins	in	a	document	
should be _________ inches.

a) 1.25 b) 1
c) 2 d) 2.25

52. Which key combinations is used to print slides 
in	StarOffice	Impress	?

a)	 Alt	+	P	 b)	 Shift	+	P
c)	 Ctrl	+	P	 d)		 Ctrl	+	Shift	+	P

53. Which	of	the	following	is	a	default	constructor?

a) add(add & x) b) add( )
c)	 add(int	x)	 d)	 add(int	x,	int	y)

54.	The	most	important	feature	of	C++	is	the	:

a) class b) pointer
c) variable d) structure

55. How many main steps are there in medical 
transcription	?

a) three   b) two
c)	 four	 	 	 d)	 five

56.	Which	is	a	self-replicating	program	that	can	
cause	damage	to	data	and	files	stored	on	the	
computer	?

a)	 Antivirus	 	 b)	 Cracking
c)	 Piracy	 	 d)	 Virus

57.	In	C++,	what	will	be	the	size	of	the	array	?
float	y[6][4];

a) 24 bytes b) 48 bytes
c)	 10	bytes	 d)	 96	bytes

58.	In	 C++,	which	 is	 a	 variable	 that	 holds	 a	
memory	address	?

a) pointer  b) constant
c) control structure d) loop

59.	In	C++,	the	array	belongs	to	which	data	type	?
a)	 derived		 	 b)	 user	defined
c)	 built-in		 	 d)	 structure

60.	Data	abstraction	is	achieved	through	:

a)	 Polymorphism	 b)	 Inheritance
c)	 Data	Hiding	 d)	 Array

61.	Which view allows the user to create and edit 
slides	?
a) Normal view b) Outline view
c) Notes view d) Handouts view

62.	In	StarOffice	Base,	which	 is	 a	 process	 of	
joining data from two or more tables of the 
same	or	different	database	?

a) Searching b) Sorting
c) Merging d) Filtering
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63.	The	body	of	a	class	is	terminated	by	:

a)	 ,	(comma)		 b)	 :	(colon)
c)	 .	(dot)	 	 	 d)	 ;	(semicolon)

64.	Which	character	prefix	the	destructor	name	
in	C++	?	

a) ~ (tilde)	 	 b	)	+	(plus)
c)	 ++	(increment)	 d)	 !	(NOT)

65.	In	StarOffice	Calc,	which	is	used	to	make	data	
easier	to	understand	?
a) formula  b) functions
c) object   d) charts

66.	In	 StarOffice	 Calc,	 which	 icon	 used	 to	
insert objects from other applications into a 
worksheet	?
a)	 Insert	OLE	object
b)	 Insert	Applet
c)	 Insert	Floating	Frame
d)	 Insert	Movie	and	Sound

67.	Access	specifier	is	also	referred	to	as	:
a) class member b) scope
c) inheritance d) visibility mode

68.	In	C++,	which	are	the	data	items	whose	values	
cannot	be	changed	?
a) constants b) punctuators
c)	 Keywords	 d)	 Identifiers

69.	In	 C++,	which	 statement	 forces	 the	 next	
iteration	of	 the	loop	to	take	place,	skipping	
any	code	that	follows	it	?
a) continue b) break
c)	 return	 d)	 size	of

70.	In	C++,	which	 of	 the	 following	 is	 a	 scope	
resolution	operator	?

a)	 :	 b)	 &
c)	 *	 d)	 :	:

71.	Visicalc	was	developed	in	the	year	:

 a) 1982 b) 1999
	 c)	 1979	 d)	 1959

72.	Which	one	of	the	following	is	simply	a	screen	
that	displays	 the	fields	of	a	 record	 in	a	well-
spaced	out	manner	?
a) Query b) Report
c) Filter d) Form

73.	What	is	the	error	thrown	by	the	compiler	for	
the	following	snippet	?

if	(a<b);
cout<<"Greater";
else
cout<<"Smaller";
a) misplaced if  b) misplaced else
c) misplaced if else d) statement missing

74.	When	a	derived	class	inherits	only	from	one	
base	class,	it	is	known	as	:	

a)	 Multiple	Inheritance	
b)	 Single	Inheritance
c)	 Hybrid	Inheritance
d)	 Multilevel	Inheritance

75.	Which	 is	 illegal	 access	 to	 the	 network	 or	
computer	system	?

a)	 Piracy
b)	 Virus
c) Cracking
d) Computer Crime

PART-II

Answer	any twenty 	questions	in	one or two 
sentences	each	:	 [20 × 2 = 40]

76.	What	is	meant	by	Word	Processing	?

77.	What	is	Hanging	Indent	?

78.	What	is	Date	Arithmetic	in	StarOffice	Calc?

79.	Write	 a	 note	 on	 reference	 operator	 in	
StarOffice	Calc.	Give	example.
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80.	What	are	the	three	general	categories	of	the	
data	management	task	?

81.	What	is	Report	?

82. Write about the types of video compressions.

83.	Write	a	note	on	AVI	format.

84.	How	will	you	change	the	slide	background	?

85.	What	is	Custom	Animation	?

86.	What	is	the	significance	of	an	object	?

87.	Write	note	on	impact	of	modifiers.

88.	What	are	tokens	?	What	are	its	types	?

89.	What	is	the	use	of	break	statement	?

90.	What	are	the	three	primary	sections	of	C++	?

91.	What	is	meant	by	return	statement	?

92.	What	is	an	Array	?	What	are	its	types	?

93.	What	is	the	use	of	strcmp(	)	function	?

94.	What	are	the	specifications	of	a	class	?

95. Write the general form of class declaration.

96.	How	 are	 functions	 invoked	 in	 function	
overloading	?

97.	What	are	the	functions	of	a	constructor	?

98.	What	are	the	advantages	of	Inheritance	?

99.	What	is	Call	Center	?

100.	What	is	Computer	Crime	?

PART-III

Answer	any seven questions.  [7 × 5 = 35]

101.	How	will	 you	 select	 the	 	 required	 portion	
of	 the	 text	 in	 a	 document	 using	mouse,	
keyboard	and	shortcuts	?

102.	What	are	the	various	functions	of	the	icons	
in	the	table	formatting	tool	bar	in	StarOffice	
Writer	?

103.	What	 are	 functions	 (in	StarOffice	Calc)	 ?	
How	will	you	use	them	in	the	worksheet	?	
Explain	with	an	example.

104.	Explain	the	various	icons	in	the	insert	object	
floating	tool	bar	of	StarOffice	Calc.

105.	Explain	the	different	types	of	Database.

106.	Explain	Exit-check	 loop	with	 syntax	 and	
example.

107.	Explain	 call	 by	 reference	method	 with	
suitable example.

108.	What	is	Operator	Overloading	?	List	its	rules.

109.	Debug	the	following	C++	program	to	get	the	
following	output	:

output	:	(Assume	a	=	15,	b	=	16)
--------------
 Simple Constructor
	 Enter	Values	for	a	and	b...15	16
	 The	two	integers...15	16
 The sum of the variables...31
	 Simple	Destructor

Program	:
--------------

# include <iostream. H>
# include < conio.h >
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class simple
{
	 Private:
	 	 int	a;	b;
	 Public
  simple( )
  {
	 	 a=b=0;
	 	 cout>>"Constructor	Simple";
  }
	 	 -simple(	)
  {
	 	 cout<<"\nSimple	Destructor";
	 	 };
	 	 void	getdata(	);
  {
	 	 	 cout<<"\nEnter	values	for	a	and	b...";
	 	 	 cin<<a>>b;
  }
  void putdata( )
  {
   cout<<"\n The  two  
	 	 integers..."<<a<<'t'<<b;
  c o u t > > " \ n T h e  S U M  o f 
variables..."<<a+b;
  }
	 };
void	main	[	]
{
	 simple	s;
 s.getdata ( )
	 s.Outdata	(	);
}

110.	Find	 the	 output	 for	 the	 following	 C++	
program.
#include<iostream. h>
#include<conio.h>
class	first

{

	 int	sum;

	 protected:

	 	 	 int	num1,	num2;

	 public:

	 first(	)

 {

	 num1=num2=sum=0;

	 cout<<"\n	First	Constructor";

 }

 void accept( )

 {

	 	 cout<<"\nEnter	the	two	numbers";

	 	 cin>>num1>>num2;

 }

 void plus( )

 {

	 	 sum	=	num1	+	num	2;

   cout<<"\n The sum of two numbers 
are..."<<sum;

  }

	 };

	 class	second	:	public	first

  {

	 	 	 int	sub;
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	 	 	 public:

   second( )

   {

	 	 	 		 sub	=	0;

	 	 	 	 cout<<"\n	Second	Constructor";

   }

void minus( )

{

	 first:	:accept(	);

	 sub=num1-num2;
 cout<<"\n The difference of two numbers 
are"<<sub;
   }
};
void main( )

{
	 second	s;
	 int	choice	=	0;
	 cout<<"\n	Enter	your	choice-(1	or	2)";
	 cout<<"\n	1.	Add...	\n	2.	Subtract...";
	 cin>>choice;
 switch(choice)
 {
	 case	1:
	 	 s.accept(	);
	 	 s.plus(	);
	 	 break;
	 case	2:
	 	 s.minus(	);
	 	 break;
  }

}

]]]]
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Part -II
76. The term word processing refers to the activity carried out using a computer and suitable software 

to	create,	view,	edit,	manipulate,	transmit,	store,	retrieve	and	print	documents.	A	document	may	
contain	text,	tables,	graphs,	charts,	equations,	pictures	and	drawings.

77. This visual clue helps the reader to see how the document is divided into paragraphs. The 
paragraphs	also	 indented	 	such	as	quotations	 that	are	set	apart	 from	the	main	document	 text.	
As	another	option,	one	may	want	to	use	a	special	kind	of	indent,	called	a	hanging indent,	for	
numbered lists.

78. Manual data calculations can be tricky because we have to keep track of the number of days in 
a	month.	In	spreadsheets,	date	calculations	become	very	simple.	To	add	a	number	to	a	date	and	
arrive	at	a	new	data,	find	the	difference	between	two	dates	one	can	use	a	wide	variety	of	function	
and formats. 

79. The operators which combine cell areas are called Reference operators.

Operator Name Example
:	(Colon)
!	(Exclamation	point

Range 
Intersection

A1	:	C108
SUM(A1	:	B6!B5	:	C12)

80. The	categories	of	the	data	management	task	in	DBMS	are	:
	 1.	Entering	data	into	the	database.
 2. Reordering records in the database.
 3. Obtaining subsets of the data.

Answers

PART - I

 1. (a); 2. (d); 3. (b); 4. (b); 5. (b); 6. (d); 7. (a); 8. (c); 9. (b); 10.   (c); 

 11. (c); 12. (b); 13. (c); 14. (c); 15. (a); 16. (c); 17 . (b); 18. (d); 19. (c); 20.   (b); 

 21. (a); 22. (d); 23. (d); 24. (d); 25. (b); 26. (c); 27. (c); 28. (d); 29. (a); 30.   (b); 

 31. (a); 32. (a); 33. (c); 34. (b); 35. (b); 36. (a); 37. (c); 38. (d); 39. (b); 40.   (d); 

 41. (a); 42. (a); 43. (b); 44. (d); 45. (c); 46. (b); 47. (c); 48. (d); 49. (d); 50.   (c); 

 51. (b); 52. (c); 53. (b); 54. (a); 55. (a); 56. (d); 57. (d); 58. (a); 59. (a); 60.   (c); 

 61. (a); 62. (c); 63. (d); 64. (a); 65. (d); 66. (a); 67. (d); 68. (a); 69. (a); 70.   (d); 

 71. (c); 72. (d); 73. (b); 74. (b); 75. (c).
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81. A	report	 is	printed	 information	based	on	a	
query	 that	 gathers	 criteria-matching	 data	
and,	in	some	cases,	performs	mathematical	
calculations.

82. The	two	types	of	video	compressions	are	:	
 (i)  Lossless compression : Retains the exact 

image throughout the compression. 
 (ii)  Lossy compression : 	 Provides	 a	

comparatively higher ratio of compression 
but	results	in	some	loss	of	quality.

83. The	Audio	Video	Interleave	or	AVI	format	
was developed	 by	Microsoft	 in	 1992.	 It	
is supported by all computers running the 
Windows operating systems and by most of 
the	popular	browsers.	It	 is	a	very	common	
format	on	the	Internet.	Videos	files	stored	in	
the	AVI	format	have	the	extension	.avi.

84. To change the background color or the 
background	fill	 of	 the	 current	 slide	 or	 all	
of the slides in the document the procedure 
followed	is	:	

 Choose Format → Page → Background. 
Select	the	background	fill	options	:	

 Color

 Gradient

 Hatching

	 Bitmap	Image

85. This page displays various options that allow 
the user to add or modify animation effects 
to elements of a slide.

86. An	object	is	a	group	of	related	functions	and	
data that serves those functions.

	 An	 object	 is	 a	 kind	 of	 self-sufficient	
‘subprogram’	with	a	specific	functional	area.

87.	 The	impact	of	modifiers.	

 (i)  unsigned modifies the range of the 
integer values as the sign bit is also used 
to store data. 

 (ii)  long increases the bytes for a particular 
data	 type,	 thus	 increasing	 the	 range	of	
values.

88. Tokens are the basic types of elements 
essential	for	program	coding.	It	is	the smallest 
individual unit in a program.

Tokens

Keywords         Identifiers          Constants          Operators         Punctuators

89. (i)	 	Break	statement	would	exit	the	current	
loop only. 

 (ii)	 	Break	statement	accomplishes	jump	from	
the current loop.

90. A C++	Program	has	primarily	three	sections	
Viz.,

 •	Include	files

	 •		Declaration	of	variables	,	data	type	,	user	
defined	functions.

	 •	main()	function

91. Return statement marks the end of the 
function and also transfers control to the 
statement after call statement.

92. An	array	is	a	collection	of	variables	of	the	
same type that are referenced by a common 
name.

	 The	two	types	of	array	are	:

 1)  One dimensional.  

	 2)	 	Multi-dimensional.	
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93. It	compares	the	two	given	strings	and	
returns	0	it	strings	are	equal,	value>0,	if	
string 1 is greater than string 2. Otherwise 
value	less	than	0.	For	example,	strcmp	
(“Abc”,	“Abc”)	returns	Ostcmp	(“Abc”,	
“abc”)	returns	a	value	less	than	ostrcmp.

94. A	class	specification	has	two	parts.	They	are	

 (i)	 Class	declaration,

 (ii)	 Class	function	definitions.

95. Class	class-name

 {

	 private:

  variable declaration

  function declaration

	 protected:

  variable decl.

  function decl.

	 public:

  variable decl.

  function decl.

	 };

96. The	compiler	adopts	BEST	MATCH	strategy.	
As	per	this	strategy,	the	compiler	will,		

 (i)	 	Look	for	the	exact	match	of	a	function	
prototype with that of a function call 
statement. 

 (ii)	 	In	case	an	exact	match	is	not	available,	
it looks for the next nearest match. That 
is,	 the	 compiler	will	 promote	 integral	
data promotions and then match the call 
statement will function prototype.

97.	 Functions	of	constructor	are:	

 (i) 		The	constructor	function	initializes	the	
class object. 

 (ii)   The memory space is allocated to an 
object.

98. The	advantages	of	Inheritance	are:

 (i)  Reusability of code. Many applications 
are	developed	in	an	organization.		

 (ii)  Code sharing. The method of the base 
class can be shared by the derived class. 

 (iii)  Consistency of interface. The inherited 
attributes and methods provide a similar 
interface to the calling methods.

99. A	 call	 center	 is	 sometimes	 defined	 as	 a	
telephone based shared service center for 
specific	customer	activities	and	are	used	for	
number	 of	 customer-related	 functions	 like	
marketing,	 selling,	 information	 transfer,	
advice,	 technical	support	and	so	on.	A	call	
center	has	adequate	telecom	facilities,	trained	
consultants,	access	to	wide	database,	Internet	
and	 other	 on-line	 information	 support	 to	
provide information and support services to 
customers.	It	operates	to	provide	round	the	
clock	 and	 year	 round	 service	 i.e.,	 24×365	
service.

100.  A	computer	crime	is	any	illegal	activity	using	
computer	 software,	 data	 or	 access	 as	 the	
object,	subject	or	instrument	of	the	crime.

Part -III

101. Steps to select the text with mouse :

	 1.		Insertion	point	is	moved	to	the	start	of	the	
text to be selected.

	 2.		The	left	mouse	button	should	be	clicked,	
held down and dragged across the text to 
be selected. 
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 3.  When the intended text is selected the 
mouse button should be released.

 Steps to select text with keyboard :

	 1.		Insertion	point	is	moved	to	the	start	of	the	
text to be selected.

 2.  The Shift key is pressed down and the 
movement keys are used to highlight the 
required	text.	

 3.  When the Shift key	is	released,	the	text	is	
selected. 

Action to be performed To select what
Double	click	on	a	word To select a word
Click once next to the 
line

To select the particular 
line

Press	Ctrl + A To select the entire 
document

102. The	function	of	each	icon	in	the	toolbar	are	:

  –  Table Fixed.

  –  Table Fixed, Proportional.

  –  Table Variable.

  –    Merge cells : This icon is used to 
combine two or more cells into a 
single cell.

  –    Split cells : This icons is used to 
split a cell into two or more cells.

  –    Optimise :  Clicking on this 
icon	displays	a	pop-up	menu	with	
options	like	Space	columns	equally,	
Space	 rows	 equally,	 Optimum	
row height and Optimum Column 
width.

  –   Inserting Row : This icon is used to 
insert a row below the current row.

  –    Inserting Column :  This icon 
inserts a column to the right of the 
current column.

  –    Delete Row :  This icon deletes the 
current row from the table.

  –    Delete Column :  This icon deletes 
the current column from the table.

  –    Borders :  This icon display a 
floating toolbar with different 
border option for the table.

  –    Line Style : This icon is used to 
choose the style of line to be used 
for the borders.

  –   Border Colour : Clicking on this 
icon displays a palette of colours 
that can be used as a border colour 
for the table.

103. StarOffice Calc has a wide variety of 
functions that allow you to perform several 
frequently	done	calculations.	Functions	are	
predefined	 formulae	 that	 are	 available	 in	
StarOffice	Calc.	

	 To	select	a	function,	go	to	Insert menu and 
Select the Function options. The Function 
Wizard	 dialog	 box	 appears.	A	 list	 of	 all	
functions is displayed in the Function box 
when All is selected in the Category box.	If	
a category is selected (e.g. Mathematical) the 
functions related to that category alone will 
be displayed in the function box. 

 To select a function.

 (i) Select the category in the Category box. 

 (ii)	 	Scroll	down	the	list	to	find	the	function	
you want. Click once on the function 
name to see a short description of that 
function on the right side of the window. 
Double-click	 on	 it	 to	 insert	 it	 into	 the	
worksheet. 
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 (fx) 	The	Function	Wizard	shortcut	icon	on	
the formula bar can also be used to select and 
insert functions. 

	 For	 example,	 to	 insert	 the	SQRT	 function	
place the cursor in the cell where the user 
want to insert the function and click on the 
Function Wizard icon. Select Mathematical 
from Category. Select the SQRT function 
from	the	list	of	functions,	which	appears	by	
double	clicking	on	it.	The	Function	Wizard	
displays a brief description of the function 
and prompts the user to enter the number or 
the cell address on which the function should 
work.	Enter	the	number	64.

	 Now	click	on	OK,	the	result	is	displayed	in	
the cell in the worksheet. 

 Σ  One of the most commonly used 
function is the Sum function. This function 
calculates the sum of a given set of numbers. 
To	use	 this	 function,	 in	 the	worksheet,	 to	
calculate	the	total	in	cell	G3,	the	steps	are:

 (i)  Click on the cell G3 to place the cursor 
there. 

 (ii)  Click on the Sum icon on the function 
bar.	=	SUM (C3:F3) appears in the cell. 

 (iii)		Press	Enter to accept the suggested 
range.

	 The	result,	is	displayed	in	the	cell	G3.

104. To get Insert Object	floating	 toolbar,	click	
on View →Toolbar →Insert Object option. 
It	displays	with	following	icons	:

 1. Insert chart icon : 

   This icon is used for presenting the data 
in the worksheet in the form of charts of 
different	kinds	such	as	bar	chart,	pie,	chart,	
lines,	X-Y	plot,	etc.		

 2. Insert Formula icon : 

   This icon is used for inserting a formula in 
the worksheet for performing calculations. 

 3. Insert Floating Frame icon : 

   This icon is used to generate a scrolling 
screen within a worksheet. 

 4. Insert Movie and Sound icon : 

   This icon is used to insert sound or video 
files	into	the	current	worksheet.	

 5. Insert OLE object icon : 

   This icon is used to insert objects from 
other application into a worksheet. 

	 6.	Insert Applet icon : 

	 	 	This	icon	is	used	to	import	Java	Applets	
into the worksheet.

105.	The	 classification	 of	Database	 based	 on	
conceptual	structures	are	:		

 (i)  Flat-File Database.	A	database	file	that	
consists	of	a	single	data	table	is	a	Flat-	
file	 database.	 Flat-file	 database	 can	be	
quite	 useful	 for	 certain	 single-user	 or	
small-group	 situations,	 especially	 for	
maintaining lists such as address lists or 
inventories.	Data	that	is	stored,	managed.	
and manipulated in spreadsheet is 
another	example	of	a	flat-file	database.		

 (ii)  Relational database.	A	 relational	
structure represents a database made up 
of	a	set	of	related	tables.	In	a	relational	
database,	 one	 or	more	 common	fields	
existing in two or more tables create a 
relationship between these tables. The 
common	field	 or	 fields	 are	 called	 the	
Keys.  
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	 A	primary key	is	a	key	that	uniquely	identifies	
a	 record	 in	 a	 database	 table.	 In	 relational	
database,	a	primary	key	can	consist	of	one	
of	more	fields.	

 The relational database structure is the 
most prevalent database in today’s business 
organizations.	

 (iii)  Hierarchical database. The hierarchical 
database structures were primarily used 
on	Main	Frame	computers.	In	hierarchical	
database,	records	are	organized	in	a	tree	
like structure by type. The relationship 
between record types is said to be a 
parent-child	 relationship,	 in	which	any	
child type relates only to a single parent 
types.

 (iv)  Network database. The Network 
database is very similar to the hierarchical 
structure except that any one record type 
can relate to any number of other record 
types. 

 (v)  Object Oriented database. The object 
oriented structure groups data items 
and	 their	 associated	 characteristics,	
attributes and procedures into complex 
items	 called	 objects.	 Physically	 and	
object	 can	 be	 anything:	 a	 product	 or	
event,	such	as	a	house,	an	appliance,	an	
art	piece,	a	customer	complaint,	or	even	
a	purchase.	An	object	 is	defined	as,	an	
art	piece,	a	customer	complaint,	or	even	
a	purchase.	An	object	 is	defined	by	 its	
characteristics,	attributes	and	procedures.	
An	objects	 characteristics	 can	 be	 text,	
sound,	graphics	and	video.	Examples	of	
attributes	might	 be	 colour,	 size,	 style,	
quantity	and	price.	A	procedure	refers	to	
the processing or handling that can be a 
associated to the object

106.  Do	...	while	<(condition)>	is	called	exit-check	
loop,	as	the	condition(test	expression)	marks	
the last statement of the body of the loop. 

 The construct of a do ... while loop is :

 do

 {

	 action	block	;

	 }	while	<(condition)>	;

Example :

#  include <iostream.h>

#  include <conio.h>

void main ( ) 

{

	 int	i	=	10;	choice	=	1	;	

 do

 {

	 	 	 cout	<<	i;

	 	 	 i	++;

 } 

	 getch(	);

}

 Output:

	 Infinite	loop	

107.In	 call	 by	 reference	method,	 the	 called	
function	 arguments-formal	 parameters	
become alias to the actual parameters in the 
calling function. This means that when the 
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function is working with its own arguments 
it	is	actually	working	on	the	original	data.	Let	
us now rewrite the function using reference 
parameters. 

# include <iostream.h>

# include <conio.h>

void	swap	(int	&n1,	int	&n2)

{

	 int	temp;

	 temp	=	n1;

	 n1	=	n2;

	 n2	=	temp;

 cout<<‘\n’<< n1

	 	 <<‘\t’<<n2<<‘\n’;

}

void main ( )

{

	 int	m1	=	10,	m2	=	20;

	 clrscr(	);

	 cout<<‘\nValues	before	swap	call”<<	‘\t’	
<<	m1	<<	‘\t\	<<	m2;

	 swap(m1,m2);

	 cout<<“\n	Calling	sawp..”;

	 cout<<“\n	Back	to	mai....	Values	are”

	 <<	‘\t’	<<	m1	<<	‘\t’<<	m2;

	 getch	(	);

 }

 Output :

	 Values	before	invoking	swap	 10	 20

	 Calling	swap	.....	 20	 10

	 Back	to	main......	Values	are	 20	 10

108. The mechanism of giving special meaning to 
an operator is called operator overloading.

 Rules for overloading operators:

 There are certain restrictions and limitations 
in	overloading	operators.	They	are:

 (i)   Only existing operators can be 
overloaded. New operators cannot be 
created.

 (ii)     The overloaded operator must have at 
least	one	operand	of	user	defined	type.

 (iii)   The basic definition of an operator 
cannot be replaced or in other words 
one cannot redefine the function of 
an operator. One can give additional 
functions to an operator

 (iv)    Overloaded operators behave in the 
same way as the basic operators in 
terms of their operands.

 (v)				 	When	binary	operators	are	overloaded,	
the left hand object must be an object 
of the relevant class

 (vi)				Binary	 operators	 overloaded	 through	
a member function take one explicit 
argument.
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109.   Line No Error Code Correct Code
1 #include<iostream.H> #include<iostream.h>
2 Private: private:
3 int	a;b; int	a,b
4 Public public:
5 cout>>”Constructor	Simple”; cout<<”	Simple	Constructor”;
6 -simple() ~simple()
7 void	getdata()	; void getdata()
8 cin<<a>>b; cin>>a>>b;
9 cout<<”\nThe	two	

integers...”<<a<<’\t’<<b;
cout<<”\nThe	two	
integers...”	<<a<<”\t”<<b;

10 cout>>”\nThe	SUM	of	
variales...”<<a+b;

cout<<”\nThe	SUM	
of	variales...”<<a+b;

11 void	main[	]  void main ()
12 s.getdata() s.getdata()	;
13 s.Outdata(); s.putdata();

110.   Out put

No (if choice=1) (if choice=2)
1 First Constructor 

Second Constructor 
Enter	your	choice-(1	or	2)	
1.Add...	
2.Subtract...1 
Enter	the	two	numbers	10	5	
The Sum of two numbers are...15

First Constructor 
Second Constructor 
Enter	your	choice-(1	or	2)	
1.Add...	
2.Subtract...2 
Enter	the	two	numbers	10	5	
The difference of two numbers are...5
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