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1 A 26 D 51 C 

2 C 27 D 52 D 

3 C 28 C 53 B 

4 A 29 B 54 D 

5 B 30 B 55 B 

6 A 31 C 56 A 

7 B 32 C 57 D 

8 C 33 B 58 C 

9 D 34 C 59 D 

10 A 35 D 60 A 

11 D 36 D 61 A 

12 C 37 A 62 B 

13 A 38 B 63 A 

14 D 39 C 64 C 

15 C 40 D 65 D 

16 A 41 D 66 C 

17 B 42 A 67 C 

18 A 43 B 68 B 

19 D 44 C 69 D 

20 A 45 D 70 B 

21 A 46 C 71 A 

22 D 47 B 72 B 

23 A 48 A 73 C 

24 B 49 C 74 B 

25 A 50 B 75 D 
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PART – II 

76. You can switch over from insert mode to type over mode by pressing insert key. 

77. Portrait and Landscape 

 Length of the document is more than the width is portrait is default orientation 

 Width of the document is more than the length is called landscape 

78. Excel from Microsoft, Quatrapro from Borlaond International, Improve from Lotus  

      corporation,Star Calc from Sun microsystems. 

79. A continuous group of cells in a worksheet is called a Range. A range is referred to by the  

      range address. The cells A1, B1, C1, D1, E1 and F1 can be called A1:F1 and the cells A4,   

      A5, A6, B4, B5 and B6 can be referred to as A4:B6. 

80. A database is a repository of collections of related data or facts. It arranges them in a  

      specific structure. 

81. A report is printed information that is assembled by gathering data based on user supplied  

      criteria. 

82. Compression is a technique by which a recurring set of information is identified and  

       replaced by a single piece of information. There are two types of video compressions: 

Lossless compression – Retains the exact image throughout the compression. 

          Lossy compression – Provides a comparatively higher ratio of compression but results in 

                                             Some loss of quality. 

83.   1. Modeling 

        2. Animating 

        3. Rendering 

84.  To start a presentation, click the Slide Show icon on the Presentation Toolbar or  

        choose Slide Show Slide Show or press F5. 

85. To Insert a Picture in a slide, choose Insert Picture  From File or click the Insert  

       Picture icon from the Insert toolbar. 

86. The mechanism by which the data and functions are bound together within an object  

       definition is called as ENCAPSULATION. 

87. A ternary operator ( ?:) is also called as conditional operator. The general syntax is E1 ? E2 : 

      E3where E1,E2,E3 are operands. E1 should essentially be of scalar type, E2 and E3 are  

      values or statements. 

 Eg: max = (num1 > num2) ? num1 : num2; The variable max will take the value of num1  

      if num1 is greater than num2, otherwise max will be assigned with the value of num2. 
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88. Type cast refers to the process of changing the data type of the value stored in a variable .  

      The syntax is : (data type) <varaible/value> or data type (variable/constant) . 

       x = 8 % (int) 7.7. 

 

89. unsigned modifies the range of the integer values as the sign bit is also used to store data. 

       long increases the bytes for a particular data type, thus increasing the range of values. 

90.  

Break Statement Continue Statement 

It accomplishes a jump from 

current loop 

It forces the next iteration of the 

loop to take place 

 

91.  1. Number and type of arguments -(char name [ ] - is an argument) 

 2. The type of return values 

92.   Returns the number of characters stored in the array. 

 Syntax: strlen(char*) 

 Ex: strlen(name); 

93.   An array in C++ is a aderived data type that can hold several values of the same type. 

       An array is a collection of variables of the same type that are referenced by a common 

name. 

 One dimensional: comprising of finite homogenous elements 

Multi dimensional: comprising of elements, each of which is itself a one- dimensional 

array 

94.    A class is a new way of creating and implementing a user defined data type. 

        Class is a new way to bind the data and  its associated function together 

 1) Class declaration 

2) Class Function Definitions 

95.   Is initialized to zero, only when the first object of its class is created . No other 

initialization is  Permitted. 

       Only one copy of the member variable is created and is shared by all the other objects of 

its class type 

       Its scope or visibility is within the class but its lifetime is the lifetime of the program. 

96.   The compiler adopts BEST MATCH strategy. As per this strategy, the compiler will  

look for the exact match of a function prototype with that of a function call statement 

      In case an exact match is not available, it looks for the next nearest match. That is, the 

compiler  

      will promote integral data promotions and then match the call statement with function 

prototype. 

97.    1) The constructor function initializes the class object  

          2) The memory space is allocated to an object 
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98.   When a derived class inherits from multiple base classes it is known as multiple 

inheritance. 

 

99.     Hospital Management System 

·         Patient Tracking System 

 

100.   A virus is a self-replicating program that can cause damage to data and files stored on 

          your computer. 57000 known virus programs are in existence. 6 new viruses are found  

          each day. 

 

PART –III 

101. To save a document for a first time following steps are used: 

1. File →Save command is selected or save icon is clicked. 

2. To select a drive, up one level icon is clicked, then a list of drives will be displayed.  

On the list of drives, a double click is made on the required drive. Now a list of folders  

available on that drive is displayed. 

3. A double click is made on the required folder and the file name is given in the File  

name list  box. 

4. Choose the required document type from the Save as type list box and click on the 

 Save button to save the document in that type. The document is now saved and a file  

name appears  in the title bar. 

Once a file is saved under a name, to save it again the name need not be entered again. 

  file can be saved simply by selecting the File→Save command or by clicking the Save 

 button.  Ctrl + S is the keyboard shortcut for saving the document. 

 

102.   Tools  Spelling  Check is selected or is clicked. To check a part of the document  

 only that portion is selected. The F7 key may also be pressed to select the spelling  

 command. 

  Not in dictionary text area displays the misspelled word and the Suggestions list 

 Displays  any alternative spellings. 

Any of the following can be done: 

• To skip this occurrence but stop on the next one. Ignore Once button is clicked. To skip 

 All  occurrences of this word. Ignore All button is clicked. 

• To replace the word with one of the selected spellings, in the suggestions list that  

spelling is  clicked, and Change button is clicked to change this occurrence and Change 

 All button is clicked to replace all occurrences of the world. 

• If none of the replacements is correct, correction can be made manually in the Not in  

dictionary text area. Add button is clicked to add the word to the dictionary. 
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103.   Functions are predefined formulae that are available in StarOffice Calc. 

 To select a function, go to Insert menu and Select the Function option. 
 A list of all functions is displayed in the Function box when All is selected in the Category 

box. If a category is selected (e.g. Mathematical). 
The Function Wizard shortcut icon on the formula bar can also be used to select and insert  
functions. 
 
 
 
Select the SQRT function from the list of functions, which appears by double clicking on it. The 
 Function Wizard displays a brief description of the function and prompts you to enter the 
 number or the cell address on which the function should work. Enter the number 64. 
 
One of the most commonly used function is the Sum function. This function calculates the sum 
 of a given set of numbers. To use this function, you can either click on the Function Wizard 
 icon or then select SUM or you can just click on the Sum icon on the formula bar. 

 

104.    Insert Object from View →Toolbar. 
Insert Chart Icon 
 This icon is used for presenting the data in the worksheet in from of charts of 
 different kinds such as Bar Chart, Pie Chart, Lines, XY plot, etc. More details on charting are 
 given in a later section. 
• Insert Formula Icon 
 This icon is used for inserting a formula in the worksheet for performing calculations. 
• Insert Floating Frame Icon 
This icon provides to generate a scrolling screen within a worksheet. 
• Insert Movie and Sound Icon 
This icon is used to insert sound or video files into the current worksheet. 
• Insert OLE Object Icon 
This icon is used to insert objects from other application into a worksheet. 
• Insert Applet Icon 
This icon is used to import Applets written in Java programming language into the worksheet. 

 

105.  Flat – File Database 

A database file that consists of a single data table is a Flat-file database. Flat-file database  
can be quite useful for certain single user or small-group situations, especially for maintaining 
 lists such as address lists or inventories. 

 
 Relational database 

A primary key is a key that uniquely identifies a record in a database table. In relational  
databases, a primary key can consist of one or more fields. 
The relational database structure is the most prevalent database in today’s business  
organizations. 
Hierarchical database 
The hierarchical database structures were primarily used on Main Frame computers. In 
 hierarchical databases, records are organized in a tree like structure by type. The relationship 
 between record types is said to be a parent-child relationship, in which any child type relates 
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 only to a single parent type. 
 Network database 
The Network database is very similar to the hierarchical structure except that any one record 
 type can relate to any number of other record types. 
Object Oriented database 
An Object Oriented database is a newer structure that has been generating a great deal of  
interest in recent years. 
An object is defined by its characteristics,attributes and procedures. An object’s characteristics 
 can be text,sound, graphics, and video. Examples of attributes might be colour,size, style,  
quantity, and price. A procedure refers to the processing or handling that can be associated to 
 the object. 
 

 
106.   for (; ; ) .. loop : is an entry controlled loop and is used when an action is to be repeated for a  
 predetermined number of times. The syntax is  

for(intial value ; test-condition ; increment) 
{ 
action block; 
} 
The general working of for(;;)loop is : 
1. The control variable is initialized the first time when the control enters the loop for the first 

 time 
2. Test condition is evaluated. The body of the loop is executed only if the condition is TRUE. 

 Hence for(;;) loop is called as entry controlled loop. 
3. On repetition of the loop, the control variable is incremented and the test condition will be 

 evaluated before the body of the loop is executed. 
4. The loop is terminated when the test condition evaluates to false. 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int i,fact = 1; 

for(i = 1; i < 6; i++) 

fact *= i; 

cout << “\nThe factorial of the number is ..” << fact; 

} 

 

The factorial of the number is 120. 

 

107.    Scope refers to the accessibility of a variable. There are four types of scopes in C++.  
They are:1. Local scope 2. Function scope 3. File scope 4. Class scope 
Local Scope 
A local variable is defined within a block 

The scope of a local variable is the block in which it is defined. 

A local variable cannot be accessed from outside the block of its declaration. 
Function scope 
The scope of variables declared within a function is extended to the function block, and all sub- 
blocks therein. 
The life time of a function scope variable, is the life time of the function block. The scope of  
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formal parameters is function scope. 
File scope 
A variable declared above all blocks and functions (precisely above main ( ) ) has the scope of 
 a file. The scope of a file scopevariable is the entire program. The life time of a file scope  
 variable is the life time of a program. 
Class Scope 
A class is a new way of creating and implementing a user defined data type. Classes provide a 
 method for packing together data of different types. 
One Relevant Example 

108.    Only existing operators can be overloaded. New operators cannot be created. 

The overloaded operator must have at least one operand of user defined type. 
 The basic definition of an operator cannot be replaced or in other words one cannot redefine  
the function of an operator.One can give additional functions to an operator 
 Overloaded operators behave in the same way as the basic operators in terms of their 
operands. 
 When binary operators are overloaded, the left hand object must be an object of the relevant 
 class 
 Binary operators overloaded through a member function take one explicit argument. 

 
109. Debug  

  

Error 

No 

Error Code Correct Code 

1 $include #include 

2 Private: private : 

3 int a;b; int a,b; 

4 Public public: 

5 cout>> cout<< 

6 }; } 

7 void getdata( ); void getdata( ) 

8 cin<< cin>> 

9 cout>> cout<< 

10 void main[] void main( ) 

11 - getch( ) 

 

110. Output: 

 Add Constructor…. 

 Subtract Constructor…. 

 Enter your choice 

1. Add… 

2. Subtract… 

1 
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Enter the two numbers…. 

5 

6 

The sum of two numbers are…. 11 

 


