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3. BASIC STATEMENTS 

1. Explain switch statement with a suitable example? 

 It is a multiple branching statement where based on a condition 

 The control is transferred to one of the many possible points. 

Syntax: - 

switch(expression) 

{ 

case 1: action block1;  

break; 

case 2: action block2;  

break; 

case 3: action block3;  

break; 

default: action block;  

break; 

} 

Example: - 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int a, remainder; 

cout << “\n Enter a number ...”; 

cin >> a; 

remainder = a % 3; 

switch (remainder) 

{ 

case 1 : cout << “\n Remainder is one”; 

break; 
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case 2 : cout << “\n Remainder is two”; 

break; 

default: cout << “\n The given number is divisible by 3”; 

break; 

} 

getch();  

} 

The above program displays Or Output: 

 Remainder is two if a = 5 or so 

 The given number is divisble by 3, if a = 9 or so 

Or in other words the above program checks for divisibility by 3 and prints messages 

accordingly. 

2. Explain Entry-check loop with example?or  Explain while loop with example?  

 While loop is called as the entry-check loop. 

 The body of the while loop will be executed only if the condition is true. 

 The control exits the loop once the condition is evaluated to false. 

Syntax:- 

while (condition) 

{ 

action block 

} 

Example:- 

#include<iostream.h> 

#include<conio.h> 

Void main() 

{ 

clrscr(); 

int n=2; 

while(n<6) 
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{ 

cout<<n*n<<’\t’; 

n=n + 1; 

} 

getch(); 

} 

Working of loop:- 

 Initializes the control variable n=2 

 n<6 is evaluated, control is transferred to step 3, if the condition is TRUE 

 Print the square of the value stored in num 

 Increment n by 1 

 Control is transferred to step 2 

 End 

Output:- 

4  9  16  25 

 

 

3. Explain Exit-check loop with example? Explain do…while loop with example?  

 Do….while is called as exit-check loop. 

 The condition marks the last statement of the body of the loop. 

 

Syntax:- 

do 

{ 

action block; 

} while (condition); 

 

 

Example:- 



 www.padasalai.net 

 p.chandrasekaran    5 
 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

clrscr(); 

int n = 2; 

do 

{ 

cout << n * n << ‘\t’; 

n =n +  1; 

} 

while (n< 6); 

getch(); 

} 

 

Working of loop:- 

1. Initializes the control variable n=2 

2. n<6 is evaluated, control is transferred to step 3, if the condition is TRUE 

3. Print the square of the value stored in num 

4. Increment num by 1 

5. Control is transferred to step 2 

6. End 

Output:- 

4  9  16  25 

 

4. Explain Entry-controlled loop with example? Explain For loop with example?  

 for loop is an entry controlled loop 

 It is used when an action is to be repeated for a predetermined number of times. 

Syntax:- 
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for(initial value; test-condition; increment) 

{ 

action block; 

} 

Example:- 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int i,fact = 1; 

for(i = 1; i < 6; i++) 

fact *= i; 

cout << “\nThe factorial of the number is ..” << fact; 

} 

 

Working of loop:- 

 The control variable is initialized first. 

 Test condition is evaluated. 

 The body of the loop is executed only if the condition is true. 

 The control variable is incremented and the test condition will be evaluated before 

the body of the loop is executed. 

 The loop is terminated when the test condition is false 

 

Output: 

120 

 

 

 

5. Explain the ‘Nested.. if’ statement with an example in C++?  
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The statement sequence of if or else may contain another if statement 

ie., the if else statements can be nested within one another. 

Syntax:-  

if (expression -1) 

if (expression -2) 

{ 

 action -1; 

} 

else 

{ 

 action-2; 

} 

else 

{ 

 action-3; 

}; 

Example:- 

if (grade = = ‘A’) 

if (basic > 5500) 

incentive = basic * 10/100; 

else 

incentive = basic * 5/100; 

else 

cout << “Try to attain Grade A”; 

Working of the above example : 
 
 Grade = ‘A’ and basic == 5501, then incentive gets the value 550. 

 Grade = ‘A’ and basic = = 5000, then incentive gets the value 250. 
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6. What is if and  if…else Statement explain with an example?  

if statement :  

If is the simplest of all the decision statements. It is implemented in two forms 

 

 Simple if statement 

 if .. else statement 

 

Syntax : 

if (condition/expression) 

{ 

action block; 

} 

Example: 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int a; 

clrscr(); 

cout << “\nEnter a number “; 

cin >> a; 

if ( a%2 == 0) 

cout << “\n The given number “ << a << “is even”; 

getch(); 

} 

if .. else: 

if .. else…statement which chooses between two alternatives , executes the chosen 

block based on the condition. 

Syntax: 
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if (condition/expression) 

{ 

action block; 

} 

else 

if (condition/expression) 

{ 

action block; 

} 

Example: 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int a; 

clrscr(); 

cout << “\nEnter a number “; 

cin >> a; 

if ( a%2 == 0) 

cout << “\nThe given number “ << a << “is 

even”; 

else 

cout << “\nThe given number “ << a << “is 

odd”; 

getch(); 

} 

 

 

Output: 



 www.padasalai.net 

 p.chandrasekaran    10
 

 if a = 5  Remainder is two  

 if a = 4  Remainder is one 

 if a = 6  The given number is divisible by 3 

 

4. FUNCTIONS 

Explain call by value method with an example?  

Call By Value: 

In call by value method, any change in the formal parameter is not reflected back to the 

actual parameter. 

 In this method, the called function creates new variable to store the value of the 

arguments passed to it. 

 In this method copies the value of actual parameters into the formal parameters. 

 The function creates its own copy of arguments and then uses them. 

 In this method, the flow of data is always from the call statement to the function 

definition. 

 

Example: - 

#include<iostream.h> 

#include<conio.h> 

void sawp(int n1,int n2) 

{ 

int temp; 

temp=n1; 

n1=n2; 

n2=temp; 

cout<<n1<<’\t’<<n2<<’\n’; 

} 

main() 

{ 
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int m1=10,m2=20; 

clrscr(); 

cout<<”Before swap”<<m1<<’\t’<<m2<<’\n’; 

cout<<”Calling swap”; 

swap(m1,m2); 

cout<<”Back to main values are”<<m1<<’\t’<<m2<<’\t’; 

getch();  

} 

Output:- 

Before swap 10 20 

Calling swap 20 10 

Back to main values are 10 20 

 

2. Explain call by reference method with suitable example?  

In call by reference method, any change in the formal parameter is reflected back to the 

actual parameter. 

 In this method, the called function arguments-formal parameters become alias to the 

actual parameters in the calling function. 

 The function is working with its own arguments. 

 It is actually working on the original data. 

 In this method, any change made in the formal parameter is reflected back in the 

actual parameter. 

Example: - 

#include<iostream.h> 

#include<conio.h> 

void sawp(int &n1,int &n2) 

{ 

int temp; 

temp=n1; 
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n1=n2; 

n2=temp; 

cout<<n1<<’\t’<<n2<<’\n’; 

} 

main() 

{ 

int m1=10,m2=20; 

clrscr(); 

cout<<”Before swap”<<m1<<’\t’<<m2<<’\n’; 

cout<<”Calling swap”; 

swap(m1,m2); 

cout<<”Back to main values are”<<m1<<’\t’<<m2<<’\t’; 

getch(); } 

Output:- 

Before swap 10 20 

Calling swap 20 10 

Back to main values are  20 10 

 

3. Define scope? Explain the different types of scopes variables in C++? 

Scope refers to the accessibility of a variable.  

There are four types of scopes in C++. They are 

1. Local scope 2. Function scope 3. File scope 4. Class scope 

1. Local scope: - 

 It is defined within a block 

 It is the block in which it is defined. 

 It cannot be accessed from outside the block of its declaration. 

 A block of code begins and ends with curly braces { }. 

 It exists only while the block of code in which they are declared is executing. 

2. Function scope: - 
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 It is declared within a function is extended to function block, and all sub-blocks. 

 It is accessible in all the sub-blocks. 

 The lifetime of a function scope variable is the lifetime of the function block. 

 The scope of formal parameters is block function scope. 

3. File scope: - 

 A variable declared above all blocks and functions have the scope of a file. 

 The file scope variable is the entire program. 

 The lifetime of a file scope variable is the lifetime of a program. 

4. Class scope: - 

 A Class is a way to bind the data and its associated functions together. 

 Classes provide a method for packing together. 

Examples : 

# include <iostream.h> 

# include <conio.h> 

void main ( ) 

{ int a, b; 

a = 10 

b = 20; 

if (a > b) 

{  

int temp; 

temp = a; 

a= b; 

b = temp; 

} 

cout << a << b << temp; 

getch ( ); 

} 

4. Explain Inline Functions with an example?  
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When the functions are small, the compiler replaces the function call statement by 

its definition ie, its code during program execution. This feature is called as inline 

function. 

 An inline looks like a normal function in the source file but inserts the function’s 

code directly into the calling program. 

 Inline functions execute faster but require more memory space. 

 Reusability of code leading to saving of memory space and reduction in code size 

Example:  

# include <iostream.h> 

# include <conio.h> 

inline float convert_feet( int  x) 

{ 

return x * 12; 

} 

void main() 

{ 

clrscr(); 

int inches = 45; 

cout << convert_feet(inches); 

getch(); } 

 

 

 

7. POLYMORPHISM 

1. What is the advantage of operator overloading? (Or) List out the rules for 

overloading operators?  

The mechanism of giving special meaning to an operator is called as operator 

overloading. 
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 Only existing operators can be overloaded. New operators cannot be created. 

  The overloaded operator must have at least one operand of userdefined type. 

  The basic definition of an operator cannot be replaced. 

  Overloaded operators behave in the same way as the basic operators in terms of 

their operands. 

  When binary operators are overloaded, the left hand object must be an object of the 

relevant class 

  Binary operators overloaded through a member function take one explicit 

argument. 

2. Explain function overloading with rules? [June-07, 09, Oct-07, Mar-08,09,10] 

Function overloading :-  

 The ability of the function to process the message or data in more than one form is 

called as function overloading. 

Rules for function overloading:- 

 Each overloaded function must differ either by the number of its formal parameters. 

  The return type of overloaded functions may or may not be the same data type. 

  The default arguments of overloaded functions are not considered by the C++ 

compiler as part of the parameter list. 

  Do not use the same function name for two unrelated functions. 

Example : 

#include<iostream.h> 

#include<conio.h> 

float area ( float radius ) 

{  

cout << “\nCircle …”; 

return ( 22/7 * radius * radius ); 

} 
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float area (float half, float base, float height) 

{ 

 cout << “\nTriangle ..”; 

return (half* base*height); 

} 

float area ( float length, float breadth ) 

{  

cout << “\nRectangle …”; 

return ( length *breadth ) ; 

} 

void main() 

{ 

clrscr(); 

cout<< area(0.5); 

cout<< area(0.5,0.6); 

cout<< area(0.7.0.8); 

} 

Output: 

Circle …..  0.75 

Rectangle ….. 0.3 

Rectangle ….. 0.56 
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8. CONSTRUCTORS & DESTRUCTORS 

1. What is a constructor? Explain the rule for Constructors?  

Constructor:- 

  The constructor is a special function that initializes objects when they are created. 

  It is automatically invoked when an object is created. 

Functions of Constructor:- 

 The constructor function initializes the class object � The memory space is 

allocated to an object. 

Rules for Constructor:- 

 The name of the constructor must be same as that of the class  

 A constructor can have parameter list 

 The constructor function can be overloaded. 

 The compiler generates a constructor, in the absence of a user defined constructor. 

 The constructor is executed automatically 

2. List the rules for Destructor?  

The destructor has the same name as that of the class prefixed by the tilde character (~). 

 The destructor cannot have arguments 

 It has no return type 

 Destructors cannot be overloaded 

 In the absence of user-defined destructor, it is generated by the compiler. 

 The destructor is executed automatically when the control reaches the end of class 

scope. 

9.INHERITANCE 

1. Explain the different types of inheritance?  

There are different types of inheritance. 

1. Single inheritance 

2. Multiple inheritance 

3. Multilevel inheritance 

4. Hybrid inheritance  
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5. Hierarchical inheritance  

1. Single inheritance:- 

When a derived class inherits from only one base class, it is called as single 

inheritance. 

 

Base Class-

Employee 

 

 

 

 

 

 

 

2. Multiple inheritance:- 

When a derived class inherits from multiple base classes, it is called as single 

inheritance. 

 

 

Base Class-Address    Base Class-Office 

 

 

 

Derived Class-Manager 

 

 

 

3.Multilevel inheritance:- 

 

Derived Class-

Manager 
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The transitive nature of inheritance is reflected by this from of inheritance. When a 

class is derived from a class, which is a derived class itself. It is called as multilevel 

inheritance. 

 

                                               Base Class-Grand Father 

 

 

                                                  Derived –Father 

 

 

                       Derived –Child 

 

2. What are the advantages of inheritance?  

Reusability of code: - 

 Many applications are developed in an organization. Code developed for one 

application can be reused in another application. This saves a lot of development time. 

Code sharing: -  

The method of the base class can be shared by the derived class. 

Consistency of interface: -  

The inherited attributes and methods provide a similar interface to the calling 

methods. 

Aeroplane, Car and Bicycle. These three derived classes are said to be having a 
consistence interface. 

COMMANDS AND SHORTCUTS  FOR VOLUME-I & II 

1. File -> New -> Text Document (Star Office Writer is opened) 
2. File -> Save (Save As dialog box is opened) Ctrl + S 
3. File -> Close (Closes a document and not the Star Office application)  
4. File -> Open (Open dialog box is opened) Ctrl + O 
5. Edit -> Cut (Cut the selected text) Ctrl + X 
6. Edit -> Copy (Copy the selected text) Ctrl 

+ C 
7. Edit -> Paste (Paste the selected text) Ctrl 

+ V 

8. Edit -> Find & Replace (Find and Replace 
dialog box) Ctrl + F 

9. Ctrl + A (Select the entire the document) 
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10. Format -> Character (Character dialog box 
is opened) 

11. Center alignment (Ctrl + E) 
12. Left alignment (Ctrl + L) 
13. Right alignment (Ctrl + R) 
14. Justified alignment (Ctrl + J) 
15. Format -> Paragraph (opens the Paragraph 

dialog box) 
16. Format -> Bullets and Numbering (Opens 

Bullets and Numbering dialog box) 
17. Shift + F1 (Extended Tip) 
18. Tools -> Spelling -> Check (Opens the 

Spelling check dialog box) 
19. Tools -> AutoCorrect (AutoCorrect dialog 

box) 
20. F7 (Opens the Spelling check dialog box)   
21. Table -> Insert -> Table (Opens Insert 

Table dialog box) 
22. Table -> Insert -> Rows (Opens insert rows 

dialog box to add rows in a table) 
23. Table -> Insert -> Columns (Opens insert 

columns dialog box to add columns in a 
table) 

24. Tab (To move forward through the cells in a 
table) 

25. Shift + Tab (To move backward through the 
cells in a table) 

26. Table -> Delete -> Rows (To delete rows 
from a table) 

27. Table -> Delete -> Columns (To delete 
columns from a table) 

28. Edit -> Select -> All (To select the entire 
document) 

29. Table -> Delete -> Table (To delete the 
entire table) 

30. Table -> Table Properties (To open the 
Table Properties dialog box) 

31. Format -> Page (Opens Page Style dialog 
box) 

32. View -> Ruler (It is used when the ruler is 
not visible in the work area) 

33. Insert -> Fields -> Page number (To insert 
a page number on every page) 

34. File->New -> Spreadsheet(Opens  
StarOfficeCalc Window) 

35. Edit -> Fill -> Series (Opens Fill Series 
dialog box) 

36. Insert -> Function(Opens Function Wizard 
dialog box) 

37. Ctrl+ F2 ->(Opens Function Wizard dialog 
box) 

38. Format -> Cells(Opens the Format Cells 
dialog box) 

39. Format -> AutoFormat(Opens AutoFormat 
dialog box) 

40. Format -> Column -> Width(Opens 
Changing Column Width dialog box) 

41. Format -> Row -> Height(Opens Changing 
Row Height dialog box) 

42. View -> Toolbar -> Inset Cell(Opens 
Floating toolbar) 

43. View -> Toolbar -> Insert Object (Opens 
Floating toolbar) 

44. Edit ->Delete Contents (Opens Deleting 
Contents dialog box) 

45. Edit ->Delete Cells (Opens Deleting Cells 
dialog box) 

46. Insert ->Picture ->From File(Opens Insert 
picture dialog box) 

47. Insert -> Special Character (Opens the 
Insert Special Character dialog box) 

48. Insert -> Chart(Opens AutoFormat Chart 
Window) 

49. File -> Print (Print dialog box is opened) 
50. Format -> Print Ranges -> Edit (To select 

a print range) 
51. Format -> Print Ranges -> Delete (To 

delete a print range) 
52. File -> Page View (To preview a worksheet 

before printing) 
53. Edit -> Fill -> Down or Left or Right 
54. Edit -> Fill -> Series 
55. File -> New -> Database (Opens Database 

Wizard dialog box) 
56. Edit -> Paste Special (Opens Past Special 

dialog box) 
57. File -> Send -> Outline to Presentation 

(Sends outline of a text document into a 
Presentation) 

58. File -> Send -> AutoAbstract  (Sends 
outline along with its accompanying 
paragraphs) 

59. Alt + Tab (To switch between multiple 
applications) 

60.  TO COMPILE C ++ PROGRAM    ALT + 
F9 

61. TO RUN C++ PROGRAM    CTRL + F9 


