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Part – I Choose the most appropriate answer.     75 x 1 = 75 
 

Q 
No 

Ch Answer 
Q 

No 
Ch Answer 

Q 
No 

Ch Answer 

1 D Insertion Point 26 D Datum 51 D Inheritance 

2 A Ctrl + A 27 D Form 52 A Bjarne Stroustrup 

3 D Edit -> Cut 28 B Form 53 B Pointer Variable 

4 B Fajita 29 B Default Filter 54 A 96 Bytes 

5 C Hanging Indent 30 C Hierarchical 55 A 3 

6 A Delete 31 B Three 56 A = 

7 C Auto Correct 32 B Primary Key 57 D do .. while(); 

8 A F7 33 A Spread Sheet 58 D << 

9 C Tab 34 D 256 59 A cin 

10 A Table -> Delete -> Table 35 B Graphic Interchange Format 60 B -128 to 127 

11 D 1.00 " 36 B Vector Graphics Card 61 C Control Structure 

12 C Portrait 37 A .wmv 62 C Tokens 

13 A Excel 38 A Audio Interchange File Format 63 A Local 

14 B Format -> Page 39 A MMS 64 D Call by reference 

15 C 63 , 254 40 C Sound Forge 65 A Functions 

16 A SUM 41 B Object Based 66 A , C (A) Array  or  (C) Function 

17 C = 42 B Slideshow -> Show / Hide slide 67 B Array 

18 B Number 43 A Slide Sorter 68 C 20 

19 D = 44 C Escape 69 A Misplaced else 

20 A Cell 45 C Picture 70 A int 

21 C ! 46 D Templates and Documents 71 C Function Prototype 

22 D MM/DD/YY 47 B Normal 72 B 29 

23 A 20 48 C Edit -> Navigator 73 C break 

24 D Record 49 D Class 74 C strcmp() 

25 B Database Management System 50 B Polymorphism 75 D Zero 

 

Part – II Answer any twenty questions in one or two sentences each.  20 x 2 = 40 

QNo A N S W E R Marks 
 

  

76 Word Processing 

 The term word processing refers to the activity carried out using a computer and suitable software 

to create, view, edit, manipulate, transmit, store, retrieve and print documents. 

2 

   

77 Highlighting the Text 

 Highlighting can be used to call attention to key ideas or pointers in a document.  

 These highlighted sections are used to review or find the key points in the document.  

 In Star writer document, the user can highlight the required text using Highlighting Icon. 

 To remove the highlighting, select the text already highlighted and selects the No Fill from the 

colour palette. 

 

½ 

½ 

½ 

½ 
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78 Change the Margin using Ruler : 

 Margins are nothing but the edges of the page. 

 If the user is not having the exact value for the margins he can use the rulers. 

 Following steps are used to change the margin : 
o   If the ruler is not visible, click View-> Ruler option is to enable the ruler. 
o   The mouse pointer is then moved in between the gray and white area of the ruler. 
o   When the pointer is in proper position, the mouse pointer changed as double headed arrow. 
o   Now, click mouse left button and drag to a new location. 
o   When release the button, the margin will be changed to the new location. 

½ 

 

½ 

 

½ 

 

½ 

   

79 Electronic Spreadsheet : 

 An electronic spreadsheet is a worksheet used in a computer to create and quickly perform “What 
if” analysis of interrelated columnar data in workspaces. 

2 

   

80 Differentiate between Cell Addressing : 

RELATIVE CELL ADDRESSING  ABSOLUTE CELL ADDRESSING  

 Default cell addressing   Alternative cell addressing ½ 

 Cell addresses can be change while copying   Cell addresses cannot change while copying ½ 

 No special symbol required   Special symbol ‘$’ required for each cell address ½ 

 Example :   =sum(A1:B1)   Example :   =sum($A$1:$B$1) ½  
 

   

81 Range : 

 A continuous group of cells in a worksheet is called a Range 

 A range address is the address of the first cell in the range, followed by a colon, followed by the 

address of the last cell in the range. 

 For example, the cells, G1, G2,G3, G4 and G5 can be called G1:G5. 

 

1 

½ 

½ 

   

82 Database : 

 A database is a repository of collections of related data or facts. 
2 

   

83 Differentiation between Query and Filter :  (Ant 4 points are enough) 

QUERY  FILTER  

 Queries are special views.   Filter is built-in tool.  

 Queries are written by SQL.   No special language required. ½ 

 There is no type in queries.   There are 2 types of filter. (Auto and Standard) ½ 

 Queries can be saved later.   Filter cannot be saved. ½  

 Queries cannot hide the records.   Filter can hide the records from our view. ½ 
 

   

84 Multimedia : 

 Multimedia is a computer-based presentation technique that incorporates text, graphics, sound, 
animations, and video elements. 

2 

   

85 Steps to invoking to creating 3-D animation: 

 There are 3 essential steps to creating 3D animation. 

 Namely, they are,     (1) Modeling        (2) Animating      and     (3) Rendering 

2 

   

86 Sampling : 

 The conversion of analog sound waves to a digital format is called Sampling. 
2 

   

87 Views of a presentation : 

 There are 5 types of presentation views available in Star Office Impress. 

 Namely, they are, (1) Normal    (2) Outline    (3) Notes   (4) Handout   and (5) Slide Sorter 

2 

   

88 Uses of Master Slide : 

 A master slide determines the text formatting style for title, outline and the background design for 
individual slides, or for all of the slides in a presentation.  

2 
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89 Object : 

 An object is a group of related functions and data that serves those functions. 

 An object is a kind of a self-sufficient “subprogram” with a specific functional area. 

1 

1 
   

90 Encapsulation : 

 The mechanism by which the data and functions are bound together within an object definition is 
called as ENCAPSULATION. 

 This Encapsulation is one of the essential technique in OOP used to derive Class and Objects. 

2 

   

91 Tokens : 

 The basic types are collectively called as Tokens.  

 A token is the smallest individual unit in a program. 

1 

1 
   

92 Variable : 

 Variables are memory boxes that can hold values or constants. 

 Which identifier changes it’s values often during the execution of the program is called as variable 

 Generally, identifiers may also call as variables. 

 For example : 
void main()                                  
{ 
     int  a=10, b=10;                        From the given snippet, identifier ‘a‘  is constant  and 
     cout << “\n a = “ << a;                                                     identifier ‘b‘  is variable. 
     cout << “\n b = “ << b++; 
} 

1 

 

 

1 

 

 

 

   

93 Types of Unary Operators : 

 Unary operators require one operator and one operand. 

 For example, +a, -a, ~a, ++a etc., 

Operator Meaning Usage Example 

+ Unary Plus Negation + a 

- Unary Minus Negation - a 

& Ampersand Address of & a 

! Exclamation Logical NOT ! a 

 Indirection Pointer  a 

~ Tilde Bitwise ~ a 

++ Plus Plus Increment ++ a 

- - Minus Minus Decrement - - a 
 

2 

   

94 Type Cast : 

Type cast refers to the process of changing the data type of the value stored in a variable at runtime 
Syntax : (data type) <variable / value>  or data type (variable / constant) . 
Example :  if  float a = 6.5; int b = 3; cout << int(a) / b; then output will be 2. 
                  if  int a = 6; int b = 3; cout << float (a / b); then output will be 2.0 

1 

 
 

1 
   

95 Continue Statement : 

 The continue statement forces the next iteration of the loop to take place. 

 Any codes beyond to the statement ‘continue’ will be skipped by the compiler. 2 
   

96 Syntax of if..else statement : 

if  ( condition ) 

{ 

     action block of TRUE ; 

} 

else 

{ 

     action block of FALSE ; 

} 
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97 Advantages of Functions : 

 Functions are advantageous as they 
o Reduce the size of the program. 
o Induce reusability of code. 

1 

1 
   

98 Scopes of Variables : 

 Scope refers to the accessibility of a variable.  

 There are four types of scopes in C++.  

 Namely, They are:   (1) Local scope    (2)  Function scope  (3)  File scope   and    (4)  Class scope 

1 

 

1 
   

99 Array : 

 An array in C++ is a derived data type that can hold several values of the same type. 

 An array is a collection of variables of the same type that are referenced by a common name. 
Types of Array : 

 Arrays are of two types. 
o One dimensional: comprising of finite homogenous elements. Ex : int num [10] ; 
o Multi dimensional: comprising of elements, each of which is itself a 1-D array. Ex : int num [2][2]; 

 

1 

 

1 
   

100 String Manipulation Functions : 

(1)  strlen() 

Syntax    : strlen(string);  

Usage     : This string function is used to return the number of characters stored in the string. 
Example : if char name[10]={”srkvsshss”}; means, the command strlen(name); will return 9. 

 

(2)  strcpy () 

Syntax    : strcpy (target string , source string);  

Usage     : This string function is used to copy the content from source string to target string. 
Example : if char name1[10]={”srkvsshss”}; and char name2[10]={”\0”}; means, the command  
                  strcpy(name2 , name1); will return name1=“srkvsshss” and also name2=“srkvsshss”. 

 

 

1 

 

 
 

 

1 

 

 

PART – III ANSWER ANY SEVEN QUESTIONS ONLY.     7 X 5 = 35 

NOTE : You may draw icons, toolbars, if necessary. ( Draw the big dialog boxes are not necessary) 

QNo A N S W E R Marks 
 

  

101 Find and Replacing the given text  

 Purpose : Using this tool we can able to find the error words and replace them by correct words. 1 

 Procedure :  

  To Find and Replace Text, Choose Edit -> Find & Replace. 1 

  The Find & Replace dialog box appears on the screen.  

  In the Search for box, type the text that we want to find and in the Replace with box, enter the word 
to be replaced. 

1 

  Click Find button to start the search.  

  When click Replace, Star Office Writer will replace the first found occurrences of the searched text. 1 

  When click Replace All, Star Office Writer will replace all found occurrences of the searched text. 1 

  To skip the found text and to continue the search, click Find again.  

  Click Close when finished the search.  

   

102 Check spelling after the entire document is typed:  

 Purpose : The documents should be prepared without any spelling mistakes. 
               For this purpose Star Office Writer includes a built-in dictionary and spell-check program. 
               In the document, the spelling can be checked after the document is typed. 

1 

 Procedure :  

 
 Click Tools -> Spelling -> Check or click spell check      icon or F7 function key.  

1 

  Spell check dialog box appears on the screen.  
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  Not in dictionary text area displays the misspelled word and the Suggestions list displays any 
alternative spellings. 

1 

  Click Ignore once, to skip current occurrence but stop on the next one. 1 

  Click Ignore All, to skip all occurrences of this word.  

  Click Change button is clicked, to change the current occurrence. 1 

  Click Change All button to replace all occurrences of the word.  

  If none of the replacements is correct, correction can be made manually in the Not in dictionary text 
area. 

 

  Add button is clicked to add the word to the dictionary.  

  Click Close when finished the spell check.  

   

103 Table Formatting Toolbar : (any 10 icons are enough)  

  Purpose : The toolbar contains various formatting functions related to the table. 1 

                      Once a click is made inside a table a floating toolbar for tables appears on the screen.  

                      If not visible, enable it by clicking, View -> Toolbars -> Table.  

  Toolbar icons :  

T
a

b
le

 

 
 Table  - Fixed ½  

  Table Fixed, Proportional ½  

  Table  - Variable  

C
e
ll
s

 

 Merge Cells This icon is used to combine two or more cell into a single cell.  ½  

 Split Cells This icon is used to split a cell into two or more cells. ½  

 Optimize 
Clicking on this icon displays a pop-up menu with options like Space columns 
equally, Space rows equally, Optimum row height and Optimum column width. 

 

R
o

w
 /

 C
o

l 

 Inserting Row This icon is used to insert a row below the current row. ½  

 Inserting Column This icon inserts a column to the right of the current column. ½  

 Delete Row This icon deletes the current row from the table.  

 Delete Column This icon deletes the current Column from the table.  

L
in

e
 /

 

B
o

rd
e
r  Borders This icon displays a floating toolbar with different border option for the table. ½  

 Line Style This icon is used to choose the style of line to be used for the border. ½  

 Border Colour Clicking on this icon it displays a palette of colours for different borders of the table.  

   

104 Inserting Functions in Star Office Calc :  

 Purpose : Star Office Calc has a wide variety of built-in functions to perform frequent calculations. 1 

                     Functions are predefined formulas.  

 Inserting Functions :  

  Click  Insert -> Function (or ) Click Ctrl + F2 (or) click           Insert Function icon 1 

  Function wizard dialog box appears on the screen.  

 Examples:   

 Example 1 : To find summation of given range using SUM() function. 1½  

  To find summation using formula, type a range of values on A1:A5.  

  Click on A6 and make that as active cell.  

  Click   f (x)   Insert Function icon   

  Function Wizard Dialog Box appears on the screen.  

  Using mouse, click Functions tab.  

  Using mouse, choose Mathematical under Category title.  

  All formulas related to Mathematical will be filler on Function list.  

  Using mouse, scroll down and double click on the function SUM.  

  A small description will be displayed on the right side of the dialog box.  

  On the title number1, type the range as A1:A5  
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  Under Formula text box, a formula will be displayed as =SUM(A1:A5)  

  Finally click OK button.  

  Now the summation will be displayed on the active cell A6.  

   

 Example 2 : To find square root of the given cell value using SQRT() function. 1½  

  To find square root using formula, type a value on A1.  

  Click on A2 and make that as active cell.  

  Click   f (x)   Insert Function icon.  

  Function Wizard Dialog Box appears on the screen.  

  Using mouse, click Functions tab.  

  Using mouse, choose Mathematical under Category title.  

  All formulas related to Mathematical will be filler on Function list.  

  Using mouse, scroll down and double click on the function SQRT.  

  A small description will be displayed on the right side of the dialog box.  

  On the title number, type the cell value as A1.  

  Under Formula text box, a formula will be displayed as =SQRT(A1)  

  Finally click OK button.  

  Now the square root will be displayed on the active cell A2.  

   

105 Insert Object Tool Bar :   

 Purpose : Star Calc provides Insert Object Tool for inserting third party objects with spread sheets. 1 

                   For this purpose, click View -> Toolbars -> Insert Object. 1 

                   An Insert Object Toolbar will be appeared on the screen.   

 Toolbar Icons :  

 1. Insert Chart Icon 
2. Insert Formula Icon 
3. Insert Floating Frame Icon 
4. Insert Movie and Sound Icon 
5. Insert OLE Object Icon 
6. Insert Applet Icon 

 

  Insert Chart Icon  This icon is used for presenting the data in the worksheet in from of charts. ½ 

  Insert Formula Icon  This icon is used for inserting a formula in the worksheet to do some calculation. ½ 

  Insert Floating Frame Icon  This icon provides to generate a scrolling screen within a worksheet. ½ 

  Insert Movie and Sound Icon  This icon is used to insert sound or video files into a worksheet. ½ 

  Insert OLE Object Icon  This icon is used to insert objects from other applications in a worksheet. ½ 

  Insert Applet Icon  This icon is used to import Applets written in Java programs into the worksheet. ½ 

   

106 Manipulation  of a Database :  (explanation of any 5 titles are enough)  

  Manipulation of Database are in the following ways :   

 o Searching - The process to select a desired specific data from a database. 1 

 o Sorting - The process of arranging the data in a table in some order. 1 

 o Merging - The process of joining data from two or more tables of the same or different databases. 1 

 o Performing Calculations on data - Do any kind of arithmetic calculations on the data stored in the database. 1 

 o Filtering - The process of a way of limiting the information that appears on screen. 1 

 o Editing the database - The process of performing corrections and calculations on the existing data on the database.  
 o Report Generation - The process of generating any desired report, from the data of the database.  

   
107 Process of Report Generation :  

 Purpose :  
A report is printed information that is assembled by gathering data based on user supplied criteria. 
Reports are list of records in a customized format for specific purposes. 

1 
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Method of Creating Reports : 

 

  To create a report, right click on Reports in the <Database> pane.  

 Then click ‘Use Wizard to Create Report’.  

 Report wizard appears on the screen. 

 There are 6 steps available to generate reports. 

 Report Wizard window displays a list of available tables and queries. 

 Most of the reports are created by using queries. 

 Select the table or query we want. 

1 

 Step:1 ½  

  Fields of Selection window appears on the screen.  

  A list of fields from the selected table or query.  

  Select the fields to be included in the report by using the > or >> buttons.  

  Click on the Next button.  

 Step:2 ½  

  Next, a Labeling fields window appears with the field and Label.  

  Modify the labels for the corresponding fields, if we want.  

  Click on the Next button.  

 Step:3 ½  

  The Grouping window is displayed on the screen.  

  This window is used to specify the fields based on which the records can be grouped together.  

  Click on the Next button.  

 Step:4 ½  

  Then, the Sort Options window will display on the screen.  

  Here the sort criteria, if any, can be specified.  

  Click on the Next button.  

 Step:5 ½  

  The Choose Layout window will display on the screen.  

  Here we can select the Layout of Data, Layout of Headers and Footers and Orientation options  

  Click on the Next button.  

 Step:6 ½  

  The Create Report window is displayed on the screen.  

  Here, we can choose the report as Static or Dynamic.  

  The user also has the choice of either using the Report immediately or Modifying the Report 
Layout. 

 

  Enter the title for the report.  

  Finally, click the Finish button to view the report.  

   

108 Loop:  

 Loops execute a set of instructions repeatedly for a certain number of times. 1 

 Types of Loop:  

 There are 2 types of loop.   (1) Entry Check Loop    and    (2) Exit Check Loop  

 Entry Check Loop:  

 There are 2 categories of entry check loop.   (1) for ( ; ; ) Loop    and    (2) while( ) Loop  

 Exit Check Loop:  
 There is only one exit check loop.   (1) do..wile( ) Loop  
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for(;;) loop  while() loop  do..while(); loop   
       

Syntax / General Format :  Syntax :  Syntax :   
for ( initialization ; condition ; incre / decre)   initialization;   initialization;  1 
{  while (condition)  do   
      Action block of loop ;  {  {   
}        Action block of loop ;        Action block of loop ;   

        incre / decre ;        incre / decre ;   
  }  }   
    while (condition) ;   
Explanation of syntax :  Explanation of syntax :  Explanation of syntax :   

 In general, a loop contains 3 portions.    In general, a loop contains 3 portions.    In general, a loop contains 3 portions.   1 

 Namely, they are initialization, condition and 
increment / decrement. 

  Namely, they are initialization, condition and 
increment / decrement. 

  Namely, they are initialization, condition 
and increment / decrement. 

  

 The open and close curly braces {  } nothing 
but the action block of loop. 

  The open and close curly braces {  } nothing 
but the action block of loop. 

  The open and close curly braces {  } 
nothing but the action block of loop. 

  

 From the above syntax, ‘for’ is a keyword.   From the above syntax, ‘Initialization’ 
means, the declaration of control variable. 

  From the above syntax, ‘Initialization’ 
means, the declaration of control 
variable. 

  

 ‘Initialization’ means, the declaration of 
control variable. 

  ‘while’ is a keyword.   ‘do’ and ‘while’ are keywords.   

 ‘condition’ check status of the loop.    ‘condition’ check status of the loop.    ‘condition’ check status of the loop.    

 Then increment  or decrement of control 
variable. 

  Then increment  or decrement of control 
variable. 

  Then increment or decrement of control 
variable. 

  

       

Working procedure of loop :  Working procedure of loop :  Working procedure of loop :   

 From the above syntax, ‘for’ is a keyword and 
indicates that the loop is entry check loop. 

  From the above syntax, ‘Initialization’ 
means, the declaration of control variable 
along with a initial value.  

  From the above syntax, ‘Initialization’ 
means, the declaration of control 
variable along with a initial value.  

 1 

 ‘Initialization’ means, the declaration of 
control variable along with a initial value. 

  But, the initialization of control variable 
happen only once in the loop.  

  But, the initialization of control variable 
happen only once in the loop.  

  

 But, the initialization of control variable 
happen only once in the loop. 

  ‘while’ is a keyword and indicates that the 
loop is entry check loop. 

  ‘while’ is a keyword and indicates that 
the loop is entry check loop. 

  

 ‘Condition’ checks the status of the loop.    ‘Condition’ checks the status of the loop.    ‘Condition’ checks the status of the 
loop.  

  

 Condition may be either in relational or 
logical expressions. 

  Condition may be either in relational or 
logical expressions. 

  Condition may be either in relational or 
logical expressions. 

  

 If the given condition is TRUE then the action 
block of loop get executed. Otherwise, if 
FALSE, the loop will be terminated (stopped). 

  If the given condition is TRUE then the 
action block of loop get executed. 
Otherwise, if FALSE, the loop will be 
terminated (stopped). 

  If the given condition is TRUE then the 
action block of loop get executed. 
Otherwise, if FALSE, the loop will be 
terminated (stopped). 

  

 Then the increment or decrement of control 
variable will happen. 

  Then the increment or decrement of control 
variable will happen. 

  Then the increment or decrement of 
control variable will happen. 

  

 Again the control checks the condition status.   Again control checks the condition status.   Again control checks condition status.   

 This process will continue until the given 
condition gets FALSE. 

  This process will continue until the given 
condition gets FALSE. 

  This process will continue until the 
given condition gets FALSE. 
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     Here, this do..while(); loop has the 
condition at last of the loop body.  

  

     It is a little difference when compared 
with above two loops. 

  

     Due to this difference, exit check loop 
will execute at least only once, even 
though the condition get false. 

  

       

Example of loop :  Example of loop :  Example of loop :  1 
# include <iostream.h>  # include <iostream.h>  # include <iostream.h>   
# include <conio.h>  # include <conio.h>  # include <conio.h>   
void main()  void main()  void main()   
{  {  {   

int n = 5 ;  int n = 5 , i = 1 ;  int n = 5 , i = 1 ;   
for (int i = 1; i <= n; i++)  while ( i <= n)  do   
{  {  {   

cout << “\t” << i ;  cout << “\t” << i ;  cout << “\t” << i ;   
}  i++ ;  i++ ;   
  }  }   
getch();  getch();  while ( i <= n) ;   

}  }  }   
       

Output:  Output:  Output:   
1     2     3     4     5  1     2     3     4     5  1     2     3     4     5   

 
109 Debugging List :  (any 10 errors enough : each error carries ½ mark)  110 Output : 

Err No Error Code Correct Code Reason    

1 $ include (iostream.h) # include <iostream.h> Need preprocessor directive (#)    values before invoking the swap10      20 1 

2 $ include (iostream.h) # include <iostream.h> < > symbols are needed for header files   calling swap… 1 

3 void main [ ] ; void main ( )  ( ) is need instead of [ ]   20       10 1 

4 void main [ ] ; void main ( )  ; is not necessary    1 

5  { Open curly brace { is missing    back to main … values are10       20 1 

6 int a ; b ; int a , b ; Separator comma is missing    

7 a = 10 a = 10 ; Terminator ; is necessary  Sample Key Created by :- 

G. JAGADEESWARAN  M.C.A., M.Phil., M.Ed., 

COMPUTER INSTRUCTOR 

SRI RAMAKRISHNA MISSION VIDYALAYA 

SWAMI SHIVANANDA HR SEC SCHOOL 

PERIYANAICKENPALAYAM 

COIMBATORE-641020 

Mobile : 9842342797 

EMail : g.jagadeeswaran@gmail.com  

8 b = 20 b = 20 ; Terminator ; is necessary  

9 If if Keyword ‘if’ should not have capital letters.  

10 int temp int temp ; Terminator ; is necessary  

11 Temp = a ; temp = a; Variable name in error.  

12 Cout >> \n <, a <<’\n’<< b cout << ‘\n’ <, a <<’\n’<<b ; Keyword ‘cout’ should not have capital letters.  

13 Cout >> \n <, a <<’\n’<< b cout << ‘\n’ <, a <<’\n’<<b ; Insertion symbol not in proper position.  

14 Cout >> \n <, a <<’\n’<<b cout << ‘\n’ <, a <<’\n’<<b ; Escaping sequence should be enclosed with quotes.  

15 Cout >> \n <, a <<’\n’<<b cout << ‘\n’ <, a <<’\n’<<b ; Terminator ; is necessary  
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