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CLASS : XII                SUB:COMPUTER SCIENCE MAXIMUM MARK :150 

 
 

 

CHAPTERS 

 QUESTIONS  

Marks (1 M) (2 M) (5 M) Total 
Questions 

Vol-I 

Star Writer( 1-5) (23) 
23 9 2 2 13 

Star Calc (21) 21 7 2 2 11 

Star Base (18) 18 9 2 1 12 

Multimedia (9) 9 5 2 - 7 

Star Impress (9) 9 5 2 - 7 

Sub Total-Vol-1 80 35 10 5 50 

Vol-II 

Chapter-I (4) 
4 2 1 - 3 

Chapter-II (10) 10 4 3 - 7 

Chapter-III (12) 12 5 1 1 7 

Chapter-IV (11) 11 4 1 1 6 

Chapter-V (7) 7 3 2 - 5 

Chapter-VI (10) 10 6 2 - 8 

Chapter-VII (10) 10 3 1 1 5 

Chapter-VIII (11) 11 4 1 1 6 

Chapter-IX (10) 10 3 1 1 5 

Chapter- X to XII (10) 10 6 2 - 8 

SUB-TOTAL-VOL-II (95) 95 40 15 5 60 

TOTAL  (175) 175 75 25 10 110 
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1. AN INTRODUCTION TO STAROFFICE WRITER 

TWO MARK QUESTION 

1. What is meant by text editing? 

Entering a new text or modifying the existing text in a document is known as text 

editing. 

Ex : cut, copy, paste.  

2. How will you switch over from insert mode to type over mode?[J-10] 

We can toggle between type-over mode and the insert mode by using the insert 

key. The status bar gives the information about the current mode (Insert or Type-over-

mode). 

3. What are the functions of star office? 

 To create a text document using StarOffice writer. 

 To create a spreadsheet using StarOffice calc. 

 To create a presentation using StarOffice impresses. 

 To create a database using StarOffice Base. 

 To draw using StarOffice draw.   

4. Define word processing? 

The term word processing refers to the activity carried out using a computer and 

suitable software to create, view, edit, manipulate, transmit, store, retrieve and print 

documents. A document may contain text, tables, graphs, charts, equations, pictures and 

drawings. 

 
5. List the few commercial word processing packages? 

Some of the other commercially available word processing packages are  

1. MS Word 2. Lotus AmiPro 3.Word Perfect 4.Word Star 5.Word Pro. 

6. How will you create a new text document? 

 File New  Text Document command is used to open a new text document. 

Short cut key is Ctrl + N. 

7. How will you save a Document? 

The file can be saved simply by selecting the File  Save command or by clicking 

the Save button. Ctrl + S is the keyboard shortcut for saving the document. 
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8. How can work with multiple documents? 

 Click on the Window Menu option and select the file from the list of documents 

displayed. 

 Click on the document button visible on the task bar 

 
9. How will you correct mistakes in Star Office writer? or What purpose does 

Backspace and Delete Key serve in correcting mistakes? 

If a mistakes is identified it can be corrected either using the backspace key or the Delete 

key.  

 Backspace key deletes the character to the left of the insertion point.  

 Delete key deletes the character to the right of insertion point. 

10. What is the difference between copying text and moving text in star office? 

 
S. NO Copying Text Moving Text 

I.            

II.  

 

 

 

Duplication of the text is done 

Pasted in the same place  

Short cut key ctrl + c, ctrl + v 

 

Duplication of the text is not done 

Text is moved to another place 

Short cut key ctrl + x, ctrl + v  

 

11. What are the scrolling procedures? 

i. To scroll left and right arrow respectively should be clicked 

ii. To scroll up and down  arrow respectively should be clicked 

iii. If there are several pages in the document the user can know the current page 

number by looking at the pop-up page number that appears next to the scroll bar. 

Scrolling a document does not move the insertion point. The mouse click should 

be used to get the i-beam at the required place. 
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12. How will you open the star office documents? 

To reopen a document that has been saved and closed, the File Open command 

can be used. Short cut key is Ctrl + O. 

13. How will you close the star office documents? 

After saving the document can be closed using the File  Close command. 
FIVE MARK QUESTION. 

1. Explain how we can select the text in StarOffice writer? 

Selecting Text 

Even though the document is built up by typing one character at a time, while editing and 

formatting one always work with words, lines, paragraphs and sometimes with the whole 

document.  

Selecting Text with Mouse 

Following steps are to be followed: 

1. Insertion point is moved to the start of the text to be selected. 

2. The left mouse button should be clicked, held down and dragged across the text to be 

selected. 

3. When the intended text is selected, the mouse button should be released.  

 4. To unselect the wrongly selected text a click should be made outside the selected text. 

Selecting Text with Keyboard 

Following are the steps to be followed: 

1. Insertion point is moved to the start of the text to be selected. 

2. The Shift key is pressed down and the movement keys are used to highlight the 

required text. 

3. When the Shift key is released, the text is selected. 

 Selection Shortcuts 

The following shortcuts can also be used for selection. 

 

ACTION TO BE PERFORMED TO SELECT WHAT 

 

Double click on a word To select a word 

 

 

Click once next to the line 

To select the particular line 

 

Press Ctrl + A To select entire documents 
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2. Expalin the moving and copying the text ? 

Moving the Text 

The selected text can be easily cut and pasted in the required location. Following steps are 

to be followed. 

1. The text to be moved to a new location is selected. 

2. Edit → Cut is selected or in the tool bar is selected to cut the selected text. 

3. Insertion point is moved to the place where the text is to be pasted. 

4. Edit → Paste is selected or in the tool bar is selected to paste the text in the new location. 

The text can also be pasted in this way to another or another type of document. 

The following keyboard shortcuts can be used to move text. 

 

 

 

Copying the Text 

1. The text to be copied is selected. 

2. Edit → Copy is selected or is clicked. 

3. The insertion point is selected where the copy of the text should appear and is clicked. 

The following keyboard shortcuts can also be used for copy and paste: 

 

 

 

3. How will you find and replace a given word in StarOffice writer? 

Finding and Replacing Text 

1. Choose Edit → Find & Replace or Ctrl + F The Find & Replace dialog box appears . 

2. In the Search for box, type the text that you want to find in your document. 

3. In the Replace with box, enter the replacement word or phrase. 

4. Click Find to start the search. 

5. When Writer finds the first instance of the word or phrase, do one of the following: 

 To replace the found instance of the text with what you entered in the Replace with box, 

click Replace. 

 To replace all instances of the text with what you entered in the Replace with box, click 

Replace All. 

 To skip the found text and to continue the search, click Find again. 

6. Click Close when you have finished the search. 

      Ctrl + X → to Cut 
 

Ctrl + V → to Paste 

      Ctrl + C → to Copy 
 

Ctrl + V → to Paste 
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4. Explain Moving around the Document in StarOffice writer? 

 To move the insertion point to anywhere in the document either the mouse or the keyboard 

can be used.  

 The thick horizontal line in the page area is called the end-of-document marker. 

 To move the insertion point with the mouse, the mouse pointer is moved to the required 

spot and the mouse button is clicked. 

 To move the insertion point with the keyboard the arrow keys and other key combination 

can be used. 

 If the key combination is joined with a plus sign, the first key must be pressed and held 

down and the second key is to be pressed. 

S.NO TO MOVE TO PRESS 

1 One character to the left LEFT ARROW 

2 One character to the right RIGHT ARROW 

4 One word to the left CTRL+LEFT ARROW 

5 One word to the right CTRL+RIGHT ARROW 

6 One cell to the left (in a table) SHIFT+TAB 

7 One cell to the right (in a table) TAB 

8 Up one line UP ARROW 

9 Down one line DOWN ARROW 

10 To the end of a line END 

11 To the beginning of a line HOME 

12 Up one screen (scrolling) PAGE UP 

13 Down one screen (scrolling) PAGE DOWN 

14 To the end of a document CTRL+END 

15 To the beginning of a Document CTRL+HOME 
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TWO MARK QUESTION 

1. What are the commonly used formatting changes? 

StarOffice Writer offers a number of choices for formatting such as bold or italics, 

and defining the font, type, and font size. Bold, italic or underlined are the most common 

types of text formatting 

2. What are the various types of paragraph alignments that can be made?[O-08,J-12] 

    Click to left align text. Ctrl + L 

 Click to right align text Ctrl + R 

  Click to justify text.  Ctrl + J 

 Click to center text.  Ctrl + E 

3. How will you create the Numbered list in StarOffice document? 

Steps in creating numbered list: 

 Select the text to be numbered. The StarOffice Writer will number each paragraph.  

Blank lines within the selection will be numbered. 

   Click icon to create a numbered list. 

4. How will you create the Bullets  list in StarOffice document? 

Steps in creating Bullet list: 

 Select the text that to which bullets are to be added. The StarOffice Writer will add 

bullets to each paragraph within the selection, and not to each line. 

  Click on the Bullets icon from the formatting tool bar. 

    5. How will you change the font color while formatting the text? 

To use a different text color, select the text and click the arrow in the Font Colour icon. A 

colour palette is displayed from which the required colour can be selected.Alternatively, select the 

text and click on the Font colour icon,to apply the current colour of the Font Colour. 

 

 

 

 

2. TEXT FORMATTING 
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6. What is meant by Highlighting the text? 

Highlighting can be used to call attention to key ideas or pointers in a document. When 

reading something important in a book, a magazine, a report, or any document, the reader takes a 

yellow highlighter pen and drags across it.  

7. What is meant by  indenting the text ? 

Alignment changes are most appropriate for headings or other special paragraphs in the 

document. But to make a long document easy and inviting to read, some of the paragraph-

formatting features described in this section, including indents can be used. indentation helps in 

providing the document more readability. 

 
8. How will we Increase an indent, Decrease an Indent using tool bar? 

If a left indent is required - useful for setting off a paragraph from the main body text - the 

toolbar can be used to set the indent.   Click the Increase Indent icon; the paragraph is 

indented 1/2 inch from the left margin. If the indent is too much or if one wants to undo the 

indent, the Decrease Indent icon is clicked to decrease of undo the indents. 

9. What is  style?  
 

A style is a named set of defaults for formatting text. This is an alternative way of 

formatting text. 

10. Give the steps involved for chance the line spacing? 

To change the line spacing, following steps are used: 
 
1. Select the paragraphs(s) that needs to be changed. 

2. Select Format → Paragraph. 

3. If necessary, click the Indents & Spacing tab. The Indents & Spacing tab. 

4. Click on the Line spacing drop-down list box, and select the required line spacing option. 

5. Click the OK button. 

11. What is meant by Hanging indent? 

The First line option can be used to indent the line of the paragraph. Using the spin 

arrows, if a positive value is specified, the first line will be indented. A negative value will result 

in a hanging indent; that is, the first line will hang outside the paragraph. 
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12. List about the several help system in StarOffice writer? 

 Online help 

 Help Agent 

 Help Tips 

 Extended Help Tips 

14. What is the difference between hard formatting and soft formatting? 

HARD FORMATTING SOFT FORMATTING 

It applies directly to the portion of the 

Selected text. 

Its applies a style. 

It is most appropriate for one time usage. It is most appropriate several formatting 

option. 

 

 FIVE MARK QUESTION 

1. What are the formatting changes that can be made with respect to the fonts? 

 Click to make text Bold. 

 Click to make text Italic. 

 Click to make text Underlined. 

The same can also be achieved by clicking on Format →Character and then selecting an 

option from the Typeface list box.  

Changing the Fonts 

  A font is a set of characters and numbers in a certain style. Each font looks 

different from other fonts. Some fonts, like the Times New Roman, look professional and are 

suited for business documents. Some fonts, like FAJITA, are decorative. Some fonts, like 

Symbol and Wingdings, are actually sets of symbols.  

Method 

Click the down arrow in the Fonts Combo box of font tab in Character dialog box. 

Use Format _ Character to open the Character dialog box. From the list of available 

fonts, click the required one. The text changes to the selected font. 

Font Size 

The size of the text is also important. The same size of the text cannot be used for a legal 

document, and an advertisement material. Similarly the size of the letters used in the main text 

and footer cannot be the same. The size of a font is measured in points, and there are 72 points to 

an inch. 
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Method 

Click the down arrow in the Size combo box of Fonts tab in Character dialog box. 

Use Format _ Character to open the Character dialog box. 

The text changes to the selected font size. 

Changing the Font Colour 

A different colour for selected text can be used. Colour printers are becoming more and 

more popular. 

Method 

To use a different text color, select the text and click the arrow in the Font Colour icon. A 

colour palette is displayed from which the required colour can be selected. Alternatively, select 

the text and click on the Font colour icon, to apply the current colour of the Font Colour. 

2. How would you create the bullets and numbered list? 

Creating Bullets and Numbered List 

When the document presents a matter using text in the form of long paragraphs the reader 

may not be able to quickly notice the important points or messages.  

Creating a Bulleted List 

1. Select the text that to which bullets are to be added. The StarOffice Writer will add bullets to 

each paragraph within the selection, and not to each line. StarOffice Writer will add bullets 

to any blank lines within the selection. 

2.              Click on the Bullets icon from the formatting tool bar, StarOffice Writer creates 

a bulleted list, as shown in figure. 

Creating a Numbered List 

For items that appear in a specific order, such as a series of steps, one can create a 

numbered list. StarOffice Writer will add the numbers automatically and also indent the 

paragraphs so that the text is aligned properly.  

Following steps are used to create a numbered list. 

1. Select the text to be numbered. The StarOffice Writer will number each paragraph. Blank lines 

within the selection will be numbered. 

2.             Click icon to create a numbered list. 

Removing the Bullets or Numbers 

To remove bullets from a list, the list is selected and the Bullets button is clicked again. 

To remove numbers for a list, select the list and click the Numbering button. 
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Applying Different Styles for Bullets and Numbers 

StarOffice Writer provides various styles for the bullets and numbers, which can be 

selected using Format → Bullets and Numbering. 

3. How can we Indent text with the paragraph dialog box? 

Indenting Text with the Paragraph Dialog Box 

The Increase Indent and Decrease Indent icons are useful if it is needed to indent text from 

the left. If one wants to indent from the left and right or if one wants to create a special kind of 

indent, a different method is used. The Paragraph dialog box must be used. 

1. Move the insertion point to the beginning of the paragraph to be indented. To indent several 

paragraphs, select those paragraphs. 

2. Select Format → Paragraph command. 

3. Click the Indents & Spacing tab in the Paragraph dialog box. 

4. Do any of the following. 

i. To indent from the left, type the amount to be indented in the Before text spin box       

or use the spin arrows to select a value. 

ii. To indent text from the right, type the amount or use the After text spin arrows to enter 

the amount in the spin box. 

iii. Click the OK button. The First line option can be used to indent the line of the 

Paragraph. Using the spin arrows, if a positive value is specified, the first line will be 

indented. 

iv. A negative value will result in a hanging indent that is the first line will hang outside 

the paragraph. 

4. What are the various types of paragraph alignments that can be made? 

Paragraph Alignment 

 A paragraph is any text followed by a hard return. 

 When typing in StarOffice Writer, all text is left aligned, and the right margin is ragged or 

uneven. For most text, this alignment works great. For other paragraphs, one may want to 

make a change.  

 Also, each time Enter is pressed, the paragraph options for that paragraph are carried 

down to the next paragraph. 

 Four types of alignment can be selected, and the best way to make a change is to use the 

Formatting toolbar. 

 To change the alignment of one paragraph, first click within that paragraph. To change the 

alignment of several paragraphs, select the ones needing change. 
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 Do one of the following 

Click   to left align text.   

Click   to right align text  

Click   to justify text.    

Click   to center text.    

The following keyboard shortcuts can also be used to change the alignment. 

To make text Press 

Left aligned 

Right aligned 

Justified 

Centered 

Ctrl + L 

Ctrl + R 

Ctrl + J 

Ctrl + E 
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TWO MARK QUESTION 

1. What is meant by Auto spell check? 

StarOffice Writer has an automatic spell-check feature that can check for possible spelling 

mistakes even as the document is being typed. This feature can be turned ON or OFF by clicking 

on the Auto Spellcheck icon. 

2. What is meant by auto correct option? 

StarOffice Writer will automatically correct some spelling mistakes. StarOffice Writer 

recognises some common misspellings and typographical mistakes and makes the replacement 

automatically. For instance, if a word is typed as “teh”, StarOffice Writer automatically replaces 

this with the correct word “the”. 

3. How many ways the mistakes can be corrected in star office writer? 

These mistakes can be corrected in two ways: 

1. Backspace key is pressed to delete a misspelled word and the word is retyped. 

2. If the right spelling is not known, StarOffice Writer can help the user with some 

choices. The misspelled word is right clicked. A pop up menu appears on the screen. If the 

correct spelling is shown, a click is made on that word to replace. 

4. Differentiate ignore once and ignore all? 

 

Ignore Once 
 

 
Ignore All 

 

To skip this occurrence but stop on the next 

one. 

To skip all occurrences of this word. 

 

5. Differentiate change and change all? 

 

Change  

 
Change all  

To change this occurrence of the word To replace all occurrences of the word. 

 

 

 

 

 

3. CORRECTING SPELLING MISTAKES 
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FIVE MARK QUESTION 

1. How would you carry out the spell check after the entire document is typed? 

Checking the Spelling after the Document is Typed 

The following steps are used for a spell check. 

Tools → Spelling → Check is selected or is clicked. To check a part of the document 

only that portion is selected. The F7 key may also be pressed to select the spelling command. 

Not in dictionary text area displays the misspelled word and the Suggestions list displays any 

alternative spellings. Any of the following can be done: 

 To skip this occurrence but stop on the next one. Ignore Once button is clicked. To skip 

all occurrences of this word. Ignore All button is clicked. 

 To replace the word with one of the selected spellings, in the suggestions list that spelling 

is clicked, and Change button is clicked. 

  To change this occurrence to Change All button is clicked to replace all occurrences of 

the word.  

 If none of the replacements is correct, correction can be made manually in the Not in 

dictionary text area.  

 Add button is clicked to add the word to the dictionary. 

2. How will you add an entry to the  Auto Correct list of the star office writer? 

In addition to flagging some words, StarOffice Writer will automatically correct some 

spelling mistakes. StarOffice Writer recognises some common misspellings and typographical 

mistakes and makes the replacement automatically. For instance, if a word is 

Typed as “teh”, StarOffice Writer automatically replaces this with the correct word “the”. 

Creating AutoCorrect Entry 

i. Tools → AutoCorrect command is clicked. 

ii. Now auto correct dialog bow will appear. 

iii. If need, click replace tab. 

iv. In the replace text box, type replaced. 

v. In the with text box type the correct word or replacement word. 

vi. Click replace button to the entire word as auto correct entry. 

vii. Click Ok to finish the task. 
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TWO MARK QUESTION 

1. How will you create a table in the document? 

 When Table →Insert →Table is selected from the menu bar, the Insert Table 

dialog box is displayed. 

 In the Name textbox the name of the table is given. Using the spin arrows in the 

Columns and Rows text box the number of columns and rows are entered. 

   2. How will you add a required number of rows and columns in a table? 

 Table →Insert → Rows using this command insert more rows in the particular 

table. 

 Table → Insert → Columns using this command insert more columns in the 

particular table. 

3. How will you delete a required number of rows and columns in a table? 

 Table → Delete → Rows using this command delete more rows in the particular 

table 

 Table → Delete → Columns using this command delete more columns in the 

particular table. 

4. How to change the width of a column in a table? 

1. To resize a column, place the cursor in a table cell, hold down Alt, and then press the 

left or the right arrow. To resize the column without changing the width of the table, hold 

down Alt+Ctrl, and then press the left or the right arrows. 

2. To resize a row, place the cursor in the row, hold down Alt, and then press the up or the 

down arrows. 

5. How to make the selected rows and columns of the same size? 

Follow the steps to make the selected rows/columns the same size. 
 
 Select the rows and columns that are to be resized. 

 To make all columns even, right click inside the table and select Column→ Space 

Equally in the pop-up menu. 

 To make all rows even, right click inside the table and select Row→ Space Equally in the 

pop-up menu. 

 

 

4. WORKING WITH TABLES 
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6. How will you delete a entire table in the star office writer document? 

1. The entire table is selected using Edit→ Select → All command while keeping the 

insertion point inside the table. 

2. The menu option Table→ Delete → Table is used to delete the selected table. 

FIVE MARK QUESTION. 

1. What are the Various function of the icons in the table formatting tool bar? 

 

       Table Fixed 

     Table Fixed, Proportional 

  Table, Variable 

  Merge Cells - This icon is used to combine two or more cell into a single cell. 

  Split Cells - This icon is used to split a cell into two or more cells. 

  Optimise - Clicking on this icon displays a pop up menu with options like Space 

columns equally, Space rows equally, Optimum row height and Optimum column width. 

  Inserting Row - This icon is used to insert a row below the current row. 

  Inserting Column - This icon inserts a column to the right of the current column. 

  Delete Row - This icon deletes the current row from the table. 

  Delete Column - This icon deletes the current Column from the table. 

 Borders - This icon displays a floating toolbar with different border option for    

the table. 

 Line Style - This icon is used to choose the style of line to be used for the border. 

 Border Colour - Clicking on this icon displays a palette of colours that can be   

used as a border colour for the table. 
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TWO MARK QUESTION 

1. What is meant by Margin? 

StarOffice Writer prints to the edge of the page. If there is a big top margin for instance, 

much white space is left at the top of the document. The default margins are 1inch top and bottom 

margins and 1.25 inches left and right margins.  

2. What is page formatting mean? 

Page formatting measns, that Margins control how close StarOffice Writer prints to the 

edge of the page.Changing the page orientation, Portrait or Landscape 

3. What are the two types of page orientations 

portrait 
The length of a document will be more than the width.This orientation is called portrait. 

The default orientation is portrait. 

landscape 

Some of the documents the width will be more than the length. This type of orientation is 

called landscape. 

4. What is meant by header and footer? 

 Header is an area at the top of page. 
 

 Footer is an area at the bottom of the page. 
 

5. What is the purpose of creating a header and footer in the document? 

When the documents are longer than one page, normally some type of reference numbers 

are added on the page. For instance, page numbers are a must. 

6. Write down the steps involved in including text in header and footer? 

 The Format Page option is clicked. The page style dialog box is appear. 

 Select the “Header”  tab. 

 Click the “Header on” , Check box. 

 Click  “Ok” button. 

7. How will you insert page numbers in footer? 

Click on Insert → Fields → Page Number will insert page numbers on every page. 

Normal text can also be included in the header and footer.  

 

5. PAGE FORMATTING 
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8. What is the use of page preview? 

Use the Page Preview option in the File menu can be used to see the change. This option 

gives an overall picture of the document and visually shows to the user, how the change has 

affected the document. 
FIVE MARK QUESTION. 

1.Explain the process of changing margin. 

 Using any one of the following methods, margins can be changed, 

1. Page Style Dialog Box 

2. Changing Margins Using Rulers 

Page Style Dialog Box 

If the user knows the exact value for the margins then the page style dialog box can be 

used to make a change. The following steps are used. 

 FormatPage command is selected. A dialog box appears on the screen. 

 Click the Page tab, if necessary. 

 In Margins group, type the new values in the spin boxes or use the spin arrows to change 

the value. 

 Click the OK button. 

Changing Margins Using Rulers 

If the user is not having the exact value for the margins then the Ruler option on the View 

menu can be used to change the margins.Following steps are used in this method. 

 If the ruler is not displayed in the screen, ViewRuler option is clicked. 

 The gray area of the ruler indicates the margin’s top area. 

 The mouse pointer is then moved in between the gray and white area of the ruler. 

 When the pointer is in the right spot, it changes into a line with arrows on both sides 

 The margin guide is dragged to a new location. 

2. How will you insert header and footer and insert page number in entire document. 

Header 

Header is an area at the top of page. 
 

Creating a Header  

 To create a header, the Header tab on the Page Style dialog box can be used. 

 In this dialog box, the Header on check box is clicked. 

 Click the OK button. 
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Footer 

Footer is an area at the bottom of the page. 

Creating a Footer 

 To create a header, the Footer tab on the Page Style dialog box can be used.  

 In this dialog box, the Footer on check box is clicked. 

 Click the OK button. 

Insert Page Number 

 Click on Insert → Fields → Page Number will insert page numbers on every page.  
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TWO MARK QUESTION 

1. What is an electronic spreadsheet? 

An electronic spreadsheet is a worksheet used in a computer to create and quickly perform 

“What if” analysis of interrelated columnar data in workspaces 

2. Can we change the data present in a cell? If so,how? 

Yes. We can change the data present in a cell.  

 Type in the new data. The new data will simply overwrite the old contents of the cell. 

 Click on the formula bar with the mouse. Press the F2 function key or simply double 

click on the cell. A vertival cursor appears on the formula bar. Move the cursor to the 

left arrow key or the backspace key and edit the data. 

3. Differentiate the terms “Spreadsheet” and “Worksheet”? 

Spreadsheet Worksheet 

The term spreadsheets refer specifically to 

the software packages. 

The term worksheet refers to the files that 

you create with spreadsheet software. 

4. What is the use of electronic spreadsheet? 

Electronic spreadsheets can also be used for presenting the worksheet data in an 

impressive manner such as bar-charts, pie-charts, line graphs, three-dimensional charts and other 

visual forms. 

5. Write the Spreadsheet applications? 

 Payment of bills    

 Income tax calculations 

 Invoices or bills 

 Account Statements 

 Inventory Control 

6. Define “Visicalc” 

VisiCalc (Visible Calculator) was the first commercial spreadsheet package developed for 

microcomputers in 1979. It contained 63 columns (A, B,………BK) and 254 rows. VisiCalc was 

essentially a financial analysis program. 

 

 

 

6. SPREADSHEET 
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7. Name some popular spreadsheet softwares. 

 Lotus 1-2-3 

 Excel 

 Quattro Pro 

 Improve  & StarOffice Calc 

8. Define Starcalc. 

StarOffice Calc is a powerful spreadsheet program included in StarOffice. It offers all the 

functions needed for business use, including various financial and statistical functions, StarOffice 

Calc database functions and much more. 

9. How will you creating new Worksheet 

To work with StarOffice Calc, open StarOffice and click on the File option in the main 

menu bar. Then click on New→ Spreadsheet 

10. What is Date arithmetic? 

In spreadsheets, date calculations become very simple. Here you can add a number to a 

date and arrive at a new date, find the difference between two dates and use a wide variety of 

function and formats to get what you want. Place the cursor in the cell where you want to enter 

the date and type it in as MM/DD/YY. 

For example: First cell- Second cell. 

11. How will you save the Worksheet? 

To save the worksheet created, go to the File menu and select the Save or the Save As 

option. Type in a file name and click on Save. For example, to save the student marks, type the 

name Marks in the File name box and click on the Save button. You can also click on the Save 

icon on the Standard toolbar. 

12. What is Range? 

A continuous group of cells in a worksheet is called a Range. A range is referred to by the 

range address. 

For example: the cells, G1, G2, G3, G4 and G5 can be called G1:G5. 

 

 

 

 

 

 

 



www.Padasalai.Net

 Star Office   & C++           www.padasalai.net 

            P.CHANDRASEKARAN M.C.A, B.ED, [PG ASST IN C.S]     -             99420 12999                                         23 
 

13. Differentiate Relative and Absolute cell addressing. 

Relative cell addressing Absolute cell addressing 

Relative cell addressing is the default type of 

cell addressing used by StarOffice Calc. 

A cell address can be made absolute by using 

the $ (dollar) sign in front of row and column 

names. 

Relative cell addressing is also the reason 

why formulae are automatically recalculated 

every time the contents of the cells used in 

the formulae change 

The C4 becomes absolute when you enter it 

as $C$4.Absolute cell addresses do not 

change when copied. 

14. What are Functions? Give an example? 

StarOffice Calc has a wide variety of functions that allow you to perform several 

frequently done calculations. Functions are predefined formulae that are available in StarOffice 

Calc. 

Eg:   SQRT( ), SUM( ). 

15. How StarOffice Calc  allows you to change the width of a column and the height of a 

row. 

 To change the column width: 

Select the column whose width you want to change. Click on Format → Column → 

Width and type the new column width in the dialog box. 

To change the Row Height: 

Select the Row whose Height you want to change. Click on Format → Row → Width 

and type the new Row Height in the dialog box. 

16. What is the use of Auto format sheet? 

The AutoFormat Sheet facility of StarOffice Calc helps to format the worksheet with 

different predefined styles and colours. 

17.What are the various icons in the insert object floating toolbar? 

→ Insert Cells Down 

  → 
Insert Cells Right 
 

  → 
Insert Rows  

  → Insert Columns 
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18. How are Picture and Special characters inserted in the worksheet? 

For inserting a picture in a worksheet follow the procedure given below: 

 Place the cell pointer in any cell. 

 Choose Insert → Picture → From File From the menu bar. 

For Special characters in a worksheet follow the procedure given below: 

 Place the cell pointer in any cell. 

 click the Insert →Special characters from the menu bar and select the desired special 

characters from the Special Character dialog box 

19. List out the icons that appear in a insert object toolbar. 

1. Insert Chart Icon 

2. Insert Formula Icon 

3. Insert Floating Frame Icon 

4. Insert Movie and Sound Icon 

5. Insert OLE Object Icon 

6. Insert Applet Icon 

20. Define 3-D formula. 

Each sheet of a spreadsheet can be used entirely independently of the other sheets. You 

can also make them dependent on each other by referring to the data in another sheet or using the 

data from another sheet in calculations. 

For example, you can enter data in Sheet 1 and Sheet 2 and can do the calculations in 

Sheet 2. You can calculate the sum of the numbers in the cell A1 of Sheet 1 and A1 of Sheet 2 

and store the result in A3 of Sheet 2. To do this, type the 3-D formula as  

= SUM(Sheet 1.A1; Sheet 2.A1). 
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FIVE MARK QUESTION. 

1. Write the advantages of using Electronic Spreadsheet? 

 Calculations are automated through the built-in mathematical, financial and statistical     

functions. 

 Accurate results to any desired level of decimal points are possible Worksheets can be 

quite big in size 

 Any part of the worksheet can be viewed or edited. 

 Worksheet can be saved and retrieved later. 

 Any part or whole of an existing worksheet can be merged with any existing or new 

worksheet. 

 Any part or whole of the worksheet can be printed in a desired format. 

 Worksheet data can be viewed in the form of graphs or charts 

 The worksheet information can be transferred to any database or word processing 

software. 

2. List out the Applications of Spreadsheet. 

• Payment of bills 

• Income tax calculations 

• Invoices or bills 

• Account Statements 

• Inventory Control 

• Cost-Benefits Analysis 

• Financial Accounting 

• Tender Evaluation 

• Result analysis of students 

2. Explain the type of operators of star office calc with an example 

Arithmetic Operators 
 

These operators return numerical results. 
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Operator Name Example 
 

+(plus) Addition 1+1 
 

-(minus) Substraction 2-1 
 

-(Minus) Negation -5 
 

*(asterisk) Multiplication 2*2 
 

 
/ (Slash) 

Division 9/3 
 

%  (Percent) Percent 15% 
 

^ (Caret) Exponentiation 3^2 
 

 
Comparative operators 
 

These operators return either true or false. 
 
 

Operators Name Example 
 

 
= 

Equal A1=B1 
 

> Greater than A1>B1 
 

< Less than A1<B1 
 

> = Greater than or equal to A1>=B1 
 

< = Less than or equal to A1<=B1 
 

< > Inequality A1<>B1 
 

 
Text operators 
 

The operator combines sections of text to the entire text. 
 
 

Operator Name Example 
 

&(And) Text operator: And “Star” & “Office” 
yields StarOffice” 
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Reference Operators 
These operators combine areas. 

 
Operator Name Example 

 
:(Colon) Range A1:C108 

 
!(Exclamation point) 

 
Intersection SUM(A1:B6!B5:C12) 

 

4. How can you generate a series of values? Explain with an example. 

AutoFill automatically generates a data series based on a defined pattern. 

1. On a sheet, click in cell, and type a number. 

2. Drag the fill handle in the bottom right corner of the cell across the cells that you want to fill, 

and release the mouse button 

Fill command to generate a series of data directly from the values of the selected cells. 

First, select the cells of the worksheet that you want to fill.  Choose the command Edit→ Fill→ 

Series. Select the type of series from the options 

Example: 

1. Enter initial value in the first cell 

2. Select A1 to A20 

3. Click Edit Fill series  

4. Select type as linear. 

5. Enter stop value. 

6. Enter increment as 3 

7. Click ok button. 

5. What are Functions? How can you use them in your work sheet? Explain with an 
example. 

StarOffice Calc has a wide variety of functions that allow you to perform several 

frequently done calculations. Functions are predefined formulae that are available in StarOffice 

Calc. 

To select a function: 

 Select the category in the Category box. 

 Scroll down the list to find the function you want.  

 Click once on the function name to see a short description of that function on 

           the right side of the window. Double – click on it to insert it into the worksheet. 
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 The Function Wizard shortcut icon on the formula bar can also be used to select 

and insert functions. 

 

One of the most commonly used functions is the Sum function. This function 

calculates the sum of a given set of numbers. 

Example 

1. To insert the SQRT function (a function to find the square root of a 

number), place the cursor in the cell where you want to insert the function 

and click on the Function Wizard icon.  

2. Select Mathematical from Category. Select the SQRT function from the 

list of functions, which appears by double clicking on it.  

3. The Function Wizard displays a brief description of the function and 

prompts you to enter the number or the cell address on which the function 

should work. Enter the number 64. 

  

6. Explain the different Formatting options available in star office calc. 

 
This is the Bold icon and is used to display data in bold. To use this icon, 

highlight the cells and click on the icon. 

 
 

 
This icon is used to display the data in italics. 

 

 
This is used to underline the data in highlighted cells. 

 

 
This is the Change Font icon. This icon displays list of fonts that can be 

used. Select the font by clicking on it. 

 

 

 This icon is used to change the font size of the data. To do so, select the 

data and click on this icon. 

 

 

 
This is the Font Colour icon. This can be used to change the font colour. 
 
 

 
These are the Align Left, Align Center, Align Right and Justify icons. 

They are used to align the contents of cells. 

f(x) 
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This is the Number Format: Currency icon. Clicking on this 

will display the contents of the selected cells in currency format, that is 

with a $ in front and with two decimal digits. 

 

 

This is the Number Format: Percent icon. Clicking on this icon will 

display the current contents in percentage format. Note that it multiplies 

the contents of the cell by 100 and displays the result with 2 decimals. 

 

 
This is the Number Format: Standard icon. Clicking on this icon will 

display the contents of the selected cells in default Format. 

 

 
These are the Number Format: Add Decimal and Number 

Format: Delete Decimal icons. They are used to increase or decrease 

the number of decimal digits that are to be displayed in the selected cells. 

 

7. Explain the procedure for Inserting a Picture or a Special character in a worksheet. 

Inserting Pictures and Special characters 

In the worksheet, StarOffice Calc also provides for inserting pictures and special 

characters like á, â. For inserting a picture or a special character in a worksheet follow the 

procedure given below  

 Place the cell pointer in any cell, say B2. 

 Choose Insert →Picture →From File. The Insert Picture dialog box appears.  

 In the File name combo box, you can type the path of the file that contains the picture or 

you can directly select the desired file from the gallery directory of StarOffice.  

 After selecting the picture file click Open.  

 For example, select Apple file from the gallery directory and click Open. 

Inserting Special characters 

 For inserting special characters, click the Insert →Special characters from the menu bar  

 Select the desired special characters from the Special Character dialog box.  

 For example, select ² from the Special Character dialog box and click the OK button. 
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8. What are the various icons in the Insert Object floating tool bar? Mention their functions 

StarOffice Calc provides tools for inserting objects.  For this purpose, click on the Insert 

Object from View → Toolbar. 

A floating toolbar appears with the following icons: 
 

1. Insert Chart Icon 

2. Insert Formula Icon 

3. Insert Floating Frame Icon 

4. Insert Movie and Sound Icon 

5. Insert OLE Object Icon 

6.   Insert Applet Icon 

Insert Chart Icon 

` This icon is used for presenting the data in the worksheet in from of charts of different 

kinds such as Bar Chart, Pie Chart, Lines, XY ,plot, etc. More details on charting are given in a 

later section. 

Insert Formula Icon 

This icon is used for inserting a formula in the worksheet for performing calculations. 

Insert Floating Frame Icon 

This icon provides to generate a scrolling screen within a worksheet. 

Insert Movie and Sound Icon 

This icon is used to insert sound or video files into the current worksheet. 

Insert OLE Object Icon 

This icon is used to insert objects from other application into a worksheet. 

Insert Applet Icon 

This icon is used to import Applets written in Java programming language into the 

worksheet. 

9. Explain the procedure to be followed to draw a chart. 

Working with Charts 

Select the data you want to chart. 

 Click on Insert → Chart or click on the Insert Chart icon as discussed earlier. 

 The cursor becomes a + sign with a small picture of the graph. Place this cursor where you    

want to insert the chart and click. 

 It prompts you to enter the area in the worksheet to be charted. Enter the range as C3 : F7 

and click Next. 
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 The next window, which appears as shown in figure 6.31 displays the different types of 

charts that can be created along with a preview of each. Select the type of chart in which 

you want to present the data. The preview. Window shows the chart. Click on Next. 

 For each type of the chart (say Pie, Bar, Column, etc.), there are different formats 

available. These formats are displayed in the next window  a preview of the each format is 

also displayed. Here, select the desired format. Click on Next. 

 In the next window ,you have provisions to give a Title for the chart, Titles for X and Y 

axes and legends. 

 

 

The Worksheet with the chart 

 Click on Create. Now, your worksheet will created.  

10. How will you Insert Rows, Columns and cells in a worksheet? Give and   example 

 Click the Insert Cell from View → Toolbar menu.  

 A floating toolbar with four icons appears. 

 These icons are Insert Cells Down, Insert Cells Right, Insert Rows and Insert 

Columns icons 

Insert Cells Down: 

 

  

In order to insert an empty cell in a column and move the existing cells down, 

place the cursor in the cell where you want to insert the new cell and click on the 

Insert Cells Down icon.  

       For example, in the Marks worksheet, to insert a cell in D4 and move the 

contents of the cell D4:D7 down, select D4 and click the icon. 
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Insert Cells Right 

 

 

In order to shift the content of a cell to the right and to create an empty cell, 

select the cell and click the Insert Cells Right icon. For example, suppose that 

the data in the fifth row of the Marks worksheet has to be shifted from C5-F5 to 

D5-G5. To do so, select the cell C5 and click the icon. 

Insert Columns 

 

 

In order to insert a column, select the column where you want to insert and click  

the Insert Columns icon. For example, to insert a new column between E and F in 

the Marks worksheet, select the column F and click the icon. 

 
Insert Rows 

 

 
In order to insert an empty row in a worksheet, select the row where you want to 

insert the new row and click the Insert Rows icon. For example, if you want to 

insert a new row between rows 4 and 5 in the Marks worksheet select the row 5 

and click the icon. 
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TWO MARK QUESTIONS: - 

1. Define Data, Information 

The term data comes from the word datum, which means a fact. The data is as fact about 

people, places or some entities. 

Information is defined as a set of processed data that convey the relationship between data 

considered. Processing means to do some operations or computations on the data of different 

variables to relate them so that these data, when related, convey some meaning. 

2. What is a Database?  

A database is a repository of collections of related data or facts.It arranges them in a 

specific structure. 

3. What are the various Data types? 

The Data types can be Character, Number, or Boolean. The numeric data type can be 

integer, float, double precision, date, time, etc. 

4. What are the steps involved in data processing? 

 Data Collection 

 Verification  

 Validation of data 

 Report Generation. 

5.Define File, Record, Field. 

File 

The entire collection or related data in one table is referred to as a File or a Table. 

Record 

Each row in a table represents a Record, which is a set of data for each database entry 

Field 

Each table column represents a Field, which groups each piece or item of data among the 

records into specific categories or types of data. 

6. On the basis of the conceptual structure how can the database be classified? 

 Searching 

• Sorting 

• Merging 

• Performing Calculations on data 

7. DATABASE 
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• Filtering 

• Editing the database 

• Report Generation 

7. What are the primary characteristics distinguish a Flat-files database from a relational      

database? 

1. Flat-file databases cannot form relationships with other tables and are best suited 

for home or small business users. 

2. Relational database are very powerful because they have the ability to form 

relationships between tables. 

8. What is Searching? 

Searching is a process to select a desired specific data from a database. 

9. What is Sorting? 

Sorting is the process of arranging the data in a table in some order. 

10. What does it means to ‘filter; database records? 

Filters are a feature for displaying and browsing a selected list or subset of records from a 

table. The visible records satisfy the condition that the user sets. Those that do not satisfy the 

condition are hidden. 

11.  What is flat file database? 

A database file that consists of a single data table is a Flat-file database. Flat-file 

database can be quite useful for certain singleuser or small-group situations, especially for 

maintaining lists such as address lists or inventories 

12. What is Relational database? 

A relational structure represents a database made up of a set of related tables. In a 

relational database, one or more common fields existing in two or more tables create a 

relationship between these tables. The common field or fields are called the Keys. 

13. What is a primary key? 

A primary key is a key that uniquely identifies a record in a database table. In relational 

databases, a primary key can consist of one or more fields. 

Examples: Employee record. 
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14. What is meant by Editing a Data? 

Editing is a process of performing corrections on the existing data, deleting the existing 

data, field(s), or record(s), adding new data, field(s), record(s) or changing the format of the 

database, and so on. 

15. What is a Database Management system? 

A DMBS is a program, or collection of programs that allows any number of users to 

access data, modify it (if necessary), and construct simple and complex requests to obtain and 

work with selected records. 

16. List out the three general categories of DBMS. 

1. Entering data into the database. 

2. Reordering records in the database. 

3. Obtaining subsets of the data. 

16. How will you create a new database? 

To do this, open StarOffice Base or if a StarOffice window is open, click on  

 File NewDatabase. The Database Wizard dialog box appears on the screen. 

17. What is sorting? What are the steps involved in sorting process? 

Once the records have been entered into the table, Star Base allows you to rearrange them 

by sorting them. You can sort the records in ascending or descending orders based on any field in 

the table. 

1. Open the table that you want to sort. 

2. Select the field you want to sort by clicking on the field name at the top of the table. Note that 

the entire column becomes highlighted. Then click on the Sort Ascending icon. The records in 

the table are displayed in the ascending order of the specified field.  

3. To sort the records in the descending order, select the field and click on the Sort Descending 

icon.  

 

18. What is meant by multiple sorting? 

Multiple sorting means sorting on more than one field of a table at the same time. 
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19. What is meant by SQL? 

Every DBMS supports a language that is similar to a programming language. This 

language, called the Structured Query Language (SQL), is designed specifically for 

communicating with a database using statements that are closer to English than to 

Programming languages. 

20. What function we can do by using SQL? 

• Search the database to locate records 

• Establish relationships or links between tables to update records. 

• List a subset of records. 

• Perform calculations. 

• Delete obsolete records 

• Perform other data management tasks 

21. What is Query and what it is used for? 

Queries are special views of the data in a table. Unlike sort, the output from a query does 

not affect the original table. The result from a query is always stored separately and can be viewed 

at any time. 

22. What is a filter? What are the types of filters available in star base? 

A filter is also a type of query. It is also used to select and display records, which match a 

certain condition. The remaining records are hidden form the user. The difference between query 

and filters is that queries can be saved for later use. StarOffice Base allows you to use two types 

of filters. They are AutoFilter and StandardFilter. 

23. What is form? 

A form is simply a screen that displays the fields of a record in a well-spaced out manner. 

24. What is report? 

A report is printed information that is assembled by gathering data based on user supplied 

criteria. 

25. What is DBMS? 

A DBMS is a software tool that allows users to create database tables and that provides 

access to multiple users. 
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FIVE MARK QUESTIONS: - 

1. What are the disadvantages of manual Data processing? 

1. The efficiency and correctness of data processing are limited to the capabilities of the   

individual who is processing the data. 

2. Manual methods take more time. 

3. In general human beings are liable to make computational and parallax errors. 

4. Manual data processing involves use of papers at each stage. Preservation and maintenance of 

large volume of paper records becomes difficult and unmanageable. 

5. Implementation of corrections, changes and modifications are tedious in manual data 

processing. 

2. What are the advantages of Electronic computerized Data processing? 

1. Once we collect and enter the data into a computer system, We can perform other operations 

with less manual labour. So,manpower is considerable saved. 

2. Though it takes some time to develop, test and put the required computer programs to use, the 

processing speed is fast, reducing the processing time, in certain cases, from man-years and man-

months to minutes and seconds. 

3. The chances of errors are less in computerized data processing. 

4. We can store large amount of the data and information in the computer storage medium, which 

is compact. Hence, we need not store bundles of paper records, thus saving space. 

5. Today computer networks are so common that we can share data and resources from one 

computer system to the other at a very fast speed and with very little effort, as in the case of 

railway and airline reservation systems. 

6. It is easy to edit the data including correction, changes and modifications. 

7. Computerized database is highly effective for searching, sorting and merging files and for other 

data manipulation activities. 

3. What are the various manipulations of a database in star office base? 

• Searching 

• Sorting 

• Merging 

• Performing Calculations on data 

• Filtering 

• Editing the database 

• Report Generation 

 



www.Padasalai.Net

 Star Office   & C++           www.padasalai.net 

            P.CHANDRASEKARAN M.C.A, B.ED, [PG ASST IN C.S]     -             99420 12999                                         38 
 

Searching 

 Searching is a process to select a desired specific data from a database. 

 Searching is done using database commands on the relevant fields. 

Sorting 

Sorting is the process of arranging the data in a table in some order. In the above example, 

we may arrange the list of staff – members in an alphabetical order or according to the seniority in 

position or date of joining or in any other order we like 

Merging 

Merging is a process of joining data from two or more tables of the same or different 

databases. For example, in a student database, you may have mark lists for different classes. 

Performing Calculations on data 

We may do any kind of arithmetic calculations on the data stored in the database. For 

example, to obtain the total marks of all the subjects of a student, you may add the marks in the 

concerned fields of the database and store them in a separate field. 

Filtering 

There are times when viewing the entire table is unwieldy. Using a Filter is a way of 

limiting the information that appears on screen. Filters are a feature for displaying and browsing a 

selected list or subset of records from a table. The visible records satisfy the condition that the 

user sets. Those that do not satisfy the condition are hidden. 

Editing the Database 

Editing is a process of performing corrections on the existing data, deleting the existing 

data, field(s), or record(s), adding new data,field(s), record(s) or changing the format of the 

database, and so on. 

Report Generation 

You may generate any desired report, from the data of the database. For example, in the 

case of student database, you may generate a report of all the students who have scored marks less 

than the minimum marks required for a pass, and another report that gives the list of passed 

students, and so on. 

4. Explain different Database types 

1. Flat – File database 

2. Relational database 

3. Hierarchical database 

4. Network database 

5. Object-Oriented database 
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Flat – File Database 

A database file that consists of a single data table is a Flat-file database. Flat-file 

database can be quite useful for certain single user or small-group situations, especially for 

maintaining lists such as address lists or inventories. Data that is stored, managed, and 

manipulated in spreadsheet is another example of a flat-file database 

Relational database 

A relational structure represents a database made up of a set of related tables. In a 

relational database, one or more common fields existing in two or more tables create a 

relationship between these tables. The common field or fields are called the Keys. 

A primary key is a key that uniquely identifies a record in a database table. In relational 

databases, a primary key can consist of one or more fields. 

Hierarchical database 

The hierarchical database structures were primarily used on Main Frame computers. In 

hierarchical databases, records are organized in a tree like structure by type. The relationship 

between record types is said to be a parent-child relationship, in which any child type relates only 

to a single parent type. 

Network database 

The Network database is very similar to the hierarchical structure except that any one 

record type can relate to any number of other record types. 

Object oriented database 

 The object oriented structure groups data items and their associated characteristics, 

attributes, and procedures into complex items called objects. 

An object is defined by its characteristics, attributes and procedures. An object’s 

characteristics can be text, sound, graphics, and video. Examples of attributes might be colour, 

size, style, quantity, and price. 

5. What is a filter? What are the types of filters available in star base? Give its function? 

A filter is also a type of query. It is also used to select and display records, which match a 

certain condition. The remaining records are hidden form the user. The difference between query 

and filters is that queries can be saved for later use. StarOffice Base allows you to use two types 

of filters.  

They are AutoFilter and StandardFilter. 
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AutoFilter: 

The AutoFilter icon is available on the toolbar. Click on        this icon to display 

only the records, which match the value of the current field. 

StandardFilter: 

Filter used with a condition called Default Filter. The condition can be specified by clicking on 

the Standard Filter       icon on the toolbar. 

 

We want to list all the records where the marks scored by the marks scored by the students 

in Maths is greater than 90. 

1. Open an existing query form the Queries pane by double clicking on it. For example 

Query_Marklist. 

2. Click the Standard Filter icon from the main toolbar. A Filter window will appear. 

3. Select Maths in the Field name box. 

4. Select > operator in the Condition box. 

5. Type 90 in the Value box. 

6. Click on OK 

 

6.What are the steps involved in designing a form in star base? 

A form is simply a screen that displays the fields of a record in a well-spaced out manner 

To design a form in Star Base, follow the procedure given below: 

1. Select Form icon from the <Database> pane and then select ‘Use Wizard to Create Form’. 

2. Select the table or query for which the form is to be designed. The field names of the selected 

table or query are displayed in the ‘Available fields’ text area. 

3. Select the field names that you would like to include in the form using the > or >> button and 

then click the Next button. 

4. Next, StarOffice Base displays ‘Set up a subform’ window. Select the ‘Add Subform’ 

checkbox, if you want to insert another form with within this form else click Next. The Style 

icons show you how the form will look if it is selected. Click on the Style icon and click on the 

Next button. 

5. The next window to selecting the data entry mode. Click on the radio button to choose whether 

the form is to be used only for entering new data or to be used for displaying all data. 
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6. The next window Form Wizard – Apply Styles specifies the form style. The page style 

decides the font attributes like font type, size color and background of the text in the form. The 

Field border specifies the field border style for the form. 

7. Next, Set the name of the form window appears asking for a name for the form. Type the 

name of the form and click the Finish button. 

7. What are the steps involved in generating a report? 

A report is printed information that is assembled by gathering data based on user supplied 

criteria. 

1. Creating a report in StarOffice Base is very similar to creating a query or a form. To create a 

report, right click on Reports in the <Database> pane. Then click ‘Use Wizard to Create 

Report’. 

2. As in the case of form, this window displays a list of available tables and queries. Select the 

table or query you want. A list of fields from the selected table or query appears on the screen. 

Select the fields to be included in the report by using the > or >> buttons and click on the Next 

button. 

3. Next, a Labeling fields window appears with the field and Label. Modify the labels for the 

corresponding fields, if you want. Click on the Next button. 

4. The Grouping window is displayed , This window is used to specify the fields based on which 

the records can be grouped together. 

5. The Grouping window is followed by the Sort Options window . Here the sort criteria, if any, 

can be specified. 

6. The Choose Layout window as shown in  displayed, here you can customize the report by 

selecting the Layout of Data, Layout of Headers and Footers and Orientation options for the 

report. 

7. The Report Wizard window which is displayed, next, allows you to choose Static or 

Dynamic Report. 

8. Enter the title for the report and click the Finish button to view the report. 
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TWO MARK QUESTIONS: - 

1. What is Multimedia?  

Multimedia is a computer based presentation technique that incorporates text, graphics, 

sound, animations and video elements. 

2. What is Morphing?  

   Morphing is a technique by which you can blend two or more images to from a new image. 

3. What is Warping?  

Warping is a technique of distorting a single image to represent something else. 

4. Compare Loss less and Lossy video compression?  

Write about types of Video Compression?  

Loss less:Retains the exact image throughout the compression. 

Lossy:Provides a higher ratio of compression but result in some loss of quality. 

5. What are the uses of Morphing and Warping?  

Most modern multimedia applications, particularly games, combine these techniques with 

virtual reality to create an environment in which gives the viewer the felling that is part of that 

environment 

6. Name the special software used in the multimedia content?  

Flash, Dreamweaver and Maya are the special software used in the multimedia content. 

7. Write the steps for creating 3-D animation?  

1. Modeling 2. Animating 3. Rendering 

8. What are the two categories of 2-D animation?  

What are the classifications of 2-D animation?  

1. Cell-based animations 2. Object-based animations 

9. Write a note on AVI format?  

 AVI means Audio Video Interleave. It was developed by Microsoft in 1992. 

 It is a very common format on the internet. 

 The AVI format have the extension .avi 

10. Write the full forms of following 

MIDI  → Musical Instrument Digital Interface 

AIFF → Audio Interchange File Format 

AVI  → Audio Video Interleave  

MPEG → Moving Pictures Experts Group 

 

8. INTRODUCTION TO MULTIMEDIA 
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11. Define MMS? 

It stands for Multimedia Messaging System. It is an application that allows you send and 

receive messages over cell phones. 

12. What is Sound Forge? 

We add special effects, such as echo, fade in, and fade out, by using sound editing 

programs are called as Sound Forge. 

13. What is Inline sound and video?  

 Sound and Video in multimedia applications can be played “inline”using a “helper”. 

 When sound or video is included as part of a web page, then it is called inline sound or 

video. 

14. What are the objects based animation? 

  It also referred to as slide or path animation. 

  It created by moving an object across a screen. 

  This animation is usually seen in a computer game. 

 Ex:A ball moving across the screen 

15. Define Vector graphics? 

  It helps in rendering the image effectively on the screen. 

  Many vendors provide special hardware called vector graphics. 

  Cards to improve the efficiency in the display of images. 

16. What is sampling? 

To convert the analog sound waves into a digital format. This conversion is called 

sampling. 

17. Write a note on shockwave format of sound file? 

 The shockwave format was developed by Macromedia and is used to store multimedia 

components created using Flash. 

 This format requires an extra component to play. Files in the shockwave format have the 

extension is .swf 

18. Define compression? 

Compression is a technique by which a recurring set of information is identified and 

replaced by a single piece of information. There are two types of video compressions: 

 Lossless compression 

 Lossy compression 
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TWO MARK QUESTIONS:- 

1. What is the use of master page in presentation?  

Master page can be used to specify basic background information that needs to be 

included in all the slides. For example, you can insert a company logo to the master slide and it 

will appear in all the slides. 

2. What are the various formats for viewing a presentation? 

Normal View, Outline View, Notes View, Handouts View, Slide Sorter View 

3. How to change the slide background?  

 We can change the background color or the background fill of the current slide or all of 

the slides. 

 Choose Format→Page→Background. Select the background fill from the options. 

4. What can you do with the left pane of the presentation window?  

Slides pane on the left displays a thumbnail image of the slide and allows us to rename 

delete or rearrange them. 

5. What is meant by “Rehearse Timings”?  

How will you record a show with rehearse timings?  

 Star office assists in defining the right rehearse timings for automatic slide changes. Star 

Office records the display time for each slide. 

 The next time you play the show with automatic slide changes, the timing will be 

recorded. 

6. What is the use of slide sorter view?  

 It allows to view miniature images of all the slides in the presentation 

 This view is also used to rearrange slides 

7. How will you insert pictures in presentation?  

  To insert a picture in a slide, choose Insert→ Picture →From File or click the Insert 

Picture icon from the Insert toolbar 

  Choose the desired picture to be inserted from the open dialog box. 

8. How will you rename a slide in Impress? 

Select the slide, which you want to rename and choose Slide →Rename Slide or right 

click on the slide and choose Rename Slide 

9. What is Custom Animation?  

  It displays various options that allow you to add or modify animation effects to elements 

of a slide. 

9. PRESENTATION 
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 Choose Custom Animation form Slide Show→Custom Animation 

10. How will you customize a presentation?  

 Choose Slide Show→Custom Slide shows, and then click New 

 It display the Custom Slide shows dialog box. 

 Enter a name for your slide show the Name box 

 You can change the order of the slides in your custom slide show,by dragging and 

11. How will we hide a slide? 

 Select the slide(s) that we want to hide the slide show 

 Choose Slide Show Show/Hide Slide 

 The slide number is struck out, but it is not removed from our presentation 

12. How will insert and delete slide? 

 To insert a slide, click the Slide button in the Presentation toolbar or choose 

InsertSlide from the menu bar. 

 If you want to delete a slide, select the slide, which you want to delete in the Slides 

Pane and press Delete key or right click on the slide, and choose Delete Slide. 

13. How will you start a presentation? 

Start slide show by choosing Slide Show Slide Show or press the F5 key. 
 

14. How will you create handouts in Star Office Impress?  

 Click the handout view tab in the view bar. 

 Open the layout pane in tasks pane  

 Choose a layout to specify how many slides are printed on a single sheet of paper. 
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TWO MARK QUESTIONS 

1. What is Object?  

 A group of data and the operations are termed as object. 

 The operations represent the behavior of the object. 

2. What is Encapsulation?  

The mechanism by which the data and functions are bound together within an object 

definition is called as encapsulation. 

3. What is Polymorphism?  

The ability of an object to respond differently to different messages is called as 

polymorphism. 

Ex:  

Draw( side)  

Draw (length, breadth)  

Draw(radius)  

4. What is meant by Inheritance?  

The process of acquiring the Base class properties is called Inheritance. 

5. What is the significance of an object? 

 An object is a group of related functions and data that serves those functions. 

  An object is a kind of self-sufficient “subprogram” with a specific functional area. 

6. List any two advantages of Object Oriented Programming?  

 Class data type allows programs to organize as objects that contain both data and 

functions 

 Data hiding or Abstraction of data provides security to data, as unrelated member 

functions cannot access its data. 

7. How is polymorphism different from inheritance? 

 Polymorphism reduces software complexity, as multiple definitions are permitted to an 

operator or function 

 Inheritance allows a class to be derived from an existing class, thus promoting reusability 

of code. 

8. What is class? 

The data type Class conventionally represents an object in the real world. Class is a 

template for entities that have common behaviour. 

 

1. OBJECT ORIENTED CONCEPTS USING C++ 
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TWO MARK QUESTIONS: - 

1. Define Tokens?  

 The basic types are collectively called as Tokens.  A token is the smallest individual unit 

in a program. 

Tokens are classified as  

Keywords, Identifiers, Constants, Operators and Punctuators 

2. What are keywords? Give examples?  

  Keywords have special meaning to the language compiler.  These are reserved words for 

special purpose.These words cannot be used as normal identifiers. 

Examples:  if, else, for, do, while, switch, case, break 

3. What is meant by the Identifiers? Give an example. 

Identifiers are also called as variables. Variables are memory boxes that hold values or 

constants. A variable name must begin with an alphabet or underscore followed by alphabets or 

numbers.  

Example: _test, test, sum12. 

4. What are Constants? Give an example. 

Constants are data items whose values cannot be changed. A constant is of numeric or 

non-numeric type. Numeric constants consist of only numbers, either whole numbers or decimal 

numbers. Integers, floating-point are numeric constants. 

Example: 3,’A’. 

5. What are Character Constant? Give Example. 

Character constant is a constant that contains a single character enclosed within single 

quotes. It can be any character as defined in the character set of C++ language Certain special 

characters like tab, backspace, line feed, null, backslash are called as non-graphic character 

constants. 

Example: ‘A’,’ b’. 

6. Write a note on String Literal?  

 It is a sequence of characters by double quotes.  These are treated as array of characters. 

Each string literal is by default with special character ‘\0’ which marks the end of a string.  

Ex:  “Mohit” 

7. What is an Operator and Operand? Give suitable example. 

Operator specifies an operation to be performed that yields a value. An operand is an 

entity on which an operator acts.  

2. OVERVIEW OF C++ 
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For example: 

RESULT = NUM1 + NUM2 

NUM1 and NUM2 are operands. + is the additional operator, that performs the addition 

of the numbers. The result (value) generated is stored in the variable RESULT 

8. List out the Relational operators with C++?  

 Relational operators are used to compare numeric values. 

The relational operators are 

 = = equal to  

 >greater than 

 <lesser than 

 >=greater than or equal 

 <=lesser than or equal 

 != not equal to 

9. Write the conditional operator with example?  

A conditional operator (? :) is also called as ternary operator. 

General Syntax: 

E1?E2:E3 where E1,E2,E3 are operands 

Example: 

max = (num1 > num2) ? num1 : num2;  

10. Write a note on assignment operators?  

  = is the simple assignment operator. 

 It is used to assign the result of an expression (on the right hand side) to the variable (on 

the left hand side of the operator). 

 Ex: - int  a=10; 

11. What are the two important purposes of void type? 

 To indicate that a function does not return a value  

 To declare a generic pointer 

12. Give two uses of void data type?  

 It indicates the compiler that the function does not return a value  

 It indicates that it holds nothing 

13. What are Logical Operators? Give an example. 

Logical operators combines the results of one or more conditions. The various logical 

operators are && (AND) , || (OR) , ! (NOT) 

Example: Result = (c = = d) && (choice != term) 

The values stored in Result  is 0 (False) 
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14. What is the use of the operators related to pointer variable?  

What are pointer variables?  

 Pointer variables can store the address of other variables.  But the address stored in 

pointer variables should be of the same data type a pointer variable is pointing to. 

 Ex: The asterisk ( * ) is used to declare the pointer variable. It is used to display the contents 

stored at a location. It is an unary operator. 

15. How are the pointer variables declared?  

int * iptr; 

Where int indicates that the pointer will point to an int data type 

* instructs the compiler that the variable is pointer 

iptr Name of the pointer variable 

16. What are Data types? Give an example. 

Data Types are the kind of data that variables hold in a programming language. The ability 

to divide data into different types in C++ enables one to work with complex objects. 

Example:  int, float, char. 

17. What are three categories of Data Types? 

They can be broadly classified into the following three categories. 

 User defined type 

 Built-in type 

 Derived type 

18. Write about User Defined Data Type?  

User Defined Data Type enables a programmer to invent own data type and define values 

it can assume.  This helps in improving readability of the program. 

19. Write about the impact of modifiers in C++?  

  Unsigned modifies the range of the integer values as the sign bit is also used to store data. 

Long increase the bytes for a particular data type, thus increasing the range of values. 

20. Write a note on enumerated data type and give the syntax and examples?  

Enumerated data type helps users in creating a list of identifiers, also called symbolic 

numeric constants of the type int. 

Syntax: enum data type identifier (value1, value2,.); 

Example: enum holidays (Sunday, Saturday) 

21. Write about Type definition and syntax in C++?  

Users can define a variable that would represent an existing data type.It allows users to 

define such user defined data type identifier.  

Syntax: typedef data_type user_defined_data_type_identifier 
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Example: typedef  int marks; 

22. What is type cast? Write note on type cast?  

It refers to the process of changing the data type of the value stored in a variable.  Type 
cast is achieved by prefixing the variable or value with the required data type.  
 
syntax  :  (data type) <varaible/value> or data type (variable/constant)  

 
23. What are the four storage specifiers in C++?  

The four storage specifiers are  

 Auto    

 Static 

 Extern 

 register  

24. List out user defined data types? 

1. Structure 2. Union 3. Class and enumeration 

25. Define size of operator in C++? 

Size of is an operator. It returns the size (memory requirement) in terms of  bytes, of the 

given expression or data type. 

26. What is Variable? 

Variables are user defined named entities of memory locations that can store data. 
 

Example:  int a; 

27. What is the use of the operator related to pointer variable? 

The ‘ &’ operator :  
When we type int num1=10; 

1) Reserves space in the memory to hold the integer value 

2) Associates the variable name num1 with a memory location 

3) Stores the value 2 at this location in the memory 

The asterix ( * ) : 

1) Used to declare a pointer variable 

2) Used to display the contents stored at a location (value at the address operator) 

3) It is a unary operator 

28. Write any four Punctuators in c ++ and write a line about them. 

;   Terminates a C++ statement. 

//   Treats statements prefixed with this as comments. 

/* */   Blocks enclosed within these characters are treated as comment. 

 [ ]    Index value for an element in an array is indicated within these brackets. 
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29. What are the operators used only by the C++? 

The following operators are specific to C++. 

::  .*  ->* 

30. How is a pointer variable different from ordinary variable?  

Variable Pointer 

1. Variables are user defined name entities of memory locations that can store data 

A pointer is a variable that hold a memory address 

2. Special characters are not allowed to declare a variable 

* is used to declare a pointer variable 

31. Write the c ++ equivalent expressions using the conditional operators? 

 i. f=0.5 if x=30 otherwise f=5 

 ii. fn=0.9 if x>=60   otherwise fn=0.7 

Ans: 

i) (x=30)   ?  f=0.5  : f=5; 

ii) (x>=60) ? fn=0.9  : fn=0.7; 

32. What is escape sequences? Give an example  

Certain special characters like tab, backspace, line feed, null, backslash are 

called as non-graphic character constants. These characters are represented using escape 

sequences. 

Example : \n , \t 

33. What is association? 

The operands and the operators are grouped in a specific logical way for evaluation. This 

logical grouping is called as association. 

34. Find the output of the following c ++ programs? 

X=5, f=6 

C= x++ + ++f; 

Output :  12 

35. Find the output of the following c ++ programs? 

X=10, f=20; 

C= x++ + ++f; 

Output :  31 

36. What is the value stored in the variable? 

X=10,f=20,c= x++ + ++f; 

C=  ? , x= ? ,  f= ? 

Ans : c is 31     x is 10      f is 21 
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37. How are pointer variable declared?  

  

int  *  iptr 

 

                    Name of the pointer variable 

Instructs the compiler that the variable is pointer. 

Indicate the pointer variable  

 

38. What will be values stored in the variable x,f and c in the following snippet? 

int x,f,c; 

x=12,f=22. 

c= x++ + ++f; 

Ans: 35 

39.  Evaluate the following C++ expressions, Assume a = 5, b =3, d =1.5, c is integer and f is 

float. 

A. f = a+b/a 

B. c = d * a+b 

Ans :  

a. F= a + b/a;  F= 5 + (3/5)  F=5+0.6 ANS: F=5; 

 

b. C=(1.5*5) +3;  C=7.5 + 3    ANS: C=10 
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TWO MARK QUESTIONS: - 

1. What are the different statements in C++? 

 Input/output 

  Declaration 

  Assignment 

  Control structures 

  Function call 

  Object message 

  Return 

2. What are the various sections in C++ program?  

A C++ program has primarily three sections viz., 

 Include files 

 Declaration of variables, data type, user defined functions  

 main( ) function 

On successful compilation, when the program is executed the main() function will be 

automatically executed. 

3. What do you know about assignment statements in C++?  

  An assignment statement, assigns value on the right hand side of an expression to the 

variable on the left hand side of the assignment operator.  = is the assignment operator.  

Ex:  num=10; 

4. What is the use of declaration statement? 

 Declaration statement introduces a variable name and associates it with a specific data 

type 

 A variable gets defined when memory is set aside  

 Some variables also get defined when they are declared 

 Pointer variables get defined only when memory is fetched. For example by using new 

memory operator 

5. What are the control structures? What are the two main categories of control structures?  

  Program statements that cause jump of control from one part of a program to another is 

called as control statements or control structures. 

The two main categories of control structures are Decision making statements and looping 

statements. 

 

3. BASIC STATEMENTS 
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6. Write the syntax of nested if statement?  

The statement sequence of if or else may contain another if statement ie., the if else 

statements can be nested within one another. 

Syntax:-  

if (expression -1) 

if (expression -2) 

{ 

 action -1; 

} 

else 

{ 

 action-2; 

} 

else 

{ 

 action-3; 

}; 

7. What is the purpose of break statement? 

 Break statement would exit the current loop only. 

 It accomplishes jump from the current loop 

8. What is the purpose of continue statement?  

The continue statement forces the next iteration of the loop to take place, skipping any 

code following the continue statement in the loop body. 

9. Write the rules for the formation of nested loops?  

 An outer loop and inner loop cannot have the same control variable, as it will lead to 

logical errors. 

 The inner loop must be completely nested inside the body of the outer loop 

10. What is  loops? What are the three kinds of loop in C++? 

Loops execute a set of instructions repeatedly for a certain number of times. 

There are three kinds of loops in C++ 

1.for loop  2. while loop   3.do .. while loop. 

11.What is meant by the compiler? 

Compilers create object files from source code. Compilers are translator programs that 

create a machine-readable program from the source code. Compiler checks for the grammar of 
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language (syntax). An object file is created from an error free source code. The object file is 

linked with the essential libraries to generate an executable file. 

 
12. What is control statement of control structure? What are the two category of control 
structure? 

Program statements that cause a jump of control from one part of a program to another are 
called Control Structures 

 
 Selection or decision making Statements 

 Looping Statements 

13.Write the different between while , do…while loops. 

While Do…while 

Is called as the entry-check loop. Is called as the exit-check loop. 

The body of the while loop will be executed  
only if the test expression results true placed 
in the while statement. 

As the condition (test expression) marks the 

last statements of the body of the loop. 

Syntax: 
do 
{ 
   action block; 
} while <(condition)> 

Syntax: 
while <(condition)> 
{ 
   action block; 
}  

 

14. What are the different between continue statement and break statement? 

Continue Break 

The continue statement forces the next 

iteration of the loop to take place 

Break statement would exit the current loop 

only. 

Skipping any code following the continue 

statement in the loop body. 

It accomplishes jump from the current loop 

 

 

15. What is the different between if…else and switch statement? 

if…else Switch 

if .. else statement which chooses between 
two alternatives. 

This is a multiple branching statement 

if .. else statement which chooses between 
two alternatives , executes the chosen block 
based on the condition. 

where, based on a condition, the control is 
transferred to one of the many 
Possible points. 
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16. What is for loop? Give its syntax. 

Loop is an entry controlled loop and is used when an action is to be repeated for a 

predetermined number of times.  

Syntax: 

for (initial value ; test-condition ; increment) 

{ 

action block; 

} 

17. What is switch statement and give it syntax? 

This is a multiple branching statement where, based on a condition, the control is 

transferred to one of the many possible points. 

Syntax: 

switch (expression) 

{ 

case 1 : action block 1; 

break; 

case 2 : action block 2; 

break; 

case 3 : action block 3; 

break; 

default : 

action block 4; 

} 

18. What is the use of insertion or put to operator? 

 The operator << is called the insertion operator or put to operator. It directs the contents of 

the variable to its right to the object to its left. 

 For example: 

int marks = 85; 

cout << marks; 

19. Write the syntax for if -else statement? 

Syntax: 

if (condition/expression) 

{ 

action block; 

} 
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else 

if (condition/expression) 

{ 

action block; 

} 

FIVE MARK QUESTIONS: - 

1. Explain switch statement with a suitable example: 

It is a multiple branching statement where based on a condition, the control is 

transferred to one of the many possible points. 

Syntax: - 

switch(expression) 

{ 

case 1: action block1;  

break; 

case 2: action block2;  

break; 

case 3: action block3;  

break; 

default: action block;  

break; 

} 

Example: - 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int a, remainder; 

cout << “\nEnter a number ...”; 

cin >> a; 

remainder = a % 3; 

switch (remainder) 

{ 

case 1 : cout << “\nRemainder is one”; 

break; 

case 2 : cout << “\nRemainder is two”; 
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break; 

default: cout << “\nThe given number is divisible by 3”; 

break; 

} 

getch();  

} 

The above program displays 

 Remainder is two if a = 5 or so 

 The given number is divisble by 3, if a = 9 or so 

Or in other words the above program checks for divisibility by 3 and prints messages accordingly. 

2. Explain Entry-check loop with example? Or Explain while loop with example?  

While loop is called as the entry-check loop. 

 The body of the while loop will be executed only if the condition is true. 

 The control exits the loop once the condition is evaluated to false. 

Syntax:- 

while (condition) 

{ 

action block 

} 

Example:- 

#include<iostream.h> 

#include<conio.h> 

main() 

{ 

clrscr(); 

int n=2; 

while(n<6) 

{ 

cout<<n*n<<’\t’; 

n=n + 1; 

} 

getch(); 

} 

Output:- 

4 9 16 25 
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Working of loop:- 

 Initializes the control variable num=2 

 num<2 is evaluated, control is transferred to step 3, if the condition is TRUE 

 Print the square of the value stored in num 

 Increment num by 1 

 Control is transferred to step 2 

 End 

3. Explain Exit-check loop with example? Explain do…while loop with example?  

Do….while is called as exit-check loop. 

The condition marks the last statement of the body of the loop. 

Syntax:- 

do 

{ 

action block; 

} while (condition); 

Example:- 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

clrscr(); 

int n = 2; 

do 

{ 

cout << n * n << ‘\t’; 

n =n +  1; 

} 

while (n< 6); 

getch(); 

} 

Output:- 

4 9 16 25 
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Working of loop:- 

1. Initializes the control variable num=2 

2. num<2 is evaluated, control is transferred to step 3, if the condition is TRUE 

3. Print the square of the value stored in num 

4. Increment num by 1 

5. Control is transferred to step 2 

6. End 

4. Explain Entry-controlled loop with example? or  Explain For loop with example?  

 for loop is an entry controlled loop 

 It is used when an action is to be repeated for a predetermined number of times. 

Syntax:- 

for(initial value; test-condition; increment) 

{ 

action block; 

} 

Working of loop:- 

 The control variable is initialized first. 

 Test condition is evaluated. 

 The body of the loop is executed only if the condition is true. 

 The control variable is incremented and the test condition will be evaluated before the 

body of the loop is executed. 

 The loop is terminated when the test condition is false 

Example:- 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int i,fact = 1; 

for(i = 1; i < 6; i++) 

fact *= i; 

cout << “\nThe factorial of the number is ..” << fact; 

} 

Output: 

120 
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5. Explain the ‘Nested.. if’ statement with an example in C++?  

The statement sequence of if or else may contain another if statement 

ie., the if else statements can be nested within one another. 

Syntax:-  

if (expression -1) 

if (expression -2) 

{ 

 action -1; 

} 

else 

{ 

 action-2; 

} 

else 

{ 

 action-3; 

}; 

 

Example:- 

if (grade = = ‘A’) 

if (basic > 5500) 

incentive = basic * 10/100; 

else 

incentive = basic * 5/100; 

else 

cout << “Try to attain Grade A”; 

Working of the above example : 
 
 Grade = ‘A’ and basic == 5501, then incentive gets the value 550. 

 Grade = ‘A’ and basic = = 5000, then incentive gets the value 250. 

6. What is if and  if…else Statement explain with an example?  

if statement :  

Is the simplest of all the decision statements. It is implemented in two forms 

 Simple if statement 

 if .. else statement 
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Syntax : 

if (condition/expression) 

{ 

action block; 

} 

Example: 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 

int a; 

clrscr(); 

cout << “\nEnter a number “; 

cin >> a; 

if ( a%2 == 0) 

cout << “\nThe given number “ << a << “is even”; 

} 

if .. else: 

if .. else…statement which chooses between two alternatives , executes the chosen block 

based on the condition. 

Syntax: 

if (condition/expression) 

{ 

action block; 

} 

else 

if (condition/expression) 

{ 

action block; 

} 

Example: 

# include <iostream.h> 

# include <conio.h> 

void main() 

{ 
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int a; 

clrscr(); 

cout << “\nEnter a number “; 

cin >> a; 

if ( a%2 == 0) 

cout << “\nThe given number “ << a << “is 

even”; 

else 

cout << “\nThe given number “ << a << “is 

odd”; 

getch(); 

} 

Output: 

In the above program “The given number 10 is even” is printed if the expression is 

evaluated to true, otherwise statement following else option will be executed. 
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TWO MARK QUESTIONS: - 

1. What is functions? 

  Functions are the building blocks of C++ programs. 

  It is also the executable segments in a program. 

 The starting points for the execution of a program is main( ). 

2. What are the advantages of using functions in C++?  

 Reduce the size of the program 

 Induce reusability of code 

 A function can be shared by other programs by compiling it separately and loading them 

together. 

3. What is the main purpose of function prototype?  

 It is help the compiler to check the data requirement of the function. 

 With function prototyping, a template is always used when declaring and defining a 

function. 

 When a function is called, the compiler uses the template to ensure that proper arguments 

are passed, and the return value is treated correctly. 

4. What are the two methods used in Functions? 

 Call by value method  

 Call by reference method 

5. Difference between call by value and call by reference?  

Call by value: - 

 The flow of data is always from the call statement to the function definition. 

 Any change in the formal parameter is not reflected back to the actual parameter. 

Call by reference: - 

 Formal and actual parameters in reference type point to the same storage area. 

 Any change in the formal parameter is reflected in actual parameter. 

6. What are the rules for actual parameters? 

It can be passed in the form of constants or variables or expressions to the formal 

parameters, which are of value type. 

7. What is meant by actual parameters and formal parameters? 

 The parameter associated with call statement is called actual parameters 

 The parameter associated with function header is called formal parameters. 

 

 

4. FUNCTIONS 
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8. Write a note on inline functions?  

When the functions are small, the compiler replaces the function call statement by its 

definition ie, its code during program execution. This feature is called as inline function. 

 An inline looks like a normal function in the source file but inserts the function’s code 

directly into the calling program. 

 Inline functions execute faster but require more memory space. 

9. What is the use of scope resolution operator? 

 :: is the scope resolution operator. 

 It is used to refer variables declared at file level. 

 This is helpful only under situations where the local and file scope variables have the same 

name. 

10. Write the general syntax of a function prototype. Give an example. 

Syntax: 

<type > <function identifier > <arguments); 

Example: 

void fun (char); 

int max (int, int); 

11. How many types of variable scopes are there? What are they?  

1. Local scope 2. Function scope 3. File scope 4. Class scope 

12. Write notes on File scope? 

 A variable declared above all blocks and functions have the scope of a file. 

 The file scope variable is the entire program. 

 The lifetime of a file scope variable is the lifetime of a program. 

 

FIVE MARK QUESTIONS: - 

1. Explain call by value method with an example?  

Call By Value: 

 In this method, the called function creates new variable to store the value of the arguments 

passed to it. 

 In this method copies the value of actual parameters into the formal parameters. 

 The function creates its own copy of arguments and then uses them. 

 In this method, the flow of data is always from the call statement to the function definition. 
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Example: - 

#include<iostream.h> 

#include<conio.h> 

void swap(int n1,int n2) 

{ 

int temp; 

temp=n1; 

n1=n2; 

n2=temp; 

cout<<n1<<’\t’<<n2<<’\n’; 

} 

main() 

{ 

int m1=10,m2=20; 

clrscr(); 

cout<<”Before swap”<<m1<<’\t’<<m2<<’\n’; 

cout<<”Calling swap\n”; 

swap(m1,m2); 

cout<<”Back to main values are”<<m1<<’\t’<<m2<<’\t’; 

getch();  

} 

Output:- 

Before swap 10 20 

Calling swap 

20 10 

Back to main values are 10 20 

2. Explain call by reference method with suitable example?  

 In this method, the called function arguments-formal parameters become alias to the actual 

parameters in the calling function. 

 The function is working with its own arguments. 

 It is actually working on the original data. 

 In this method, any change made in the formal parameter is reflected back in the actual 

parameter. 
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Example: - 

#include<iostream.h> 

#include<conio.h> 

void swap(int &n1,int &n2) 

{ 

int temp; 

temp=n1; 

n1=n2; 

n2=temp; 

cout<<n1<<’\t’<<n2<<’\n’; 

} 

main() 

{ 

int m1=10,m2=20; 

clrscr(); 

cout<<”Before swap”<<m1<<’\t’<<m2<<’\n’; 

cout<<”Calling swap\n”; 

swap(m1,m2); 

cout<<”Back to main values are”<<m1<<’\t’<<m2<<’\t’; 

getch(); } 

Output:- 

Before swap 10 20 

Calling swap 

20 10 

Back to main values are 20 10 

3. Define scope? Explain the different types of scopes variables in C++? 

Scope refers to the accessibility of a variable.  

There are four types of scopes in C++. They are 

1. Local scope 2. Function scope 3. File scope 4. Class scope 

1. Local scope: - 

 It is defined within a block 

 It is the block in which it is defined. 

 It cannot be accessed from outside the block of its declaration. 

 A block of code begins and ends with curly braces { }. 

 It exists only while the block of code in which they are declared is executing. 
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2. Function scope: - 

 It is declared within a function is extended to function block, and all sub-blocks. 

 It is accessible in all the sub-blocks. 

 The lifetime of a function scope variable is the lifetime of the function block. 

 The scope of formal parameters is block function scope. 

3. File scope: - 

 A variable declared above all blocks and functions have the scope of a file. 

 The file scope variable is the entire program. 

 The lifetime of a file scope variable is the lifetime of a program. 

4. Class scope: - 

 A Class is a way to bind the data and its associated functions together. 

 Classes provide a method for packing together. 

4. Explain Inline Functions with an example?  

When the functions are small, the compiler replaces the function call statement by its 

definition ie, its code during program execution. This feature is called as inline function. 

 An inline looks like a normal function in the source file but inserts the function’s code 

directly into the calling program. 

 Inline functions execute faster but require more memory space. 

 Reusability of code leading to saving of memory space and reduction in code size 

Example:  

# include <iostream.h> 

# include <conio.h> 

inline float convert_feet(int x) 

{ 

return x * 12; 

} 

void main() 

{ 

clrscr(); 

int inches = 45; 

cout << convert_feet(inches); 

getch(); } 
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TWO MARK QUESTIONS: - 

1. What is array? What are the different types?  

An array is a collection of variables of the same type that are referenced by a common 

name.  

Arrays are two types: One dimensional, Multidimensional. 

2. Give the syntax for Single Dimensional Array? 

Syntax: 

Data type Array-identifier [size]; 

Example: 

int mark[5]; 

3. How will you declare two-dimensional array?  

Syntax: 

Datatype Array-identifier [row] [column]; 

Example: 

int mark[5][5]; 

4. What is sorting? 

One can rearrange the data in a given array either in ascending or descending order. This 

process is called Sorting. 

5. How the strings are treated? Give example? 

 Strings are called as literals, which are treated as single dimension of characters. 

 The declaration of strings is same as numeric array. 

Example: 

char name [10]; 

char vowels[ ] = {‘a’, ‘e’, ‘i’, ‘o’, ‘u’}; 

6. Give the syntax for gets( ) & getline? 

gets (char *) getline:- cin.getline(char *, no.of characters, delimiter); 

7.. Write a note on write () function? 

  It is a member function of standard output stream. 

  All member functions of a class should be accessed through an object / instance of class. 

The two parameters required for write function are identifier string characters and number of 

characters to be displayed. 

 

 

5. STRUCTURED DATA TYPE-ARRAYS 
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8. Give the syntax for strlen( ) & its uses?  

strlen(char *,char *) 

It returns the number of characters stored in the array. 

Ex: 

p=strlen(”pugal”); 

The given string length is 5 

9. Give the syntax for strcpy( ) & its uses?  

strcpy(char * ,char  *) 

Copies source string to target string. 

Ex:a=”pugal” 

strcpy(b,a); 

10. Give the syntax for strcmp( ) & its uses?  

strcmp(char1,char2) 

It compares the two given strings. It returns 0 if strings are equal 

Ex:- strcmp(“Abc”,”Abc”>0) 

11. What is array of strings? Give example?  

 An array of strings is a two-dimensional character array. 

 The size of first index(rows) determines the number of strings 

 The size of second index(column) determines maximum length of each string 

Example:- 

Char day[7][10] = {“Sunday”, “Monday”, “Tuesday”,“Wednesday”,“Thursday”, “Friday”, 

“Saturday” }; 

12. Explain the memory representation of 2-D arrays?  

  A 2-D array is stored in sequential memory blocks. 

  The elements are stored either row-wise manner or column-wise manner 

13. What is matrix? 

A matrix is a set of mn numbers arranged in the form of a rectangular array of m rows and 

n columns. Matrices can be represented through 2-D arrays. 
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TWO MARK QUESTIONS: - 

1. What is a Class? Give example?  

 A class is a new way of creating and implementing a user defined data type. Classes 

provide a method for packing together. 

 A Class is a way to bind the data and its associated functions together. 

Example : 

Class student 

{ 

char name[30]; 

int  rno, m1,m2,m3,tot_marks; 

}; 

2. What is the specifying of a class? (or) What are the two parts of class declaration?  

1. Class Declaration 2. Class Function Definitions 

3. What are the three access specifiers? 

Private: 

Accessible by only its own members and certain special functions called as friend functions 

Pubic: 

 Accessible by members of inherited classes 

Protected: 

 Access allowed by other members in addition to class member and objects 

4. Write the general form of class declaration?  

Class class-name 

{ 

private : 

variable declaration 

function declaration 

protected : 

variable declaration 

function declaration 

public : 

variable declaration 

function declaration 

}; 

6. CLASSES & OBJECTS 
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5. Difference between Data members and Member functions? 

Data Members Member Functions 

Data Members are the data variables that 

represent the features or properties of a class. 

Member Functions are the functions that 

perform specific tasks in a class.  

Data Members are also called as attributes Member Functions are also called as methods 

 

6. Write about Static Data Member?  

1. It is initialized to zero, only when the first object of its class is created. No other initialization is 

permitted 

2. Only one copy of the member variable is created and is shared by all the other objects of its 

class type. 

3. Its scope or visibility is within the class, but its life time is the life time of the program 

7. What is the use of a dot operator? (or) How are the class members accessed?  

The members of a class are accessed using the dot operator. The call statement to the 

function execute ( ) of the class. 

Ex:-  

Stud   . execute( ); 

 Member function 

 Dot operator 

 Object Name 

8. What are the different ways of creating objects?  

 Once a class has been declared, variables of that type can be declared. 

  ‘stud’ is a variable of type student, student is a data type of clas. 

  In C++ the class variables are known as objects. 

  The declaration of an object is similar to that of a variable of any basic type. 

  Objects can also be created by placing their names immediately after the closing brace of 

the class declaration. 

9. Write short notes on memory allocation of objects?  

  No separate memory space is allocated for member function when the object is created. 

  Memory space required for the member variables are only allocated separately for each 

object. 

 Separate memory allocations for the objects are essential because the member variables 

will hold different data values for different objects. 
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10. Write a note on array of objects in C++?  

class product 

{ 

int code, quantity; 

float price; 

public : 

Void assign_data(); 

Void display(); 

}p[3]; 

void main() 

{ 

p[0].assign_data(); 

p[0].display(); 

} 

11. Write the characteristics of member functions?  

  Members functions can access the private data of a class. A non member function cannot 

do so 

  A member function can call another member function directly, without using the dot 

operator. This is called as nesting of member functions 

  Member functions can be of static type 

  The return type of a member function can be of object data type 

12. Define Encapsulation?  

The binding of data and functions together into single entity is referred to as 

encapsulation. 

13. What is meant by Data hiding?  

The members and functions declared under private are not accessible by members outside 

the class, this is referred to as data hiding. 

14. What is Data Abstraction?  

Instruments allowing only selected access of components to objects and to members of 

other classes is called as Data Abstraction. 

15. Define data hiding? 

The members and functions declared under private are not accessible by members outside 

the class, this is referred to as data hiding. 
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TWO MARK QUESTIONS: - 

1 .What is function overloading?  

The ability of the function to process the message or data in more than one form is called 

as function overloading. 

2. What is operator overloading?  

The mechanism of giving special meaning to an operator is called as operator overloading. 

3. How are functions invoked in function overloading?  

 Look for the exact match of a function prototype with that of a function call statement. 

 In case an exact match is not available, it looks for the next nearest match. 

4. List out the operators that cannot be overloaded?  

1. Membership operator  2. Scope resolution operator 

3. Size of operator   4. Conditional operator 

5. How are functions invoked in function overloading?  

 Look for the exact match of a function prototype with that of a function call statement. 

 In case an exact match is not available, it looks for the next nearest match. 

6. List out the rules for overloading operators? 

 Only existing operators can be overloaded. New operators cannot be created. 

 The overloaded operator must have at least one operand of userdefined type. 

7. Explain function overloading with rules 

 Each overloaded function must differ either by the number of its formal parameters. 

 The return type of overloaded functions may or may not be the same data type. 

FIVE MARK QUESTIONS: - 

1. What is the advantage of operator overloading? (Or) List out the rules for overloading 

operators?  

  Only existing operators can be overloaded. New operators cannot be created. 

  The overloaded operator must have at least one operand of userdefined type. 

  The basic definition of an operator cannot be replaced. 

  Overloaded operators behave in the same way as the basic operators in terms of their 

operands. 

  When binary operators are overloaded, the left hand object must be an object of the 

relevant class 

  Binary operators overloaded through a member function take one explicit argument. 

 

7. POLYMORPHISM 



www.Padasalai.Net

 Star Office   & C++           www.padasalai.net 

            P.CHANDRASEKARAN M.C.A, B.ED, [PG ASST IN C.S]     -             99420 12999                                         75 
 

2. Explain function overloading with rules?  

Function overloading: 

The ability of the function to process the message or data in more than one form is called 

as function overloading. 

Rules for function overloading: 

 Each overloaded function must differ either by the number of its formal parameters. 

  The return type of overloaded functions may or may not be the same data type. 

  The default arguments of overloaded functions are not considered by the C++ compiler as 

part of the parameter list. 

  Do not use the same function name for two unrelated functions. 

Example : 

#include<iostream.h> 

#include<conio.h> 

float area ( float radius ) 

{  

cout << “\nCircle …”; 

return ( 22/7 * radius * radius ); 

} 

float area (float half, float base, float height) 

{  

cout << “\nTriangle ..”; 

return (half* base*height); 

} 

float area ( float length, float breadth ) 

{  

cout << “\nRectangle …”; 

return ( length *breadth ) ; 

} 

void main() 

{ clrscr(); 

cout<<area(5.5); 

cout<<area(2.5,4.5); 

cout<<area(3.5,4.5); 

getch(); 

} 
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TWO MARK QUESTIONS: - 

1. What is Constructor? 

 The constructor is a special function that initializes objects when they are created. 

  It is automatically invoked when an object is created. 

2. Define Destructors? 

  It is a function that removes the memory of an object, which was allocated by the 

constructor at the time of creating an object. 

  It carries the same name as the class tag, but with a tilde (~) as prefix. 

3. Difference between Constructors & Destructors?  

Constructors Destructors 

When an instance of a class comes into a 

scope, a special function called the 

constructors gets executed 

When a class object goes out of a scope, a 

special function called the destructor gets 

executed. 

It initializes the class object. 

 

Both the functions return nothing.  

4. What are the functions of a constructor?  

  The constructor function initializes the class object 

 The memory space is allocated to an object. 

5. When is a Copy constructor executed?  

  When an object is passed as a parameter to any of the member functions.  

Ex:-void add::putdata(add x); 

  When a member function returns an object. Ex:add getdata(); 

  When as object is passed by reference to constructor. Ex:add a;b(a); 

6. What is default contractor? 

The constructors add () is a constructor without parameters. It is called as default 

constructor. 

7. What are the types of constructor? 

 The constructor add() is a constructor without parameters(non parameterized). It is called 

as default constructor – Example : add() 

 Parameterized constructor – Example : add (int s1, int s2) 

 Copy constructor –Example : add ( add & a) 

. 

 

8. CONSTRUCTORS & DESTRUCTORS 
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FIVE MARK QUESTIONS: - 

1. What is a constructor? Explain the rule for Constructors?  

Constructor:- 

  The constructor is a special function that initializes objects when they are created. 

  It is automatically invoked when an object is created. 

Functions of Constructor:- 

 The constructor function initializes the class object  The memory space is allocated to an 

object. 

Rules for Constructor:- 

 The name of the constructor must be same as that of the class  

 A constructor can have parameter list 

 The constructor function can be overloaded. 

 The compiler generates a constructor, in the absence of a user defined constructor. 

 The constructor is executed automatically 

2. List the rules for Destructor?  

 The destructor has the same name as that of the class prefixed by the tilde character (~). 

 The destructor cannot have arguments 

 It has no return type 

 Destructors cannot be overloaded 

 In the absence of user-defined destructor, it is generated by the compiler. 

 The destructor is executed automatically when the control reaches the end of class scope. 
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TWO MARK QUESTIONS: - 

1. Define inheritance? 

  Inheritance is the most powerful feature of an object oriented programming language. 

 It is a process of creating new classes called derived classes, from the existing or base 

classes. 

2. What are the advantages of inheritance?  

Reusability of code: 

Many applications are developed in an organization. Code developed for one application 

can be reused in another application. This saves a lot of development time. 

Code sharing: 

The method of the base class can be shared by the derived class. 

Consistency of interface: 

The inherited attributes and methods provide a similar interface to the calling methods. 

3. Write the syntax for creating a derived class from base class? 

How the derived class should be indicated?  

Class der_name: visibility mode base class-id 

{ 

data members of the derived_class 

functions members of derived_class 

} 

4. What is accessibility? 

An important feature in inheritance is to know as to when a number of a base class can be 

used by the objects or the members of derived class. This is called as accessibility. 

5. What is an abstract class? [June-08] 

Classes used only for deriving other classes are called abstract classes. ie., to say that 

objects for these classes are not declared. 

6. What are the different types of inheritance?  

1. Single inheritance 

2. Multiple inheritance 

3. Multilevel inheritance 

4. Hybrid inheritance  

5. Hierarchical inheritance. 

 

9. INHERITANCE 
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7. What are the three access specifiers used to inherit a derived class? 

  The three access specifiers are private, protected and public. 

  Access specifier is also referred to as visibility mode. 

  The default visibility mode is private. 

8. Write the difference between base class ad derived class 

Base class Derived class 

A base class is a class from which other 

classes are derived. 

A derived class can inherit members of a 

base class. 

 A derived class can inherit members of a 

base class. 

9. What is a base class and derived class? 

 A base class is a class from which other classes are derived.  

 A derived class can inherit members of a base class. 

FIVE MARK QUESTION: - 

1.Explain the different types of inheritance?  

This process of acquiring the Base class properties is  called as inheritance . 
 

There are different types of inheritance. 

1. Single inheritance 

2. Multiple inheritance 

3. Multilevel inheritance 

4. Hybrid inheritance  

5. Hierarchical inheritance  

1. Single inheritance:- 

When a derived class inherits from only one base class, it is called as single inheritance. 

 

 

Base Class-Employee 

 

 

 

 

 

 

 

Derived Class-Manager 
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2. Multiple inheritance:- 

When a derived class inherits from multiple base classes, it is called as single inheritance. 

 

Base Class-Address     Base Class-Office 

 

 

 

Derived Class-Manager 

 

 

3.Multilevel inheritance:- 

The transitive nature of inheritance is reflected by this from of inheritance. When a class is 

derived from a class, which is a derived class itself. It is called as multilevel inheritance. 

 

Base Class-Grand Father 

 

 

Derived –Father 

 

 

Derived –Child 
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TWO MARK QUESTIONS: - 

1. What are the technical elements you need to reach out the benefits of IT to the common 

man? 

To reach out the benefits of IT to the common man we need at least three technical elements : 

 Connectivity [Computer networks and Internet facility] 

 Affordable computers or other similar devices 

 Software 

2. What is E-banking ?  

 E-banking permits banking from the comfort of the home by using internet facilities. 

 It has truly improved the reach and services of banks. 

3. What is meant by e-Learning?  

  E-Learning that enables online educational programs leading to degrees and certifications. 

4. What is ATM?  

 It means Automatic Teller Machine 

 It enables withdrawal of money from the accounts in a particular bank anytime and 

anywhere. 

 It helps the user in emergency situations where money is needed during the nights and 

holidays. 

5. What is e-shopping? 

 You can purchase any product, any brand, any quantity from anywhere through e-

shopping. You need not go to the shop. 

 The pictures and other details are available on the website of the shop. 

 You have to select and order. 

 Credit cards and prior registration with the shop are the popular methods. 

 The items purchased will be delivered at your home. 

6. How the computers are used in entertainment? 

 Computers contribute to entertainment also.  

 You can update your knowledge in fine arts like painting, music, dance, yoga, games, 

science, nature, latest news and events.  

 You can know more about various places of worship and places of interest for tourists. 

 

 

10. IMPACT OF COMPUTERS ON SOCIETY 
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7. Name areas of healthcare in which computers are used  

 Hospital Management System 

 Patient Tracking System 

 Exchange of diagnostic records between healthcare units 

 Tracking and Monitoring Communicable Diseases 

 Decision support systems with highly advanced computing techniques 

8. What is Tele-Medicine? 

Tele-medicine is built largely on the foundational systems mentioned above. Internet 

facilitates remote diagnostics. This ensures expert advice at places where it is not there. 

9. How the computer help in Education? 

 
 Buying and browsing the latest edition of books by both local & foreign authors 

Educational CDROMs 

 Computer Based Tutorials (CBT). 
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TWO MARK QUESTIONS: - 

1. What is meant by ITES?  

 Information Technology that helps in improving the quality of service to the users 

is called IT Enabled Services. 

 ITES are human intensive services that are delivered over telecommunication 

networks. 

2. What is a Call centers?  

 A call center has adequate telecom facilities, trained consultants, access to wide 

database, Internet and other on-line information support to provide information and 

support services to customers. 

 It operates to provide round the clock and year round service ie, 24 xn365 service 

3. What is Medical Transcriptions?  

 It is a permanent, legal document that formally states the result of a medical 

investigation. 

 It facilities communication and supports the insurance claims. 

 There are three main steps in Medical Transcription. 

4. What is meant by data digitization?  

 It refers to the conversion of non-digital material to digital form. 

 A wide variety of materials as diverse as maps, manuscripts, moving images and 

sound may be digitized. 

5. Write the key benefits of data digitization?  

 Long-term preservation of the documents. 

 Storage of important documents at one place. 

 Easy to use and access to the information 

 Easy transfer of information in terms of images and text 

 Easy transfer of information through CD-ROM, Internet and other electronic 

media. 

6. Define Data Management?  

Data Management is a category of ITES pertaining to collection, digitization and 

processing of data coming from various sources. 

 

 

 

 

11. IT ENABLED SERVICES 



www.Padasalai.Net

 Star Office   & C++           www.padasalai.net 

            P.CHANDRASEKARAN M.C.A, B.ED, [PG ASST IN C.S]     -             99420 12999                                         84 
 

7. List out some keys IT enabled services. 

 e-Governance 

 Call Centers 

 Data Management 

 Medical [Telemedicine and Transcription]. 

 Data Digitization 

 Website Services 

8. What are the benefits of data digitization? 

There are many benefits of digitization. Some of the key benefits are: 

 Long term preservation of the documents. 

 Storage of important documents at one place. 

 Easy to use and access to the information. 

 Quick and focused search of relevant information in terms of images and 

text. 

 Easy transfer of information in terms of images and text. 

 Easy transfer of information through CD-ROM, internet and 

otherelectronic media 

9. Name some data management ITES. 

 Character Recognition and Processing 

 Custom reports 

 Data Entry 

 Data entry front end edits 

 Document Preparation 

 Forms are imaged and transferred to CD ROM 
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TWO MARK QUESTIONS: - 

1. What are ethics? 

Ethics is the set of rules for determining moral standards or what is considered as socially 

acceptable behaviors. 

2. What are the general guidelines on computer ethics? 

General guidelines on computer ethics are needed for: 

 Protection of personal data 

 Computer Crime 

 Cracking 

3. What are the three important methods of protecting personal data? 

 Physical Security 

 Personal Security 

 Personnel Security 

4. What is meant by Computer Crime?  

A computer crime is any illegal activity using computer software, data or access as the 

object, subject or instrument of the crime. 

5. List out the common computer crimes?  

1) Stealing hardware   2) Virus   3) Cracking 

4) Theft of computer time  5) Hardware and software piracy  

6) illegal access to confidential files 

6. What is meant by Piracy?  

Making and using duplicate hardware and software is called piracy. 

7. Write a short note on Virus?  

 A virus is a self-replicating program that can cause damage to  data and files stored on 

your computer. 

 These are programs written by programmers with great programming skills are motivated 

by the need for a challenge. 

 57000 known virus programs are in existence. 6 new viruses are found each day. 
8. What is cracking? 

 It is the illegal access to the network or computer system. 

 Illegal use of special resources in the system is the key reason for cracking. 

 The resources may be hardware, software, files or system information. 

 Revenge, business reasons and thrill are other common reasons for committing this crime. 

12. COMPUTER ETHICS 
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9. What is called theft of “Computer time”? 

Most of the computers in an organization have lot of free computer time to spare. In other 

words a lot of computer time is not used. Many solutions for using this spare time are being 

researched. However, this idle time of computers in an organization is being stolen illegally. 

Some other software runs on an idle computer without the knowledge of the organization. This is 

called ‘Theft of computer time’. 

 

He knows not he knows not, and he knows not – avoid him 

He knows he knows not, and he knows not- teach him. 

He knows not he knows, and he knows –awaken him. 

He knows he knows, and he knows – follow him. 

 

Best of Luck Student’S 

 

 

 

 

 

 

 


