
SRE VIDYASAAGAR HIGHER SECONDARY SCHOOL 

Sub : Computer Science               Full Portion Exam    Max. Mark : 150 

Class : XII - EM          Time : 3.00 Hrs 

PART - I 

I. Choose the correct answer.                              75 x 1 = 75 

1. Cut, copy, paste, find and replace are some of the commonly used functions  

a) Formatting   b) Editing    c) Aligning    d) Indenting 

2. Which of the following statement is true?  

a) The Enter key should not be pressed at the end of a paragraph.  

b) StarOffice Writer is not a word processor.  

c) Delete key deletes the characters to the right of the insertion point.  

d) To paste the selected word in the desired place insert key is used. 

3. Which of the following statement is NOT true?  

a) A text with special formatting can have a monotonous appearance.  

b) Almost all the formatting options are available under Format menu.  

c) A font is a set of characters and numbers in certain style.  

d) Highlighting can be used to call attention to key ideas or pointers in a document. 

4. Which of the following statement is NOT true?  

a) A paragraph is any text followed by a hard return.  

b) The default paragraph alignment is right.  

c) Indenting text helps to increase the readability.  

d) A style is a named set of defaults for formatting text. 

5. The only check box available in the Auto Correct dialog box is  

a) Text only       b) Numbers    

c) Match case       d) Whole words only  

6. Which of the following keys is pressed to delete a misspelled word and the word is retyped?  

a) End    b) Home    c) Shift + Delete   d) Backspace 

7. Which of the following statement is NOT true?  

a) Every table is identified by a specific name.  

b) There is a separate toolbar available for table formatting.  

c) Rows and columns can be inserted only at the end or beginning of a table.  

d) Shift + Tab to move backward through the cells. 

8. Which of the following statement is NOT true?  

a) The simplest way to add a row is to press Tab.  

b) To resize a column, place the cursor in a table cell, hold down Alt and then press up or the down 
arrows.  

c) Table -> Delete -> Table option is used to delete a selected table.  

d) By default each cell includes a border. 

9. Which of the following statement is true?  

a) The desired page orientation is selected using a combo box in the page dialog box.  

b) Portrait orientation is also known as landscape orientation.  

c) Footer is an area at the top of the page.  

d) The margins for a particular page can be set to an exact value using a Page Style dialog box. 

10. Which of the following statement is NOT true?  

a) Any part of the worksheet can be viewed or edited.  

b) Worksheet can be quite small in size.  

c) Any part of the worksheet can be printed in a desired format.  

d) Worksheet data can be viewed in the form of graphs or charts. 

11. Which of the following statement is NOT true?  

a) MS-Excel was developed by Microsoft Corporation.  

b) Lotus 1-2-3 is the first electronic spreadsheet.  

c) The first electronic spreadsheet package developed in 1979.  
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d) In previous, the spreadsheet and worksheet mean one and same. 

12. The following format is used to enter the time in StarOffice Calc is  

a) HH : MM : SS   b) SS : MM : HR   c) HR : SS : MM   d) HR : MIN : SS 

13. The syntax of formula begins with the symbol  

a) = =    b) =     c) !     d) $ 

14. Which of the following statement is NOT true?  

a) The width of a column is not enough; StarOffice Calc indicates this with small red triangles.  

b) F2 function key is used to edit the contents in a cell.  

c) Function bar is used to display the current cell and its contents.  

d) In StarOffice Calc, enter the time in the worksheet by typing it as HH:MM:SS. 

15. Which of the following statement is true?  

a) The syntax of formula in worksheet must not be begins with an equal sign.  

b) The exponentiation operator is |  

c) Exclamation point is the intersection operator in StarOffice Calc.  

d) Reference operators return numerical results. 

16. Which are written in Java programming?  

a) Applets   b) Objects    c) Tools    d) Drawings 

17. Which of the following statement is NOT true?  

a) Datum comes from the word data.  

b) Information is a group of related data conveying some meaning.  

c) Data is simply the assigned value to a variable.  

d) Variable refers to the name of memory location. 

18. Which of the following statement is NOT true?  

a) Searching is a process to select a desired specific data from a database.  

b) Sorting is the process of arranging the data in a table in some order.  

c) Merging is a process of joining data from two or more tables of the same or different databases.  

d) We cannot do any kind of arithmetic calculations on the data stored in the database. 

19. Which of the following statement is true?  

a) A database is a collection of related tables.  

b) Flat-file database allows for more complex requests.  

c) A relational database structures were primarily used on mainframe computers.  

d) In network database, records are organized in tree-view structure.  

20. Expand DBMS  

a) Data Base Mailing System     b) Data Base Mailing Security  

c) Data Base Management System    d) Data Binary Management System 

21. Which pane is displayed in the lower part of the table design window?  

a) Pages    b) Explorer    c) Database    d) Field properties 

22. To enter the data of the newly created table, select the table and choose  

a) Insert -> Open Database Object    b) Tools -> Open Database Object  

c) Edit -> Open Database Object    d) Format -> Open Database Object 

23. In Report Wizard, which window is used to specify the fields based on which the record can be 
grouped together?  

a) Layout window  b) Sorting window   c) Grouping window   d) Report window 

24. Which of the following statement is NOT true?  

a) Sorting arranges records in a table according to specific criteria.  

b) A query is also a type of report.  

c) A form is simply a screen that displays the fields of a record in a well-spaced out manner.  

d) A report is printed information that is assembled by gathering data based on user supplied criteria. 

25. How many steps are in a Database wizard?  

a) only one   b) two    c) three    d) four 

26. HTTP stands for   

a) Hyper Text Transmission Program    b) Hyper Text Transfer Problem  

c) Hyper Text Transaction Protocol    d) Hyper Text Transfer Protocol 

27. Quick Time format was developed by  

a) Microsoft   b) Sun Microsystems  c) Apple    d) Macromedia  
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28. Shockwave format was developed by  

a) Microsoft   b) Sun Microsystems  c) Apple    d) Macromedia 

29. In a video file, reducing the colors depth to less than 256 colors results in the image looking  

a) Warping   b) Jerky    c) Morphing    d) Murky  

30. In a video file, reducing the frame count less than 15 frames per second causes the video to look  

a) Modeling   b) Jerky    c) Morphing    d) Murky 

31. Which view allows you to reorder slides, edit slide titles and heading?  

a) Normal   b) Notes    c) Handouts    d) Outline 

32. To start a presentation, choose  

a) Format->Slide show  b) Tools -> Slide show  c) Slide show->Slide show  d) View->Slide show 

33. To open slide show settings dialog box, use the command  

a) Presentation -> Slide show setting    b) Slide show -> Slide show settings  

c) Format -> Slide show setting     d) Window -> Slide show setting 

34. To insert pictures in a slide, choose  

a) Format -> Picture -> From File    b) Tools -> Picture -> From File  

c) Edit -> Picture -> From File     d) Insert -> Picture -> From File 

35. To change the background color of the current slide or all slides, choose  

a) Format -> Page -> Background    b) Tools -> Page -> Background  

c) Edit -> Page -> Background     d) Slide show -> Page -> Background 

36. C++ belongs to which category of programming language?  

a) Structured   b) Object oriented   c) Modular    d) Procedural 

37. Which of the following communicates with one another by sending data as inputs?  

a) Objects    b) Entities    c) Variables    d) Methods 

38. What is the maximum range of unsigned integer data type?  

a) 255    b) 65535    c) 32768    d) 3.4e+10 

39. Find out the value assigned to m, where n1 = 7, n2 = 8. m = (n1 > n2) ? n1 : n2 ;  

a) 7    b) 8     c) 1     d) 0 

int i = 6;  

unsigned int j = 10;  

cout<<size of(I*j);  

40. The output when the above code is executed is  

a) 2    b) 4     c) 8     d) error 

41. The exponential form of 58.64 is  

a) 5.864E-1   b) 5.84E-2    c) 5.864E1    d) 5.864E2 

for (int ctr = 1, sum = 0; ctr < 5 ; ctr ++) ;  

sum += ctr ;  

cout << sum ;  

42. The output will be  

a) 15    b) 1     c) 5     d) 10 

43. How many major category of control structures are there?  

a) Only one   b) Two    c) Three    d) Four  

44. Which loop can be divided into three segments?  

a) Nested loops   b) while    c) do – while    d) for 

45. If() statement is implemented in  

a) two forms   b) three forms   c) four forms    d) several forms 

46. Basic statements in C++ constructed using  

a) Variables   b) Tokens    c) Functions    d) Classes 

47. In the following statement, the scope of the variable p is int add(int p, int q);  

a) Local scope   b) Function scope   c) Global scope   d) Class scope 

48. The function prototype int &maxref(int &a, int &b); is  

a) Call by value and Returning values method  

b) Call by value and Returning by reference method  

c) Call by reference and Returning by reference method  

d) Call by reference and Returning values method 
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49. Which of the following is not a valid function proto type?  

a) void fun (int x) ; void fun (int y) ;    b) void fun (int x, int y) ; void fun (int x, float y) ;   

c) int fun (int x) ; void fun (float x) ;    d) void fun (char x) ; void fun (char x, int y) ; 

50. The starting point for the execution of a program is  

a) # include <iostream.h>  b) main ( )   c) fact ( )    d) { 

51. int n[5] = {3,5,9,2,4}; what is stored in n[2] ?  

a) 5    b) 9     c) 2     d) 3 

52. How many methods are to display the contents of string?  

a) Two    b) Four    c) Six     d) Three 

53. The syntax of gets() is  

a) gets(char);   b) gets(char*);   c) gets(array);   d) gets(); 

54. Class name is also called as  

a) function   b) member    c) method    d) tag 

Read the following program carefully and answer the questions from 55 to 58.  

class student  

{  

private :  

char name [10] ;  

int rollno, m1, m2, total ;  

protected :  

void accept( ) ;  

void compute( ) ;  

void display( ) ;  

public :  

student( ) ;  

void execute ( ) ;  

};  

void main ( )  

{  

clrscr( ) ;  

student stud ;  

stud.execute( );  

}  

55. The data type identifier is  

a) class    b) student    c) name    d) marks  

56. Name the member function that can be accessed by an object of student class.  

a) accept( );   b) compute( );   c) display( );    d) execute( );  

57. How many data members are in the student class?  

a) 4    b) 5     c) 9     d) 10  

58. The number of bytes occupied by the object stud is  

a) 8    b) 9     c) 10     d) 18 

59. Every class declaration is terminated by  

a) , (comma)   b) . (dot)    c) :: (double colon)   d) ; (semi colon) 

60. Which of the following operator can be overloaded?  

a) Membership   b) sizeof( )    c) Unary    d) Conditional 

61. Integral promotions are purely  

a) Compiler Oriented      b) Assembler Oriented   

c) Object Oriented      d) Interpreter Oriented 

62. The functionality of  ‘+‘ operator can be extended to strings through  

a) Members overloading     b) Function overloading  

c) Constructor overloading     d) Operator overloading 

63. Which of the following is a default constructor?  

a) add(int)   b) add(float)    c) add( )    d) add(char, float) 

64. How many types of constructors available in C++?  

a) Only one   b) Two    c) Three    d) Four 
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65. Which of the following one removes the memory of an object?  

a) Constructor   b) Destructor    c) Buffer    d) Stock 

66. Function overloading can be applied for  

a) Data members  b) Constructor   c) Destructor    d) Objects 

67. Which is not inherited from the base class?  

a) Object    b) Function    c) Constructor   d) Data members 

68. Base class(Grand father) <- Derived class (father) <- Derived class (child) is a  

a) Hierarchical inheritance     b) Multiple inheritance  

c) Multilevel inheritance     d) Single inheritance 

69. Which of the following is not TRUE, related to the advantages of inheritance?  

a) Reusability of code      b) Reduce the code  

c) Code sharing       d) Consistency of interface 

70. Which prevents people from acquiring bad habits?  

a) Archive unit   b) Emotion containers  c) Camera    d) Speakers 

71. 85% of computer usage is  

a) Presentation   b) Spreadsheet   c) Database    d) Word processing 

72. The key for effective and profitable use of IT in organizations is  

a) Call center   b) Data Management  c) Website services   d) Data Digitization 

73. The device that converts the speech into a letter is  

a) Speaker   b) Rack Telephone   c) Head phone   d) Dictaphone 

74. Which one of the following security provided by restricting the people who can access the resources?  

a) Data    b) Physical    c) Personal    d) Personnel 

75. Computer ethics has its roots in the work of  

a) Herman Hollerith  b) Robert Wiener   c) Norbert Wiener   d) Herman Wiener 

PART - II 

II. Answer any Twenty questions                              20 x 2 = 40 

76. What is the difference between copying text and moving text in StarOffice Writer?  

77. Name the different line spacing options.  

78. What is the difference between absolute cell referencing and relative cell referencing?  

79. What do you mean by date arithmetic in StarOffice Calc?  

80. What distinguishes information from data? 

81. Write any four disadvantage of manual data processing?  

82. What are morphing and warping? 

83. Write a note on inline sound and video.  

84. What is the use of master page in presentation?  

85. How will you create handouts in StarOffice Impress?  

86. What is the significance of an object?  

87. Determine the order of evolution of the following expression. 

i) a+pow(b,c)*2   

ii) (b*b)-4*a*c 

88. What are keywords and identifiers give an example? 

89. What are the two types of loops based on the position of the condition?  

90. What are functions and write the advantages?  

91. Write a note on write ( ) in C++.  

92. List out user define data type. 

93. What is an array? Define its different types.  

94. Write the characteristics of member functions.  

95. What is meant by nesting of member function?  

96. List out the operators that can be overloaded.  

97. When constructor gets executed?  

98. What is multilevel in Inheritance?  

99. What is meant by e-learning?  

100. What is Computer crime?  
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III. Answer any Seven questions                                7 x 5 = 35 

101. How would you select the required portion of a text in a document?  

102. Explain the various icons available in table formatting toolbar in a StarOffice Writer document.  

103. How to generate a series of values using spread sheet in StarOffice Calc? Explain with example.  

104. How will you insert chart in a Worksheet?  

105. What are Reports? How can you create a report by using StarOffice Base?  

106. Explain switch statement with an example.  

107. What are the different ways of passing parameters in C++ functions?  

108. Write the rules for constructor and destructor definition and usage.  

109.   
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110.  Write the output for the following C++ program. 

# include<iostream.h> 

#include<conio.h> 

class add 

{ 

int num1, num2, sum; 

public: 

add() 

{ 

cout<<“\n Constructor without parameters.. “; 

num1= 0; 

num2= 0; 

sum = 0; 

} 

add ( int s1, int s2 ) 

{ 

cout<<“\n Parameterized constructor... “; 

num1= s1; 

num2=s2; 

sum=NULL; 

} 

add (add &a) 

{ 

cout<<“\n Copy Constructor ... “; 

num1= a.num1; 

num2=a.num2; 

sum = NULL; 

} 

void getdata() 

{ 

cout<<“Enter data ... “; 

cin>>num1>>num2; 

} 

void addition() 

{ 

sum=num1+num2; 

} 

void putdata() 

{ 

cout<<“\n The numbers are..”; 

cout<<num1<<‘\t’<<num2; 

cout<<“\n The sum of the numbers are.. “<< sum; 

} 

}; 

void main() 

{ 

add a, b (20, 30) , c(b); 

a.getdata(); 

a.addition(); 

b.addition(); 

c.addition(); 

cout<<“\n Object a : “; 

a.putdata(); 

cout<<“\n Object b : “; 

b.putdata(); 
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cout<<“\n Object c.. “; 

c.putdata(); 

} 
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