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MODEL QUESTION PAPER 

 

1. What is the default name given while saving a document in Staroffice    Writer? 

     (a) Untitled 1     (b) Untitled      (c) Document 1   (d) Text1 

2.  Which key combination is used to select the entire document in Staroffice  Writer? 

     (a) Ctrl + A       (b) Cffl + S       (c) Alt + A        (d) Alt + E 

3. Which one of the following is the named set of default for formatting With in Staroffice Writer? 

     (a) Style          (b) .Format       (c) Set      (d) Font 

4.  What is the name of the top portion of a Page in Staroffice Writer? 

     (a) Title           (b) Footer       (c) Header      (d) Heading 

5. Which key is used to open the spell check dialog box? 

     (a) F1           (b) F2           (c) F5           (d) F7 

6. How will make all columns even in a table vrStaroffice Writer? 

     (a) Column —> Space Equally      (b) Space Equally -Column 

     (c) Column -> Width Equally        (d) Width Equally-Column 

      7. Which key combination is used to move backward through the cells in a table? 

(a) Shift + Tab                     (b) Shift + Left arrow 

(c) Ctrl + Tab                        (d) Alt + Tab 

     8.  How many types of page orientation are there in Staroffice Writer? 

(a) 1                (b) 2              (c) 3            (d) 4 

9. Which of the following is true, to insert a page number in a document? 

    (a) Insert Fields -> Page Number     (b) Format -~> Fields - Page Number 

    (c) View -> Fields -> Page Number (d) Tools -> Fields -> Page Number 

10. Which of the following formula to add the number jn .cell A3 with the  number in ceUA4? 

     (a) sum (A3 + A4) (b) = sum (A3:A4  (c) sum (A3:A4)  (d) =Add (A3;A4) 

11. Which one of the following is,the text operator in Staroffice calc? 

(a) :              (b) '              (c» &              (d) 
A 

    12. in  Staroffice Calc, which special character is used for Absolute Cell Reference? 

(a) *          (b) =           (c) &               (d) $ 

    13. The operator "(Caret) is used for.......... 

      (a) Division        (b) Multiplication (c) Exponentiation (d) Square  

  14. How will you delete the contents,of a selected cell OP range? 

    (a) Edit -> Contents Delete        (b) Edit - Erase All 
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    (c) Edit ~> Remove Al! .              (d) Edit -Remove Contents 

  15.  Which key' is used to edit the cbntent in a cell? 

  (a) F1            (b)F2           (c) F5           (d) F7       

 16. Which icon is used to insert .a-formula in a worksheet? 

   (a) Insert Formula                (b) Add Formula    (c) Create-Formula                 (d) Edit Formula 

17. Which of the following is not a valid data type in Staroffice Base? 

 (a) Character     (b) Boolean      (c) Picture       (d) Real 

18. Which field is used to uniquely identify a record in a database table? 

     (a) Main key      (b) Primary key (c) Common key (d) Key 

19. Which database type contains single data table? 

      (a) Hierarchical    (b) Relational     (c) Fiat-file       (d) Network 

20. Which of the following option is used to remove the filter? 

      (a) Remove tiller                        (b) Delete filter 

      (c) Remove filter/Sort              (d) Delete filter/Sort 

21. What is the name of the process for joining data from two or more tables 

       (a) Joining        (b) Editing       (c) Merging      (d) Adding 

22. What is the name of the screen that displays the fields of record in a well spaced out manner? 

      (a) Report        (b) Form        (c) Query        (d) Filter 

23. Which of the following are-  hwo types of reports?                    

     (a) Static & Dynamic           (b) Static & Primary               

       (c) Primary & Secondary      (d) Dynamic & Primary 

24. What .is the name of a set of data for each database entry? 

      (a) Field          (b) File          (c) Record       (d) Table 

25. Which language is used to query the database?  

       (a) C++          (b)SQL         (c) HTML       (d) C 

26. Wnlcti-oF the following graphics helps in rendering the image effectively on the screen? 

    (a) Image         (b) Static        (c) Vector        (d) Scalar 

27. What ,is the name of the process for converting Analog waves to-a"digital formatting?           

       (a) Sampling     (b) Sound-force   (c) Amplitude     (d) Frequency 

28. Name th? technique that blends two or more image to form a new image. 

      (a) Blending      (b) Warping      (c) Morphing    (d) Modeling 

29. What is the extension for the Shockwave format file? 

 (a) wave         (b) au          (c) swf         (d) mp3 
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30. Which of the following tag is not used to launch Helper application? 

      (a) <embed>      (b) <applet>      (c) <object>      (d) <head> 

31. Which key is used to create a new presentation using a template? 

       (a) Shift + Alt + N         .         (b) Shift + Ctrl + N   (c) Ctrl + Alt + N     (d) Shift + tab      

32. Which of the following view atiows to create and edit slides? 

       (a) Normal       (b) Outline       (c) Notes        (d) Handouts 

33. Which command is used to'insert a picture in a slide? 

       (a) Insert —> Picture                           (b) Format -Picture 

      (c) Insert —> Picture —> From file   (d) Insert —> From file -> Picture 

34. How will you change the. background color of all the slides? 

  (a) Format - Background          (b) Format - Page --> Background 

  (c) Formate Page                        (d) Insert —> Page -> Background 

35. Which key combination is used to print slides in Staroffice? 

     (a) Alt + P         (b) Ctrl+P        (c) Shift+P        (d) Shift + Ctrl + P 

36. The group of data and the operations together are termed as 

 (a) State          (b) Object       (c) Encapsulation   (d) Data 

37.  What is the name of the process for acquiring Base class properties? 

  (a) Inheritance    (b) Class        (c) Polymorphism   (d) Encapsulation  

38. How many classifications of tokens are there? 

  (a) 2               (b) 3             (c) 4               (d) 5 

39. Which is not a keyword of C++? 

 (a) size            (b) static'          (c) struct.         (d) signed 

40. The range of character data type is 

 (a) 128 to 127    (b) 0 to 255      (c) 12710 128   (d) 3276810 32707 

41. Which variable that holds a memory address as value? 

      (a) Variable        (b) Pointer       (c) Static          (d) Constant 

42. Which function is called automatically? 

(a) main          (b) void           (c) friend          (d) online 

43. How many segments does a tor-loop statement consist of? 

      (a) 2           (b) 3           (c) 4          (d) 5 

44. Which is called the exit-check loop? 

 (a) for            (b) while          (c) do-while      (d) All 
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45. program written in high level language is called 

       (a) source, code                   (b) Object code      (c) compiler                            (d) machine readable file 

46. Which statement is used to terminate every action block of switch statement? 

(a) Continue      (b) For          (c) Break        (d) Case 

47. Which of the following are the building blocks of C++ programs? 

(a) Statements    (b) Functions    (c) Data types    (d) Keywords 

48. Which statement transfers control to the statement after call statemen 

      (a) cout           (b) return        (c) cin            (d) while        

49. In which method, the forma! parameters become alias to the actual parameters? 

(a) Call by reference  (b)  Call by value   (c) Call by function           (d) Call by variable 

50. Which function execute faster but require more memory space? 

       (a) linein          (b) lineout       (c) inline         (d) outline 

51. The size of the array always be .........      

     (a) positive       (b) negative      (c) float value     (d) character 

52. Which of the following function returns the number of characters stored the array? 

      (a) strien ()      (b) strepy        (c) stremp      , (d) length  

53. What will be, the size of an array a [4] (6) 

(a) 10            (b) 21            (c) 24 
 
       (d)20 

54. The functions associated with the class data type are called......... 

(a) pointers                        (b) methods (c) arrays                           (d) user defined data types 

55. Which brace is used to enclose the body of the class? 

      (a)0            (b)<>        (c)0           (d)[] 

56. Which access specifier of a class body is optional? 

      (a) Public .       (b) Private       (c) Protected     (d) Class 

57. Which of the following is achieved -through data hiding? 

      (a) Polymorphisnrf                  (b) Class       (c) Data abstraction              (d) Class members 

58. Which access specifier are used to access friend functions? 

      (a) Private        (b) Protected     (c) Public         (d) Class 

59. The. static member variable is initialized to......... 

      (a)0           (b) 1           (c) true           (d) false 

60. Polymorphism .is achieved through....... 

(a) inheritance    (b) encapsulation  (c) overloading   (d) poly program-ming 
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61. Which of the following operator can be overloaded in C++? 

      (a) Membership                    (b) Scope resolution   (c) Size of                              (d) All of these 

62. The name of the constructor must be.......... 

(a) same as class name        (b) same as one of the Member Func-tion                     

 (c) same as Object Name        (d) same as Name of Inline Function 

63. The mechanism of giving special meaning to an operator is called........ 

 (a) function overloading             (b) method overloading 

 (c) constructor overloading        (d) operator overloading 

64. How many destructors a class can have? 

 (a)1             (b)2           (c)3            (d)4 

65.  Which of the following has no return type and cannot be overloaded?" 

       (a) Constructor                    (b) Member function        (c) Destructor                    (d) Inline function 

66. Which of the following get executed when a class goes out of a scope? 

       (a) Pointer                         (b) Destructor        (c) Constructor                    (d) Function overloading 

67. In inheritance, the newly created classes are 

      (a) base class    (b) derived class (c) super class    (d) function 

68. How many access specifiers are there in inheritance? 

(a) Two           (b) Four          (c) Six            (d) Three 

69. Classes used only for deriving other classes are ........... 

(a) Concrete class        b) Abstract class (c) Class members                (d) Polymorphism 

70. Which permits banking from the comfort of the home by using internet facility? 

      (a) Call Centers   (b) e-Banking    (c) e-Shopping,   (d) e-Cards 

71. In which one of the following areas, transcription is used  

(a) Education     (b) Medicine     (c) Administration (d) Games 

72.  Which of the following does not refer to authorized access to the computer system                                                   

(a) Physical Security .              (b) Personal Security  (c) Personnel Security             (d) Piracy 

73.  Name the special device that allows the user to speak and convert the speech into a letter?                    

(a) Microphone    (b) Gamophone (c) Dictaphone   (d) Cellular Phone 

74. Which of the following is not an IT enabled- service? 

  (a) e-Governance                  (b) Railway Reservation System 

  (c) Telemediclne                   (d) Data Management 

75.  Which one of the following enables data storage and management? 

       (a) Emotion containers .           (b) Camera        (c) Archeive Unit                     (d) Speakers 
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MARCH - 2007 

I. Choose the correct answer:                                                                      

1.   CBT stands for ........................... 

 (a) Computer Based Tutorials      (b) Computer Based Tools  

 (c) Computer Based Techniques     (d) Coded Binary Toois 

2.   A facility that allows the user to speak into a special device while typing a letter using computer is 

called............ 

     (a) Cellphone      (b) Telephone    (c) Dictaphone   (d) Speaker 

3.  BPO may be expanded as ......... 

(a) Business Publication Online      (b) Business Process Outsourcing 

(c) Business Publication Outsourcing (d) Business Process Online 

4.  A self replication program that can cause damage to data and files stored on  the computer is....... 

   (a) virus          (b) antivirus       (c) language       (d) none of these 

5. The illegal access to the computer hardware and software is ....... 

     (a) Hacking       (b) Cracking     (c) Chatting       (d) Browsing 

6.  When an object is passed by reference to constructor, the constructor that  is executed is ......... „ 

(a) copy          (b) static         (c) default        (d) inline, 

7.  The process of creating new classes from the'existing class is......... 

     (a) .Polymorphism (b) Encapsulation (c) Inheritance   (d) Abstract 

8.   In inheritance, the newly created classes are ............. 

      .(a) Base class    (b) Derived class (c) Super class   (d) Function 

9.   Classes used only for deriving other classes are............. 

(a) Abstract classes   (b) Concrete classes   (c) Static classes                (d)  None of these 

10. 85% of computer usage is .......... 

(a) Presentation   (b) Spreadsheet   (c) Database     (d) Word processing 

  Read th<&'following C++ program carefully and answer the questions from  11 to13 

# inc!ude <iostream. h> class negative     

{ 

intt; 

public:    

void accept () 

{                         

cin 
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} 

void display ()                                                  

   <       

cout«i; 

}        

void main () 

{ . 

negative n 2; 

 2.accept ();                                        

-
n2

;                  

n2.disp[ay();- 

}                                         . 

11. identify" the operator that is overloaded............. 

      (a) ==            (b) (Unary)      (c)  (Binary)     (d) negative. 

12.  The prototype of the overloaded member function is......... 

.      (a) negative operator-()   (b) void operator minus   (c) void operator -()    (d) void operator-(negative) 

13.  Which of the foii'owing statements invokes the overloaded member functic 

       (a) Negative n 1 () (b)  - n 2 ()      (c) n 2+;          (d) - n 2; 

14.  The function that initializes the object is.......... 

  (a) void      (b) destructor     (c) inline          (d) constructor 

15. Whenever a class object goes out of scope, a special function thatgi      executed is ..........  

(a) Destructor     (b) Constructor   (c) Destroy       (d) End 

16. The constructor defined by the computers in the absence of user define   constructor j &  

      (a) Copy          (b) Abstract      (c) Default       (d) Destructor 

17. Which of the .following is not a valid class access specifier? 

    (a) Private         (b) Public        (c) Protected     (d) Pointer 

18. The members of a ci'ass are accessed using the operator....... 

(a) +              (b) Cdot)        (c) <             (d) > 

 

19. The variable that is initialized only when the first object of the class  created is ........... 

      (a)static            (b) private          (c) public          (d) protected 

20. The class access specifier used to access friend function is ................. 

   (a)private   (b)pubiic                (c)protected     (d) both (b)and(c) 
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21. An integer array with indexes from Q to 4,all having value I may be declared a   initialized as  

(a) int x [4]- {1};                      (b) 
int

 
x
 H 

=
 {'U.U}; 

(c) intx [5]={1,1,1,1,1};         (d) int x []={}: 

22. The size of the array must always be ......... 

      (a) positive        (b) negative       (c) float           (d) double 

23. The collection of variables of the same referenced by a common name is 

       (a) function         (b) array          (c) structure       (d) pointer 

24. Every class declaration is terminated by ............. 

        (a) (comma)                      (b)  (dot)    (c) (double .colon)             (d) (semicolon)  

 25.  Which of the following statements is NOT true? 

         (a) Member functions can be of static type 

(b) The return type of a member function cannot be of object data type 

(c) A non-member function cannot access the private data of a class 

(d) Several different classes can use the same function name; 

26. The statement that creates multiple branches, depending on the value of a single variable is ..;......... 

     (a) do-while        (b) switch        (c) if              (d) while 

27. The default return data type of a function, if no data type is explicitly  mentioned is ...... 

      (a) int             (b) char           (c) float           (d) double 

28.  The function strepy (S1, S2).............. 

(a) copies S1 to S2  (b) copies S2 to S1 (c) appends S1 to end of S2      (d) appends S2 to end of S1 

29. Which of the following is NOT true, related to functions? ; 

(a) The actural parameters can be passed in the form of contants to the formal parameters of value 

type. 

(b) The  actual parameters can be passed onty as variables to formal'  parameters of reference type.                

(c) The default value in the formal parameters can be given, in the form of variable initialization. 

(d) The defualt value for an argument can be given in between the  argument list. 

30. In the following code, the scope of the variable's is..... 

it (x < y) 

{                                    

' int a;         

a++;                                                                

}                                   

(a) Local scope-                  (b) Function scope  (c) File scope                      (d) Class scope 
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31. The modifier that allows that variable to exist in the memory computer, even after losing its scope is ..... 

      (a) Auto           (b) Static         (c) Extern        (d) Global 

32. The operator  is called as ......... 

 (a) Extraction operator    (b) Insertion operator (c) Abstraction operator (d) Stream operator 

33. A preprocessor directive starts with the symbol........... 

 (a) %                (b) \         (c) $                (d) #   / 

34. Which of the following is an entry check loop? 

 (a) Do-while       (b) Switch        (c) While         (d) If 

35.  A program written in high level language is called as......... 

(a) Object code                   (b) Source code (c) Executable code            (d) All of these 

36. The. shockwave format is used to store multimedia components create  using  ................ 

(a) Media player                   (b) Netscape Navigator (c) Internet Explorer                 (d) Flash 

37. The application that allows to send and receive messages over cellpho_JS... 

  (a) Microwave Media Service           (b) Multimedia Media Service 

  (c) Multimedia Messaging Service (d) Microwave Messaging Service 

38.  JPEG may be expanded as ................ 

(a) Joint Photographic Experts Group (b) Joint Physical Exports Group 

(c) Joint Physical Experts Group  (d) Joint Photographic Exports Group 

39. Which of the following is the commercial multimedia content development    software? 

      (a) Flash         (b) Dream Weaver  (c) Maya  (d) All of these. 

40. AIFF format was developed by........... 

   (a) Real Networks  (b) Apple        (c) IBM          (d) Microsoft 

41. SQL stands for.......... 

(a) Structured Query Language   (b) Sorted Query Language 

(c) Sorted Question Language      (d) Structured Question Language 

42. Filter used with a condition is called  

(a) Auto Filter                       (b) Default Filter (Standard filter) 

(c) Conditioned Filter           (d) unconditioned Filter 

 

43. The field type -that is not allowed by StarOffice Base is.......... 

(a) Text           (b) Binary        (c) Project       (d) Image 

44. The Computers that primarily use the hierarchical database are ......... 

(a) Super         (b) Mainframe   (c) Personal      (d) Mini 

45. To send text outline into presentation, select-........... 
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(a) File —> Send —> Outline to presentation (b) File —> Outline to presentation 

(c) File -> Presentation (d) File —> Send —> Presentation        

46.  In-presentation the view that allows us to view miniature images of all the slides is.......... 

(a) Slide sorter   (b) Master page (c) Notes view   (d) Layouts 

47. Which of the following is used, to import objects from other application into  a presentation?     

(a) Insert ODBC object           (b) Insert OLEDB object 

(c) insert OLE Object              (d) Insert DBMS object 

48.  The shortcut key for opening style list is .................... 

(a) FS            (b) F7            (c) F5          (d)F11 

49. To change the background colour of the current slide, click on .......... 

(a) Format —> Page —> Background  (b) Tools ~-> Page—-> Background 

(c) Edit -> Page —> Background   (d) View ~> Page —> Background 

50. The key combination used to open print dialog box 'n StartmpressOfficeis 

(a) Ctrl + Shift + P                    (b) Ctrl + P 

(c) Shift + P                              (d) Alt + P 

51. The intersection of rows and columns in a spreadsheet is called as........ 

 (a) cell           (b) Row intersect (c) Grid          (d) Column intersect 

52. A formula in spreadsheet always begins with.............. 

(a) +              .(b)-               ( C)    ^          (d)= 

53. Which of the following operators combines two texts? 

(a) +              (b) &               (c) !|               (d) =  

54. The function used to find the square root-of a number in StarOffice Calc is 

       (a) SQR         (b) SQT        (c) SQRT       (d) SRT 

55. The cells A4,A5,A6,B4,B5& B6 are referred in a worksheet as 

      (a) A4 : B6                        (b) A1 : B6 

     (c) A1 : A6 ; B1 : B6          (d) A4 A6 ; B4 : B6 

56.  A template for .entities that, have common behaviour is .... 

      (a) class           (b) object        (c) methods       (d) attributes 

 

57. Which of the following is an Object Oriented Programming language? 

      (a) C++          (b) C        . (c) BASIC       (d) FORTRAN 

58. Which of the following is not a C++ keyword? 

(a) this            (b) new           (c) cont           (d) if 

59. int a, b, c ; 
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a)=6;     b)=7;   c)=(a++)-(--b); 

       cout c;          

The output of the above 'code, whenJt is executed is...... 

(a) 0                (b) 9               (c) 11          .    (d) error 

60. The constant that should not have fractional part is ... 

       (a) Float          (b) Double     (c) Integer       (d) Exponent 

61.  Which of the following icons, is used to generate a scrolling screen with  Worksheet 

(a) insert Plug-in                  (b) Insert Floating frame 

(c) Insert OLE object            (d) Insert Chart 

 

62. The term data -is derived from the word ......... 

 (a) Datum         (b) Datem        (c) Datas     (d) Datus 

63.  Acolumn in a StarOffice Base table represents a .............. 

(a) Structure       (b) File.         , (c) Field          (d) Record 

64. The key that uniquely identifies a record in a database is ........... 

 (a) Primary key             (b) Secondary key  (c) Record.key           (d) Unique key 

65. The process used to select the desired and specific data from a database is ...........                             

      (a) Merging        (b) Sorcing       (c) Editing        (d) Searching 

66.  If the-length of. the document is, more than the width, the orientation is called as ..... 

      (a) Layout         (b) Landscape    (c) Portrait       (d) Margin 

67. Which of the following keys is pressed'to move backward through the ce;l 

      of Star Office Writer table?           

      (a) Ctri'+Tab      (b) Shift + Tab   (c) Enter + Tab    (d) ESC+Tab 

68.  in StarOffice Writer, the page preview option is available under the menu,. 

       (a) Format        (b) Edit          (c) File          (d) View 

68. To add a row after the last row- of the table in StarOffice Writer, the key pressed is….           

      (a) Tab            (b) Shift      (c) Alt             (d) Ctrl 

 

 

70.  The active cell in a spreadsheet is identified by .... 

         (a) Insertion pointer                 (b) Cell pointer      (c) Mouse pointer                    (d) Keyboard pointer . 

71.  Which of the following is not a word processor? 

      (a) StarWritep     (b) Note pad     (c) MS Word     (d) Wordstar 

72. The key used to delete the character to the left of the insertion point is. 
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      (a) Backspace    (b) Delete        (c) Space Bar     (d) Enter 

73. Each time when increase indent icon is clicked, the Paragraph is indented by ., 

      (a) 1 inch          (b) 1/2 inch      (c) 1/4 inch        (d) 2 inches 

74. The shortcut key used to move to the beginning of a document is........ 

      (a) Shift+Horae    (b) Home+Enter (c) Ctrl + B       (d) Ctrl+Home 

75. The key pressed to select the spelling command is ....... 

(a) F7             (b) F1            (c) F9            (d) F5 

 

 

       JUNE - 2007 

1.   Choose the correct answer:                                                                       

1. In StarOffice Text document can be created using ........ 

      (a) StarOffice Calc            (b) StarOffice Writer     (c) Star Office Impress          (d) StarOffice Base 

2.  Which keys are pressed to move the insertion point to the end 

     document?                                        

     (a) Ctrl + Home   b) Shift + Home (c) Ctrl + End    (d) Shift + End 

3;  Which font looks professional? 

(a) Fajite                        (b) Anal  (c) Wingdings                (d) Times New Roman 

4.  Bullets and Numbering option is available under.......... 

     (a) File           (b) Edit          (c) Format       (d) View 

5. Which key is pressed to select the spelling command? 

     (a)F5            (b)P6           (c)T7        (d) F2 

6.  The command to create a Simple Table is........ 

    (a) Insert -> Table - > Table        (b) Table -> Insert -> Table 

   (c) Table --> Insert                       (d) Format ~> Insert "> Table 

7.  To move the insertion point forward through the "cells press …. 

    (a) Shift          (b) Shift + Tab    (c) Tab          (d) Left Arrow 

 

8.  How many types of page orientations are there? 

    (a)1           (b)2          (c)3   ^       (d)4      

9.   In StarOffice Writer, to display the ruler on the screen select ruler under....... 

(a) File         (b) Edit        (c) Format       (d)View 

10. Which of the following data can be typed into a Spreadsheet cell? 
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      (a) Numbers      (b) Text         (c) Formulae     (d) All of these 

11. How many columns are there is Visicalc? 

(a) 63            (b) 254          (c) 32000        (d)256 

12. Which bars have shortcut icons for frequently done tasks in the Spreadsheet?                                         

      (a) Menu bar      (b) Formula bar   (c) Object bar   (d) both (b) & (c) 

13. Which key is pressed while editing the contents in a cell? 

      (a) F1            (b) F2      .     (c) F5            (d) F7  

14. The operator <> is used to check ............ 

     (a) equal          (b) greater.then   (c) less than      (d) ineqality 

15. Which icon provides a scrolling screen within a worksheet? 

      (a) Insert Floating Frame          (b) insert OLE object 

      (c) Insert Applet                          (d) Insert formula 

16. Which of-the following formualae calculates the sum of the numbers in the  cell A1 of sheet 1 and A2 of 

sheet 2? 

      (a) = Sum (Sheet.AI +Sheet2.A2)    (b) = Sum (Sheet: A1 ;Sheet2:A2) 

      (c) == Sum (Sheet.AI ;sheet2.A2>   (d) = Sum (Sheet1.A1 ; Sheet2.A2) 

17. The set of processed data is called ............ 

      (a) Data          (b) Datum       (c) Information   (d)Database 

18. Each row in a Database table represents...........        

(a) File            (b) Record       (c) Field           (d) Table 

19. The process to select a desired specific data from a database is... 

      (a) Searching     (b) Sorting       (c) Merging'      (d) Filtering 

20. A Database that consists of a single data table is .......... 

     (a) Relational      (b) Flat-File      (c) Hierarchical    (d) Network 

21. Which of the following is not a valid data type in StarOffice base? 

      (a) Text           (b) Time         (c) Project       (d) Integer 

22. Which is a type of query? 

(a) Table          (b) Forms        (c) Filter       : (d) Report 

 

23. How many steps are there in the report wizard window? 

     (a) 6               (b) 7              (c) 8    (d) 9     

24. What is the expansion of SQL? 

       (a) Syntax Question Language .     (b) Structured Query Language 

(c) Syntax Query Language           (d) Structured Question Language 
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25.  What is a way of limiting the information that appears on screen? 

       (a) Searching     (b) Filtering     (c) Merging      (d) Report 

26. MMS stands for......... 

(a) Multiple Messaging System     (b) Multimedia Mail System 

(c) Multimedia Messaging System (d) Multiple Mail System 

27.  The technique that provides an environment experienced by users as Similar,to reality is.....  

       (a) Virtual reality ,                  (b) Vector graphics   (c) Animations                         (d) Modeling                         

28. Name of the technique of distorting a single image to represent something' else is ..     

       (a) Modeling      (b) Rendering    (c) Morphing     (d) Warping 

29.  Files in the Windows Media format have the extension........ 

      (a) wmy        (b) .mov        (c) .swf        (d) wmf 

30. Which of the following tag is not used to launch hefper application? 

      (a) <embed>      (b) <name>      (c) <applet>    (d) <ob]ect> 

31. The number of options-displayed in the first page of the presentation wizard  is.........           

(a) 2            (b)3             c)4             (d) 5 

32.  Which of the following options display "created with StarOffice' message during the pause between 

each presentation? 

       (a) Automatic     (b) Effect        (c) Show Logo   (d) Default 

33. The view used to reorder slides is..........  

      (a) normal        (b) outline       (c) notes         (d) handouts 

34. To open media player window, choose.......... 

(a) Tools —> Media player          (b) Edit —> Media player 

(c) Insert -> Media player              (d) View ~> Media player 

35.   Which is not a Background fill option? 

     (a) Color          (b) Gradient      (c) Picture       (d) Hatching 

36. The ability of an object to respond differently to different messages is  called-... 

(a) Inheritance     (b) Polymorphism (c) Encapsulation (d) object' 

37. Which is a kind of a self-sufficient subprogram with a specific functional Area? 

(a) Objects       (b) Inheritance   (c) Functions     (d) Encapsulation 

38. Which is the smallest individual unit in a program? 

        (a) Tokens       (b) Statements   (c) Data          (d) Pointers 

39. Which is a conditional operator? 

(a)?           (b)>          (c)<          (d)?: 

40. Which of the following is a derived data type? 
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(a) Union         (b) Float         (c) Double        (d) Array 

41. How many storage specifiers are there in a C++? 

(a) 3               (b) 4              (c) 5               (d) 2 

42. Which of the following is the simplest of all the decision statements? 

(a) If             (b) While         (c) Switch        (d) Break 

 43.  In which headerfile the declarations for the objects cin are avaHable? 

(a) istream.h     (b) ostream.h    (c) isostream.h   (d) both (a) and (c) 

44.  How many times of the following loop will be 'executed? 

for (i== 1; i<6; i++) 

(a) 1                (b) 5              (c) 6              (d) 7  

45. The break statement would exit only.......:... 

 (a) current loop                   (b) current function 

(c) current program                (d) none of these 

46.  The statement intA;b;is invalid because ...... 

 (a) only one variable should be given   (b) capita! A is not allowed 

  (c) variables should be separated by Comma (d) all of these 

47. A function can be invoked from another function using its ........ 

(a) variables      (b) name        (c) return         (d) value 

48. In which method, the formal parameters become alias to the actual   parameters? 

(a) Call by reference          (b) Can by value  (c) Call by function     (d) Call by variable 

49. The function that returns no value is declared as ........ 

(a) Main          (b) Friend        (c) Void          (d) Online 

50. Which function does insert the functions  code directly into the calling     program? 

     (a) Void           (b) Main          (c) Online        (c) Inline 

51. The size of the array is always.... 

       (a) positive       (b) negative      (c) float          (d) double 

  52. Number of parameters required for write () function is.......... 

(a) 1            (b)2                (c) 3                 (d) 4 

 

  53. Which of the following function copies source string to target string? 

       (a) StrlentQ       (b) StrcpyQ    (c) StrcmpO      (d) Strcon() 

  54. How many access specifiers are there in the class body? 

        (a) 2         (b) 3            (c) 4             (d) 1 

  55. A class belongs to which of the following data types? 
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       (a) User Defined Type             (b) Bulk-in Type       (c) Derived Type                   (d) Array. Type 

  56. Class comprises......... 

  (a) Data members         (b) Member functions    (c) both (A) and (B)              (d) none of these. 

  57. Privafe access specifier is accessible by special function called.,,.. 

        (a) void          (b) inline         (c) friend         (d) all of thes> 

  58. Which ot the f6ilowing is an Object Oriented Programming? 

       (a) C            (b)C++         (c) BASIC       (d) FORTRAN 

  59. Class Product........                     

     < 

int c,q L                                           

float p; 

pi;' 

} 

The number of bytes occupied by p1 is......... 

     (a) 7                (b» 8               (c) 9               (d) 10 

60. Polymorphism is achieved in C++through............. 

 (a) Encapsulation (b) Inheritance    (c) Overloading (d) Function 

61. The mechanism of giving special meaning to an operator is called... 

      (a) Operator Overloading         (b) Function Overioadinc 

      (c) Inheritance                            (d) Object 

62.  Which' of the following is Hot a valid function prototype?- 

       (a) void fun (int x);                    (b) void fun (int x, int y); 

        void fun (inly);                          void fun (intx, floaty); 

(c) int fun (int x);                     (d) void fun (char x); 

    void fun (float x);                     void fun (char x,.int y); 

63.  Which of the following cannot haye arguments? 

       (a) Constructor                     (b) Destructor 

       (C) Function overloading     (d) Operator overloading 

64. When a class object goes out of scope, a special function that is executed    is...............                        

(a) destructor     (b) constructor   (c) function       (d) -object 

65. The constructors defined by the computers in the absence of user defined 

      constructor is called as........ 

(a) non-parameterised           (b) default (c) compiler gerated              (d) all of these 
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66. The special character related to destructor is............ 

       (a)+             (b)?            (c)-          (d)! 

67. The class from which the.other classes are derived is called as ......... 

(a) Objects                       (b) Object Classes (c) Sub-Class                   (d) BaseCiass 

68. Which is  not inherited from the base class? 

    (a) Object        (b) Function     (c) Constructor (d) Data members 

69. Class used .only for deriving other classes is .......... 

(a) Abstract       (b) Concrete      (c) Static     (d) Void 

70. ATM is an example for ............ 

      (a) e-shopping     (b) e-banking    (c) Transcription  (d) Digitization 

71. The device that converts the speech in to a letter is........... 

(a) Speaker            (b) Rock Telephone (c) Dictaphone                   (d) Head phone 

72. BPO may be expanded as......... 

  (a) Business Product Outcome        (b) Business Process Outcome  

  (c) Business Product Outsourcing   (d) Business Process Outsourcing 

73. Which prevents people from acquiring bad habits? 

(a) Archive unit                    (b) Emotion containers (c) camera            (d) speakers 

74. "Cracking" comes under..............                   

(a) Data Security                 (b) Computer Crime     (c) Website .Service            (d) Transcription                 

75. Which of the following is not a way of protection?  

     (a) Physical security                 (b) Personal Security      (c) Personnel Security              (d) Pi racy 

-------------------------------------------------------------------------------------------------------------------------------- 

 

SEPTEMBER - 2007 

1. Choose the correct answer:                                                                             

1. Which of the following functions will be executed first automatically, when  a C++ program is executed?             

    (a) Void           (b) Main         (c) Recursive   (d) Call  by reference              

 2.  The building blocks of C++program are .......... 

      (a) functions     (b) classes       (c) statements    (d) operations 

3. Which functions executed faster but require .more memory space? 

     (a) Normal function                   (b) Void function      (c) Regular function                  (d) Inline function 

 

 

www.Padasalai.Net



PUGAL XII C.S ENGLISH MEDIUM PUBLIC ONE MARK                  
 

                                                      
PREPARED BY: P.CHANDRASEKARAN M.C.A, B.ED.,    MOB:99420 12999 18 

 

4.  Which of the following statements marks the end of the function and also  transfers control to he 

statement after call statement? 

     (a) Return        (b) Break       (c) Continue      (d) Stop 

5.   The calling function parameters are called as................. 

(a) formal parameters           (b) actual parameters (c) dummy parameters          (d) duplicate param- eters       

6.  The operator used to access the member of a class is......... 

(a)&              (b).              (c)*            (d)+    

7.  A member function calling another function directly is called as,....,.,.. 

    (a) nesting of member functions    (b) recursive functions    (c). friend functions   (d) inline-functions 

8.   In C++, the class variables are called as 

     (a) methods       (b) objects       (c) constants     (d) functions 

9. The member functions declared under which scope can be accessed by  the objects of that class? 

    (a) public         (b) private       (c) global         (d) protected 

10. Which,one of the following is a membership operator? 

      (a)-         (b)::         (c)&            (d) ! 

11. A row in a'StarOffice Base table represents a............ 

(a) file              (b) structure      (c) field         (d) resord 

12. Hierarchical Database was primarily used on ............ 

(a) Super Computers            (b) Personal Computers 

(c) Micro Computers             (d) MainFrame Computers 

13. Which icon is used to remove the sorting'.in StarOffice Base? 

       (a) Delete Filter/Sort Icon         (b) Delete Sort Icon 

       (c) Remove Sort / Filter Icon    (d) Remove Fitter / Sort Icon 

14. In StarOffice Base, which is a printed information that is assembled by  gathering data base on used 

supplied criteria? 

     (a) Fitter          (b) Query        (c) Form         (d) Report 

15. Which of the following are user constructed statements in'StarOffice Base? 

      (a) Filters         (b) Queries      (c) Forms        (d) Reports 

16. The only check box in the auto correct dialog box is 

     (a) text only      (b) numbers     (c) match case   (d) whole words only 

17. Which of the following is a grid with a specified number of columns and  rows in StarOffice Writer?              

     (a) Cell           (b) File          (c) Border        (d) Table 

18. Which of the following keys is pressed to move backward through the cells 

    in StarOffice Writer Tables? 
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    (a) Tab           (b) Shift         (c) Shift+Tab     (d) Alt+Tab 

19. The default width of a page in default orientation is...... 

(a) 8.5 inch x 11 inch      (b) 11 inch x 8.25 inch (c) 11 inch x 8.5 inch    (d) 8-5 inch x1 inch 

20. The format for entering date in StarOffice Calc is....... 

      (a) YY/MM/DD    (b) YY/DD/MM   (c) DD/MM/YY   (d) MIWDD/YY 

21. Which enables online educational programs leading to degrees and     certifications'? 

     (a) Banking       (b) e-Shopping   (c) e-Banking     (d) e-Learning 

22. A facility that allows the user to speak into a special device and to convert 

     the speech into a letter is called ............. 

    (a)Microphone    (b) Dictaphone  (c) Gramophon   (d) Phone 

23. Which refers to the conversion of non-digital material to digital form? 

     (a) Data       (b) Document    (c) Tele-Medicine (d) Digitization 

24. The security refers to protecting data and computer system against dishon- 

      esty or negligence of employees is called as... 

     (a) physical       (b) personal      (c) personnel    (d) none of these 

25. Software that runs on an idle computer without the knowledge of the organization is called as theft 

of............ 

     (a) Computer     (b) Hardware    (c) Software     (d) Computer time 

26. The ability of an object to respond 'differently to different message is called as 

  (a) Inheritance    (b) Polymorphism   (c) Data hiding  (d) Encapsulation 

27. The process of creating new data types from existing data type is called as......                                   

       (a) inheritance            (b) Polymorphism (c) overloading            (d) Encapsulation 

28. C++ was developed by ............ 

(a) Dan Bricklin         (b) James Gosling  (c) Bjarne Stroustrup         (d) RickMascitti 

29. The range of int data type is .. 

(a)-32678 to 32678             (b)   -32768 to 32767   (b) -32767 to 32768              (d)   -32768 to 32768 

30. How many fundamental data types are there in C++?  

      (a) 1             (b) 2            (c) 3       .    (d) 4 

31. The constructor without any parameter is called as.......... 

  (a) initial constructor    (b) instance parameter   (c) default constructor    (d) parameterized 

constructor 

32. The default visibility mode of constructor is......... 

(a) public     (b) protected     (c) private       (d) general 
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33. The symbol'that must be used between derived and base class is...... 

   (a)&            (b):             (c)-::        (d)# 

34. A derived class that inherits from multiple base class is known as..... 

     (a) single inheritance      (b) multiple inheritance      (c) multilevel inheritance     (d) hybrid inheritance 

35. Which of the following permits banking from We comfort of the homo by  using internet facilities? 

     (a) Banking       (b) e-Shopping   (c) e-Banking    (d) e-Learning 

36. In C++, polymorphism is achieved by ......... 

      (a) Inheritance     (b) Constructor   (c) Overloading (d) Encapsulation 

37. The mechanism of giving special meaning to an operator is called as..... 

     (a) ddta overloading       (b)   function overloading   (e) variable overloading    (d)   operator overload-ing 

38. The memory space is allocated loan object using....... 

(a) constructor   (b) destructor    (c) overloading   (d) instance 

39. Which is executed automatically when the control reaches the end of the  class scope? 

     (a) Constructor    (b) Destructor   (c) Overloading   (d) Copy ConstMctor 

40. The destructor is prefixed by the character....... 

(a) #               (b) &              (c) %              (d)- 

41.  Which of the following is a computer based presentation technique th 

       incorporates text, sound, animations and video elements? 

      (a) Animation     (b) Multimedia  (c) Compression  (d) Modelling 

42. Which technique is used to distort a single image to .represent somethin   else?                                              

      (a) Warping      (b) Morphing     (c) Rendering     (d) Animating 

43. GIF stands for.........                                                     

(a) Graphic Interchange Format   (b) Graphic Information Format 

(c) Graphical Interface Format       (d) Graphic Interconnection File 

44. The expansion for MIDI is.........           

(a) Musical Instrument Data Interface (b) Musical instructions Digital "Interface 

(c) Musical instrument Digital Interface (d) Musical Information Data Interface 

45. The technique of identifying recurring set of information and replacing them 

       by a single piece of information is called as.......... 

(a) Virtual reality                     (b) Vector Graphics  (c) Compression   (d) Synthesize 

46. In StarOffice, which one of the following is used to create a text document? 

       (a) starOfficeWriter               (b) StarOffice Calc    (c) StarOfficelmpress                (d) StarQfficeOraw 
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47. The. seiection shortcut u-sed to select the entire document in StarOffice  Writer is…..          

(a) Ctrl+R          (b) Ctri+C        (c) Ctrl+V         (d) Ctrl+A 

48. Which is a set of characters in a certain style? 

(a) Text          (b) symbol      (c) Document    (d) Font 

49. What can be used to call attention to key ideas Jn the document? 

      (a) Highlighting   (b) Formatting    (c) Indenting      (d) Editing 

50. Which button is clicked to include the word to the dictionary? 

      (a) Include         (b) Replace      (c) Add          (d) Move 

51. Which facility of. StarOfficeCalc helps to format-the worksheet with different 

predefined styles and colours? 

(a) Chart          (b) Auto Format (c) Applet        (d) Muttiple sheets 

52. The term 'data' is derived from the word......... 

(a) fact           (b) forms         (c) datum        (d) entities 

53. The process used to select a desired and specific data from a database is 

(a) merging        (b) filtering        (c) Sorting       (d) searching 

41. Which of the following is a computer based presentation technique th 

      incorporates text, sound, animations and video elements? 

      (a)Animation     (b) Multimedia  (c) Compression  (d) Modelling 

42. Which technique is used to distort a single image to .represent something  else?          

      (a) Warping      (b) Morphing     (c) Rendering    . (d) Animating 

43. GIF stands for.........                                                     

(a) Graphic Interchange Format   (b) Graphic Information Format 

(c) Graphical Interface Format        (d) Graphic Interconnection File 

44. The expansion for MIDI is.........           

(a) Musical Instrument Data Interface (b) Musical instructions Digital lnterface 

(c) Musical instrument Digital Interface (d) Musical Information Data Interface 

45. The technique of identifying recurring set of information and replacing them 

      by a single piece of information is called as.......... 

(a) Virtual reality             (b) Vector Graphics (c) Compression           (d) Synthesize 

46. In StarOffice, which one of the following is used to create a text document? 

      (a) starOfficeWriter        (b) StarOffice Calc   (c) StarOfficelmpress       (d) StarQfficeOraw 

47. The. seiection shortcut u-sed to select the entire document in Starffice  Writer is ....... 

(a) Ctrl+R          (b) Ctri+C        (c) Ctrl+V         (d) Ctrl+A 
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48. Which is a set of characters in a certain style? 

(a) Text          (b) symbol      (c) Document    (d) Font 

49. What can be used to call attention to key ideas Jn the document? 

     (a) Highlighting   (b) Formatting    (c) Indenting      (d) Editing 

50. Which button is clicked to include the word to the dictionary? 

      (a) Include         (b) Replace      (c) Add          (d) Move 

51.Which facility of. StarOfficeCalc helps to format-the worksheet with different predefined styles and 

colours? 

(a) Chart          (b) Auto Format (c) Applet        (d) .Muttiple sheets 

52 The term data is derived from the word......... 

(a) fact           (b) forms         (c) datum        (d) entities 

53. The process used to select a desired and specific data from a database is 

(a) merging        b) filtering        (c) Sorting        (d) searching 

54.  DBMS is an acronym for ....... 

       (a) Database Maintaining System    (b) Database Management System 

       (c) Database Manipulating System   (d) Database Merging System 

55.  The accurate length, of decimal digits in a double precision number is..... 

       (a) 13            (b14           (c).8             (d)7 

56.  Which one of the following is used to-declare a generic pointer?  

       (a) int             (b) char          (c) void          (d) string 

57.  In C++, which file comprises the combined properties of Jstream and   ostream?                                                  

       (a) stdio.h         (b) string.h      (c) conib.h        (d) iostream.h 

58.  Which of the following is the assignment operator? 

       (a)+            (b)=           fc)===       (d).! 

59.  How many kinds of loops are there in C++? 

       (a)1             (b)2            (C)3            (d)4 

60.  Nested if.............. else statement can be replaced by the statement of..... 

       (a-) select-case    (b) switch-case (c) for           (d) do.while 

61. The process of arranging the data in a given array is called....... 

       (a) merging        (b) ordering       (c) filtering        (d) sorting 

62.  A character array should be terminated with a .......... 

       (A):           (b)0           (c)/0            (d)\0 
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63. Which string manipulator function copies source string to target-string? 

      (a) Strien()       (b) StrcopyO     (c» Strcpy()      (d) Stremp() 

64. The body of a class is terminated by-a ........... 

      (a).             (b);             (c)-;              (d)# 

65. Data abstraction in C++ is achieved by......... 

      (a) Inheritance                       (b) Potyiflorphism       (c) Data Hiding                    (d) Encapsulation 

66. In StarOff ice Impress the window allows to quickiy jump from one slide to 

      other slide or move between open files is ......... 

      (a) Desktop       (b) Navigator    (c) Preview       (d) Moving slider 

67. In StarOffice Impress, which view, allows to view miniature images'of all 

      slides?                

      (a) Sis-e Sorter   (b) Outline       (c) Notes        (d) Handouts 

68. The keyboard shortcut used to create a new presentation using template is 

      (a) Ctri+lS   (b) Shift+Ctrl+N (c) Alt+N         (d) Ctrl+F+N 

69. Which one of the following displays various transition effects that can, be  attached to a slide?             .       

(a) Custom animation               (b) Slide transition             (c) Animation effects               (,d) Slide sorter 

70. Which button is pressed to start the slide show in StarOfficetmpress? 

       (a) P1             (b) =3            (c) F5            (d) F7 

71. The bar used to display the current cell and its content is....... 

(a) menu bar      (b) object bar    (c) formula bar   (d) function bar 

72. The option under the tile menu used to quit the StarOffice is. 

       (a) Close          (b) Quit         (c) Exit       (d) End 

73. A continuous group of cells in a worksheet is called as.......... 

(a) column        (b) row          (c) datasheet     (d) range 

74. Graphic representations of numbers are known as.......... 

 a) Charts        (b) Graphs     (c) Bar diagrams (d) Cells . 

75. To do the calculations for different worksheets in a particular sheet, we use 

        (a) 20 formula    (b) function     (c) 3D formula    (d) selection 

 

      MARCH-2008 

I. Choose the correct answer:                                                                          

1.  Which of the following functions is used as electronic pets in computerized  home?                                           

     (a) Projection TV                   (b) Interactive screen       (c) Creative line                     (d) Robot 
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2.  Which of the following refers to the conversion of non-digitai material to digital form? 

      (a) Modularisation  (b) Digitization   (c) Either(a)or(b) (d) None of these 

3.   !TES stands for........... 

(a) International Technology Energy Service      (b) International Technology Enabled System 

(c) Information Technology Energy System (d) Information Technology Enabled Services 

4.  Computer ethics has its roots in the work of ........... 

(a) Herman Hollerith        (b) Robejt Wiener(c) Norbert Wiener (d)  Herman Wiener 

5. Which of the following is the telephone based Shared Service Centre? 

      (a) Call centre   (b) ATM         (c) Phone centre (d) None of these 

6.  Which of the following is not true? 

(a) Constructors cannot be overloaded (b) Constructor is executed automatically 

(c) Constructors can have parameters (d) Destructors cannot be overloaded 

Read the following declarations and answer the Questions from 7 to 9: 

class vehicle         

{ 

int wheels; 

public:              

void inputdata (int, int); 

void outputdata (); 

Protected: 

int Passenger; 

 

} 

class heavy_vehicfe; protected vehicle 

  { 

int diesel_petrol; 

Protected ; 

int load;                                              

Public:                                . 

void readdata (int, int); 

void writedata (); 

                

class bus: private heavy_vehicle 
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{ 

char marksf 20 ];                                  

Public:           .                               

void fetchdata.( char); 

void displaydata (); 

} 

7. Which is the base cfass of the class heavy_vehicle? 

     (a) Bus           (b) Heavy_vehide        (c) Vehicle       (d) Both (a) and (c) 

8. The data member that can be accessed from the function display data() is..... 

     (a) passenger     (b) load          (c) marks        (d) all of these 

9. The data member that can be accessed by an object of bus class is ........ 

    (a) inputdata     (b) readdata      (c) fetchdata     (d) all of these 

 oufputdata         writedata         displaydata 

10. The unit that enables data storage and management is ......... 

(a) Archive                      . (b) Emotion controller 

(c) warehouse                     (d) none of these 

11. Which of the following operators cannot be overloaded? 

       (a)+             (b)++           (c)+=           (d):: 

12. While overloading functions, the possible integral promotions are ...... 

 (a) char  int            (b) int  char  (c) both (a) and (b)                (d) none of these 

13. When the control reaches the end of the cfass scope, the function 

      automatically executed is........... 

     (a) Constructor    (b) End          (c) Destroyer   (d) Destructor 

14. Which of the following is used to initialize the class object? 

     (a) Static          (b) Dynamic     (c) Constructor  (d) Destructor 

15. Constructor should be declared under the scope. 

     (a) private         (b) protected     (c) pointer 

16. The members of the class can be accessed using the operator. 

      (a) +             (b) size of       (c) new          (d) (dot) 

17. The private data of a class can be accessed only through....... 

(a) member function   (b) friend function  (c) either (a) or (b)   (d) neither (a) nor (b) 

18. When a member function is defined within the class  it behaves like... 

     (a) in-line         (b) friend         (c) public         (d) private 
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19. The variable-shared by all the objects of a class  has the datatype ... 

     (a) Static         (b) Auto         (c) Extern        (d) Private 

20. In operator overloading the operator functions must be defined as....... 

(a) member function                (b) friend function 

(c) either (a) or (b)                 (d) neither (a) nor (b) 

21. Arrays in C++ belong to which of the following data type? 

      (a) Basic        (b) Derived      (c) User defined  (d) Primitive 

22. A character array should be terminated by a ........... 

(a) \\               (b) \0             (c) V?               (d) 0 

23. In a 2-Darray, the first sub-script stands for............ 

     (a) row           (b) column       (c) diagonal      (d) object 

24. The members that can also be accessed from outside the class should be  declared as........... 

     (a) Private        (b) Public        (c) Protected     (d) None 

25. Data abstraction is achieved in C++ through....... 

   (a) Data hiding   (b) Polymorphism (c) Overloading   (d) Encapsulation 

26. Which of the following creates object file from source code? 

     (a) Editor         (b) Linker        (c) Compiler     (d) Header  

27. The function that returns no value is. declared as........    

(a) Static          (b) Void          (c) Extern         (d) Null 

28. The scope of any variable used in the entire program is ........... 

(a) Local          (b) File           (c) Function       (d) Class 

29. The building block of a C++program is............ 

(a) Function '    (b) Loop        (c) Statement     (d) None 

30. The return type of the function prototype float power (float, int) is ....... 

(a) char           (b) double        (c) int             (d) float 

31. The modifier that allows the variable to exist in the memory of the  computer even after losing its scope 

is........... 

     (a) Auto           (b) Extern        (c) Global        (d) Static 

32. The declarations for the object, Cin are available under the header file... 

      (a) rnputstream.h  (b) istream.h     (c) stream.h      (d) stdstream.h 

33.Which of the following is called as put to operator? 

(a) »            (b)«           (c)##           (d) " 

34. Which of the following is the invalid variable declaration? 

      (a) int a, b;        (b) .int a ;         (c) int a:         (d) int a ; b ;  int b;              float b; 
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35. The statement used to exit from switch structure is.......... 

(a) break          (b) exit           (c) quit.           (d) default 

36. Multimedia'incorporate features like ........... 

      (a) Text           (b) Video      (c) Sound        (d) allot these 

37. The special hardware used to improve the efficiency of the display images  is 

(a) Vector Card                           (b) Vector Graphical Chord 

(c) Vector Graphics Card          (d) Vector Image 

38. Which of the following formats creates a perfect reproduction of images? 

      (a) MIDI      (b) GIF      (c) JPEG        (d) BMP 

39. MMS may be expanded as.........       . 

(a) Multimedia Messaging System    (b) Muff-media Mastering Service 

(c) Multimedia Messaging Service    (d) Multimedia Mastering System 

40. The technique of distorting a single image to represent something else is 

       (a) Turning     (b) Sampling     (c)Morphing     (d) Warping 

41. In StarOfficeimpress, to start a presentation, press............         

(a) F5             (b) F1           (c) F2            (d) F3 

42.TO create a.new presentation using a template, the key combination used 

      is.............. 

(a) Shift + Ctrl +0                   (b) Shift + N (c) Shift +0             (d) Shift + Ctrl + N 

43. To rename a slide, choose slide                         

(a) rename slide                 (b) new slide (c) rename                          (d) slide rename 

44. To open style list in presentation, press........... 

(a) F10           (b)F11          (c) F12          (d) F13 

45. Which bf'the following is used to import object from other application-into  a presentation? 

    (a) Insert QLEDB object       (b) Insert OLE object      (c) Insert ODBC object      (d) Insert DBMS object 

46.SQL stands for... ....... 

     (a) Structured Query Language       (b) Sorted Question Language 

     (c) Sorter Query Language               (d) Structured Question Language 

47. Which of the following is also a special type of query? 

     (a) Form         (b) Report       (c) Filter        (d) Question 

48.To insert the Spreadsheet Calc cell in StarOfficeWriter, seiect....... 

     (a) Edit —> Paste                         (b) Edit —> Past Special  

    (c) Tools —> Paste Special            (d) Format —> Paste 
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49.Which of the following is not a step in data processing? 

     (a) Collection      (b) Verification    (c) Computation (d) Validation 

50.A row is a StarOffice Base table represents a........... 

     (a) structure       (b) File           (c) Field         (d) Record 

51.C++ belongs to which category of programming language? 

     (a) Structured                      (b) Object oriented      (c) Modular                         (d) Procedural 

52.The group of data and operations together are known as......... 

     (a) Class          (b) Function      (c) Structure      (d) Object 

53.The escape sequence used to represent Bell, non-graphic character con-stant is............. 

     (a)\a           (b)\v           (c) \o           (d)\b 

 Inti = 6;. 

Unsigned intj = 10 ; 

Cout size of (i*J); 

54.The output when the above code is executed is.......... 

     (a) 2             (b) 4            (c) 8            (d) error 

55. If a =5 andb=4, the value of the expression a+b/2 6 is ......... 

      (a) 15            (b) 16          ,(c)17           (d) 18 

56.The ceil referencing that does not get changed when copied is. 

    (a) Relative cell addressing   (b) Database Merging Store 

    (c) Reference                         d) Comparative 

57.DBMS may be expanded as......... 

      (a) Database Maintenance System       (c) Database Management Store 

      (b) Absolute cell addressing        (d) Database Management System 

58. A database file that consists of a single data table is......... 

     (a) Flat-file database (b) Relational database    (c) Network database 

     (d) Hierarchical database 

59. The term'data has come from the word............ 

(a) Datas         (b) Datus        (c) Datem       (d) Datum 

60. The number of field types used in StarOfficeBase is........ 

       (a) 20            (b) 30           (c) 12            (d) 13         

61. The bar used to display the current cell and its contents in StarOfficeCalc is 

      (a) Menu         (b) Object       (c) Formula      (d) Function 
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62. Which of the following is the reference operator? 

,(a)%             (b)<>           (c) &            (d»! 

63. The pointer that identifies the active cell in a worksheet is..,.;..... 

     (a) Cell pointer   (b) Insertion      (c) Keyboard      (d) Mouse 

64. The default date format used in spreadsheet is........ 

      (a) dd/mm/yy     (b) mm/dd/yy    (c) dd/mm/yyyy   (d) yy/dd/mm 

65. Pill command in StarOfficeCalc is available under the menu....... 

(a) Edit .         (b) Format       (c) File           (d) View 

66. In StarOfficeWriter, the key used to move forward in a table is ......  

(a) Shift           (b) Alt            (c) Tab            (d) Ctrl 

67. In StarOfficeWriter, the command used, to insert more than one row in-a  table is......... 

(a) Insert  Table —>- Rows             (b) Insert —> Rows  

(c) Table —> Insert —> Rows       (d) Table - Rows 

68. The ruler option in StarOffice Writer is available under.......... 

(a) file       (b) edit          (c) format        (d) view 

69. The default page orientation is....... 

(a) Book         (b) Landscape   (c) Handout      (d) Portrait 

70. The first electronic spreadsheet is.......... 

(a) VisiCalc       (c) StarCalc      (c) Lotus         (d) Excel 

71. Which of the following StarOffice functions is used for creating text document? 

(a) StarOfficeBase           (b) StarOfficeCalc (c) StarOfficelmpress  (d) StarOfficeWriter 

72. The keyboard shortcut to cut a selected text is ............ 

(a) Ctrl + X         (b) Ctrl + V        (c) Ctrl + B         (d) Ctrl + C 

73. The key used to delete the characters to the left of the insertion point is 

       (a) backspace (b) delete (c) Space bar (d) enter 

74. In StarOfficeWriter, the key pressed to enter a hard return is...... 

 (a) spacebar    (b) enter        (c) backspace    (d) esc 

75. The button used to .skip the spelling change only for the current word is 

       (a) ignoreall      (b) Ignore once (c) Change       ,d) Change all 

 

JUNE . 2008 

1.  Choose the correct answer:                                                             

1.  To draw tines and circles in a worksheet click the icon........ 
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(a) Insert picture                       (b) Insert special character  

(c) Show draw functions           (d) Insert chart 

2.  Which involves data collection, varification, validation and report generation? 

   (a) Data                              (b) Data processing    (c) Database                       (d) Table 

3.  Each database column represents............. 

     (a) File            (b) Record       (c) Field          (d) Character 

4.  In which Computers Hierarchical Database structures were used? 

     (a) Mini           (b) Micro        (c) Mainframe    (d) Super 

5.  How many field .types are there in StarOffice base?        

     (a) 17 .           (b) 13           (c) 15            (d) 20 

6. The mechanism by which the data and functions are bound together within    a object definition is called? 

(a) Object        (b) Encapsulation   (c) Polymorphism   (d) Inheritance                   . 

7. What is the name for the process of acquiring the Base class properties? 

    (a) Inheritance    (b) Encapsulation (c) function      (d) Polymorphism 

8. Which brace is used to enclose the body of the C++ program? 

    (a)0      .     (b)<>       .  (c){}         (d)[] 

9.  in the following which defines Local variable? 

      (a) Auto           (b) Static     (c) Extern         (d) Register 

,10. The range of signed int data type is......... 

    (a)-128 to 127  .,       (b) 0 to 255     (c) -32768 to 32767                (d) 128 to -127 

11. Which is the default access specifier in the class? 

    (a) Private        (b) Public        (c) Protected   (d) None of these 

12. Which is referred as key feature of object oriented programming? 

(a) Data riding    (b) Encapsulation (c) Data hiding   (d) Data members 

13.The static member variable is initialized to ....... 

(a) 0               (b) 1              (c) True           (d) Fatse  

13. Which access specifier is accessible by members of inherited class? 

     (a) Private         (b) Protect       (c) Protected     (d) Class 

14. The functionality of ' +' operator can be extended to strings through 

    (a) function overloading            (b) operator overloading   (c) inheritance         (d) class 

15. Presentations can be created using 

      (a) StarCWiceWriter          ( b) StaifOffieeWriter  (c) StarOfficelmpress         (d) StarOfficeDraw 

16. Which is a word, processor? 

       (a) StarWiceBase          (c) SlarOffice Impress       (b) StarOfficeCalc     (d) StarOfficeBase 
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17. In SlarOfficeWriter, under which menu all the .formatting options are available............ 

      a) File           (b) Edit    .     (c) View          (d) Format 

18. Which can be used to call attention to key ideas? 

     (a) Formatting                (b) Highlighting      (c) Bullets and Numbers             (d) Indenting 

19.The command to open a spell check dialog box is......... 

    (a) Edit -> Spelling ~> Check        (b) Tools ->Spelling -Check 

    (c)..Edit—> Check ~> spelling      (d) Tools -> Check -Spelling 

20.Improve'spreadsheet was developed by .......... 

     (a) Lotus Corporation         (b) Microsoft      (c) Apple                      (d) Borland 

21.Spreadsheet accepts the date format as........... 

    (a) DO/MM/YY    (b) MM/DD/YY   (c) YY/MM/DD   (d) YY/DD/MM 

22.Which of the following is reference operator? 

     (a).&              (b)
A
              (c) :         <d) = 

23.A continuous groupof cells in a worksheet is called......... 

    (a) Record       (b) Range       (c) Group   .  (d) Sheet 

24.Which are referred to as predefined formulae?. 

     (a) Functions , (b) Charts       (c) Objects       (d) Cell address 

25.Which shows special views of the data in a table? 

     (a) Queries      (b) Forms       (c) Reports      (drillers 

26.What is the; name of the process for joining data from two or more tables? 

       (a) Joining        (b) Editing        (c) Merging      (d) Adding 

27. An example for Object Oriented Language is........... 

(a) StarOffice     (b) C            (c) C++          (d) HTML 

27- Which is a kind of a self-sufficient 'sub-program' with a specific functional area? 

(a) Entity          (b) Object       (c) Overloading   (d) Ciass 

28. Based on operand requirements, operators are classified as ......... types. 

(a) 2             (b)3            (c)4             (d) 5 

29. Which of the following is the simple assignment operator? 

      (a)=            (b)==          (c)+=          (d)!= 

30. How many bytes does the unsigned int data type occupy? 

      (a) 1             (b) 2            (c) 3            (d) 4 

31. Which one of the following cannot be overloaded? 

      (a) Constructor    (b) Destructor   (c) Operator      (d) Function 

32. The class from which the new classes are derived is known as........ 
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     (a) base class    (b) derived class (c) Child class    (d) sub-class 

33. Which form of inheritance is reflected by the transitive nature of inherit-ance? 

     (a) Multilevel     (b) Multiple level (c) Singleton      (d) Multipath 

34. Whenever a class object goes out of scope, a special function that gets executed is.............. 

(a) Destructor    (b) Constructor   (c) Destroy       (d) End 

35. C8T stands for....... 

     (a) Computer Brand Tutorials      (b) Computer Based Tutorials 

     (c) Computer Based Training       (d) Computer Based Tutors 

36. Which one of the following operators can be overloaded? 

      (a) Membership   (b) Size of       (c) Unary        (d) Conditional 

37. The......... arguments of overloaded functions are not considered by the 

C++ compiler as part of the parameter list. 

(a) actual         (b) reference     (c) formal        (d) default 

38. Which of the following gets executed, when an instance of a class comes  into scope? 

       (a) Constructor   (b) Destructor    (c) Overloading   (d) Encapsulation 

39. Constructor has the same name as the ......... 

       (a) object         (b) htmt          (c) class         (d) instance 

40. The constructor without any parameter is called as........ 

(a) initial constructor                (b) instance constructor 

(c) default constructor             (d) parameterized constructor   

59. Which is not in the step process of creating a 3D animation? 

      (a) Modelling     (b) Moving      (c) Animating     (d) Repdering 

60. Shockwave format ^as developed by........... 

(a) Microsoft '   (b) Apple        (c) Macromedia (d) !BM 

61. Statement used in C++ to display messages and result is....... 

(a) print           (b) printin         (c) cout          (d) cin 

62. Which are the channels through which data flow from the call statement to the function? 

 (a) Function Name         (b) Parameters (c) Values                        (d) Return 

63.. in which method any change in the formal parameter is not reflected back 

       to the actual parameter? 

(a) ball by value          (b) Call by reference (c) Both (a) and (b)      (d) Call by function 

64. Which function executes faster but requires more memory space? 

     (a) Void          (b) Main         (c) Inline        (d) Online 
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65. Which variable is defined within a block? 

(a) Local          (b) Function      (c) File           (d) Cass 

66. What is useful in computer based education? 

    (a) CBT          (b) e-shopping    (c) Transcription  (d) Teaching 

67. Which is used for customer-related functions? 

   (a)le-shopping    (b) e-banking    (c)-e-mail        (d^ Call centres 

68. What refers to the conversion of non-digital material to digital form? 

    (a) Transcription   (b) Tele-medNne (^Digitization   ^d) Data Manage-ment                                                

69.Which of the following is not an IT enabled service ? 

(a) Reservation   (b) e-Governance (c) Tele-medicine (d) Data manage-ment                

70. A self-re pi Seating program that damages data and files stored on the  computer is called.......... 

(a) Software                     (b) Data Management      (c) Virus                     (d) e-Governance 

71. How many destructors can be given in a class? 

(a)1              (b)2     .      (c)3             (d)0 

72. In inheritance, the newly created classes from the base class are....... class 

(a) base          (b) derived      (c) super     (d) void 

73. Which operator is used while defining a derived class? 

      (a):.            (b);             (c):,             (d)- 

74. Access specifier is also referred to as ....... 

(a) derived                              (b) base (c) visibility mode                .(d) derived members 

75: Which permits banking from the comfort of the home by using internet? 

     (a) Call centres    (b) e-banking    (c) e-shopping    (d).e-cards   

              

 

MARCH - 2009 

Choos  the best answer                                                                

1. The building Mocks-of C++ programs are called as 

    (a)functions       b) programs     c) classes     d) inheritance 

2. The functions that return no value are called as 

      a) static            b) inline          c) getline       d) vodd 

 3. Any change made in the formal parameter which is reflected back in the actual     parameter is 

     a) call by value   b) cally by method   c) caily by function d) calt by reference 
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 4. T"® variable declared above all blocks and functions is called as 

     a) Loal Scope    b) Function Scope    c) File scope (d) Class Scope                . 

5. The key feature of object oriented programming is 

     a) Data Abstraction b) Encapsulation c) Polymorphism    d) Data Hiding 

6. The members of the class are accessed by using a/an 

    a) Increment operator                     b) Decrement operator 

     c) Scope Resolution operator         d) Dot operator 

7. Members defined within the class behave like a / an 

    a) Friend function   b) Inline function c) Member function. d)GeOine function 

 8. A member function which can call another member function directly without using dot              

    operator is called as 

   a) Data member function                 b) Static data members 

   c) Nesting of member function     d) Inline function 

9. The mechanism of giving a special meaning loan operator is called as 

       a) Constructor overloading             b) Function overloading 

       c) Operator overloading                 d) Destructor 

10. The user defined screens that are used to enter view edit the data in a table 

     Starbase  re called as      

a) Tables          b) Queries        c) Forms      d) Reports. 

11. Filter used with a condition is called 

a) Filter            b) Standard Filter c) Autofi.eter d) Remove filter 

12- Which of the following is not a step in data processing ? 

a) Collection       b) Verification     c) Computation  d )Validation 

13. The different field types in StarOfficebase are 

a) 14              b) 20             c) 25          d)  12 

14. The term'Data' comes from the word 

     a) Datum          b) Fact          c) Entity       d)  Information 

15. In StarOfficeWriter, which of the following commands is used to get a table 

     format dialog box? 

a) Tabe -> Table properties         b) Table -Table Format 

c) insert —> Table properties        d) Insert —> Table. 

16. In StarOfficeWriter table, intersection of Row and Column is called 

 a) pointer           b) Cell           c) table         d)   cell reference. 
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17. If the length of the document is more than the width, the orientation is called us 

      a) page            b) landscape     c) portrait     d)  header 

18. Which of the following dialog boxes can he used to set the margins in  StarOfficeWriter? 

    a) Format         b) Table         c) Paragraph   d) Page Style 

19. A continuous group of cells in a worksheet is called 

     a) Range          b) Intersection    c) Merging     d) Sorting 

20. CBT means                   . 

a) Computer Based Tutor           b) Computer Based Tutorials 

c) Computer Based Teaching        d) Computer Basea Technology 

21. A category of IT enabled service pertaining to collection, digitization and 

     processing of data coming from various sources is 

    a) e-govemance    b) Call centres   c) Data digitization  d) Data Management. 

22. The illegal access to the network or computer system is called as . 

     a) Piracy          b) Computer Crime c) Computer ethics  d) Cracking   

23. A self'replicating program that can cause damage to data and files stored in ,a computer is called                     

     a) crime           b) Virus         c) application   d)  piracy 

24. A Security, that refers 'to protecting data and computer system against 

     dishonesty or negligence of employees is 

     a) Data Security   b) Physical Security c) Personal Security d) Personnel Security           

25. Which of the following is the process of deriving a class from an existing class? 

      a) Inheritance     b) Class         c) Polymorphism    d) Object 

26. The ability of an object to respond differently to different messages is called as 

       a) .Object          b) class         c) polymorphism  d) inheritance. 

27. Which of the following have special meaning to the language compiler? 

     a) Tokens         b) Constants     c) Identifiers   d) Keywords 

28. The storage specifier that instructs the compiler to store the variable in the 

     CPU register to optimise access is            

     a) auto            b) static         c) extern       d) register 

29. Which of the following qualifiers specifies that the value of the variable will not 

       change during the run time of the program ? 

     a) Const           b) Static         c) Extew      d) Auto 

30. Which of the following is a scope resolution operator-? 

 a)  :              .    b) ;                 c) ::          d)   .* 

31. A special function that has the same name as the class name is 

www.Padasalai.Net



PUGAL XII C.S ENGLISH MEDIUM PUBLIC ONE MARK                  
 

                                                      
PREPARED BY: P.CHANDRASEKARAN M.C.A, B.ED.,    MOB:99420 12999 36 

 

     a) constructor     b) destructor     c) both (A) and (B) d) friend function 

32. The default visibility mode in inheritance is 

a) public           b) static         c) protected    d) private 

33. When a derived class inherits from multiple base classes, it is known as 

   a) single inheritance         b) multiple inheritance     c) multilevel inheritance           d) hybrid inheritance        

34. Classes used only for deriving other classes are called as 

a) Abstract classes                  b) Derived classes c) Base classes                        d) Destructor 

35. Which of the following enables online educational programs leading to 

      degrees and certifications? 

a) e-governance                     b) e-learning c) e-banking              d) e-commerce 

36. Which,of the following operators cannot be overloaded? 

a) +                 b) ++              c) ::             d)   + = 

37. During overloading of which of the following operators, the left hand object 

      must be an object of the relevant class? 

      a) Unary           b) Binary        c) Ternary     d) None of these 

38. When an instance of a class comes into scope, a special function called... 

      gets executed. 

a) constructor           b) destructor   c) function overloading                d) operator overloading 

39. Constructors defined by the computers in the absence of user defined 

     constructor is called as                         

      a) default constructor         .b) copy constructor       c) parameterised constructor         d) both (A) and (C) 

40. A function that removes the memory of an object which was allocated by   the constructor at the time of 

creating an object is 

             a) constructor.            b) copy constructor b      c) default constructor                d) destructor 

41. MMS means 

a) Multimedia Services              b) Multimedia Messaging System 

c) Multimedia System               d) Multimedia Messaging Structure 

42. Multimedia applications that allow users to actively participate instead of just 

     sitting by as passive recipients of information are called as 

        a) Interactive Multimedia           b) Multimedia .System 

       c). Computer based Tutorial         d) Web based Tutorial 

43. A technique by which you can blend two or more images to form a new   image is             

      a) Modeling       b) Morphing    c) Warping    d) Animating 
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44. The compression that retains the exact image throughout the compression is called 

a) lossless compression            b) lossy compression c) rendering      d) animating 

45. The format that was developed by Macromedia and is used to store 

        Multimedia components creating using Flash is 

      a) AVI format     b) MIDI format   c) Wave format    d) Shockwave format 

46. In StarOffice Writer, as the characters are typed the flashing vertical bar that   moves .towards right is 

called 

      a) Pointer        b) Insertion point   c)Key       d) Word wrap 

47. In StarOfficeWriter, Shortcut key used to select the whole document is 

     a) Ctrl + A         b) Ctrl + S       c) Alt + A      d) Alt + E 

48. The named set of defaults for formatting text is 

      a) Style            b) Help agent     c) Indentation   d)  Highlighting 

49. The Button used to skip the spelling change for the current word is 

        a) Ignore    b) Change       c) Ignore once d) Skip 

50. In StarOfficeWriter key combination used for justifying the selected paragraph is 

       a) Ctrl + C     b) Ctrl + E        c) Ctrl + B      d) Ctrl + J 

51. The function used to find the square root of a given number is 

    a) Sqr()         b) Sqrt()    c)Sqt()      d) SquarerootQ 

52. The process of arranging the data in some order in a table is called 

       a) Searcning       b) Sorting       c) Merging     d) filtering 

53. A database file that consists of a single data table is called 

     a) Flat file database        b) Relational database     c) Network database                 d) Hierarchical database 

54. The key that uniquely identifies every record in a database table is, 

      a) Unique key     b) Record key   c) Primary key d) Secondary key 

55. The key combination used to save the database table is 

      a) Ctrl+C          b) Ctri+S        c) Ctrl + V      d)   Ctrl + A 

56. Read the following C++ program carefully and answer the Questions from 56 

       to 60 : 

# include < iostream.h >                         

voidmainO 

{ 

int num '== 2 ; 

do 
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{     

cout   num * num '\t'; 

num + = 1 ;                        

}                                                   

while (num <6); 

} 

57. Name the control variable used in the program              

     a) num           b) + = 1    .    c) \t          d) None of these 

58. What is the test expression (condition ) used ? 

     a) num          b) num  num    c) (num <6) d) None of these 

59. How many times will the loop be executed? 

     a) 6           .       b) 4               c) 5              d)   3 

60. What is the output of the following program?             

      a) 2 4   9 16 25               b) 2 4 6 8      c) 4 9 16 25         d) 0 4 9 25 

61 . What type of loop statement-is used in the program? 

     a) Entry check loop                  b) Exit check loop       c) Entry controlled -loop               d) Selection loop 

62. The subscript of an arrays always commences from     

       a)   1                   b) -1                   C) 0              d)   2 

63. Which of the following is a 2-dimensional character array? 

   a) Array of strings                  b) Matrix     c) Literals                                d). Strings 

64. Which of the following is an invalid array declaration? 

     a) int array [100 ];       b) int array [];   c) int array [ i ];             d) const .int i = 10 ; int array [ i ]; 

64. A way of binding the data and its associated functions together is called as 

     a) class            b) objects        c) functions    d) data hiding 

65. The body of a class is enclosed within braces and is terminated by  

       a) .            b) ;              c)             d) * 

66. In StarOffice impress, the page used to specify basic background informa- tion that needs to be included 

in all the slides is 

      a) Slide Transition                   b) Custom Animation       c) Master page                       d) Layout 

67. The function key which is used to ru,n or start the presentation is 

      a) F2           b) F1            c) F4          d) F5    

68. Which of the following keys is used to create a new presentation- using template?  

a) Shift+Alt+N                    b) Shift+Ctri+N c) Ctri + Alt + N     .             d) Shift + Tab 
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69. Which command is used to insert a picture in. a slide? 

    a) Insert -> Picture                           b) Format -> Picture  

    c) Insert —> Picture ->-From file    d) View -> Picture ->Insert 

70. Which command is used to open HTML Export window in StarOffice  impress? 

a) file—> Export                    b) Tools-> Export 

c) Insert —> Export                 d) File/-> Open -> Export 

71. Which command is used to generate a series in SlarOfficeCalc ? 

      a) Cell reference   b) Copy         c) Fill        d) Cut     . 

72. Predefined formulae that are available/in StarOfficeCalc are 

    a) Relative cell referencing            b) Cell address 

    c) Absolute celt referencing           d) Functions 

73. In StarOfficeCalc, which command is used to change the width of the column in a worksheet? 

a) Insert —> Column —> Width        b) Insoh -> Width ~> Column 

c) Format —> Column —> Insert       d) Format ~> Column —> Width 

74. Which of the following icons provides to generate a scrolling screen within  a worksheet? 

a) Insert Formula            b) Insert OLE object c) Insert Floating France          d) Insert Chart 

                                                             

 

JUNE-2009 

              Choose the Correct answer:                                 

1.  Which helps to format the worksheet with predefined styles and colours? 

a) AutoStyleSheet      b) AutoColor Sheet c) AutoFormatSheet                d) AutoSheet 

2. Each row in a table represents...... 

     a) Record         b) Field          c) File         d) Database 

3. In StarOfficeBase, how many field types can be used? 

     a) 14             b) 20           c) 11          d) 12 

4. Which of the following is the special views of the data in a table? 

     a) Sorting         b) Filtering       c) Queries     d) Editing 

5.   Which of the following filters is with a condition? 

      a) Autofitter         b) Sortfilter   c) Filter        d) Standard filter 

6.  Which of the following provides security to data? . 

      a) Class           b) Data hiding  c) Base class d) Derived class 

7. Which one of the following is an example of object oriented programming? 
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     a) BASIC         b) C            c) Pascal      d) C++ 

8. How many classifications of operators are there based on operand 

     requirements in C++? 

     a) 13             b) 4            c) 3           d) 14 

9. What is the maximum range of\insigned integer datatype? 

    a) 255           b) 65535        c) 32768      d) 3.4e+10 

10. Which Escape sequence is used to represent New Line? 

a) M             b» \n          c) \;m        d) \x 

11. The body of the class is terminated by a............ 

      a) (comma)      b) : (colon)      c) ; (semicolon)   d)   ( ) 

12. Member functions are called as............ 

   a) Datatypes       b) Access specifiers      c) Methods        d)  Attributes 

13. How many copy (copies) of the. member variable is (are) created if it is static memory?      

      a) 
;
 Two           b) One.      c) Three      d) Four 

14. Class product 

< 

int a, b; 

             float P; 

public: 

void assign_data ();                                          . 

void dteplay ();                                                

           void main() 

{                            

product PI, P2 ;  

}.           

The number of memory bytes allotted for the variable P1 is...... 

      a) 12             b) 10         c) 8           d) 4 

15. The mechanism of giving special meaning to an operator is called ....... 

       a) Operator overloading            b) Function overloading       c) Inheritance         d) Object 

16. A word processing document may contain ......... 

     a) text and tables                   b) graphs and charts      c) pictures                             d) arf these 

17. Which command is selected to cut the selected text in StarOffice Writer? 

      a) File -> cut                          b) Edit -> cut      c) Format —> cut                   d) Tools —> cut 
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18. Which of the following keys opens the starOffice help? 

      a) F1           b) F4            c) [=12         d) F2 

19. Which fonts took professional ? 

      a) Fajita          b) Times New Roman  c) Anal           d) Arial Black 

20. Which of the following keys is pressed to delete a misspelled word and the        word is retyped? 

      a) End            b) Home        c) Shift + Delete  d) Backspace 

21. in StarOfficeCalc the syntax of formula always begins with......... 

      a) '$                b) #   .           c) =       .   d)  ^ 

22. In which of the following formats the date is entered in a cell in       StarOfficeCalc? 

      a) DD/MM/YY     b) MM/DD/YY   c) YY/DD/MM d) YY/MM/DD 

23. Which of the following functions is used to find square root of a given   number in StarOfficeCalc? 

      a) SQRC)         b) SQRSQ      c) SQRTQ   .d) SQUAREQ 

24. Which of the following reference operators is named as Intersection"? 

     a)         b) I           c) &          d) = 

25. Which of the following formulae calculates the sum. of. numbers in the cell        A1 of sheet 1 and A2 

of sheet 2? 

a) = sum (sheet 1 .A1 + sheet 2.A2)   b) = sum (sheet! . A1 + sheet2  A2) 

c) = sum (sheetl. A1 ; sheet 2.A2)    c) = sum (sheet! .A1 : sheet2.A2) 

26. What is the expansion of SQL? 

a) Syntax Question Language         b) Structured Query Language 

c) Syntax Question Language        d) Structured Question Language 

27. To insert the Spreadsheet Calc cell in startOffice Writer, select... 

       a) Edit -> paste                    b) Edit ~> paste Special 

       c) format -paste                   c) Tools -> paste Special 

28.A database that consists of a single data table is ...,...., 

       a) Flat-File         b) Relational      c) Hierarchical d)  Network 

 

29. Which of the following displays the fields of a records in well spaced out manner ? 

  a) Query           b) Report        c) Form       d)-Table 

30. Which icon is pressed'to displays the records in original order after sorting? 

  a) Remove Filter /Sort              b) Delete Filter / Sort 

  c) Exclude Filter /Sort                d) Delete Sort / Filter 

31. How many types of arrays are there? 

      a) 3                  b) 4                c) 6             d)  2 
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32. Which of the following functions copies source string to target string? 

      a) Strien( )         b) Strcpy( )     c) Strcmp( )   d) Strcon( ) 

33. What will be the size of the array float exam [4] [6]? 

      a) 10 bytes         b) 96 bytes      c) 24 hyte-s    d) 20 bytes 

34 Which of the following is a way to bind the data and its associated functions  together? 

    a) Array            b) Function     c) Class        d)  Pointer 

35. Class name is also called as..,,,...... 

     a) Function       b) member     c) method     d) tag 

36. The view-used to reorder slides is.......       

       a) Normal         b) Outline       c) Notes       d) Handouts 

37. Which command is used to open HTML Export Wizard? 

  a) File -> Export                b) Tools ~> Export 

  c) Insert -> Export               d) File->0pen-> Export 

38. Which of the following is used to import objects from other application into a   presentation 

      a) Insert Object           b) Insert OLE Object
l
       c) Insert Plug-in          d) Insert Application 

39. Which key is used to start a presentation? 

      A ) F2             b) F5           c) F7         d) F11 

40. Which page can be used to specify basic background information that to be  included in all the slides? 

     a) Master page                    b) Layouts      c) Custom animation            d) Slides transition 

41. Which of the following terms means a name having two or more distinct meanings? 

   a) Data Abstraction                 b) Encapsulation     c) Inheritance                       d) Overloading 

42. The Overloaded function definitions are permitted for which of the following data      types? 

     a) Built in                               b) User defined    c) Derived                            d) All of these 

43. The constructor without parameters is called as......... 

    a) method constructor       b) operator constructor    c) functional constructor        d) default constructor 

44. The special character related to destructor name is.......... 

     a) +                 b) ?               c) -             d)   ! 

45. How many destructors are allowed in a class? 

    a) Only one       b) Z            c) 3 

46. Which is the smallest individual unit in a program? 

     a) Tokens         b) Statements    c) Data 

47. Which of the following that cause flow of control jumps from one part of the   program? 

  a) Control Structures                b) Operators     c) Puntuators                           d) Identifiers 

48. The statement intA; b; is invalid because-........ 
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     a) only one variable should be given       b) capital A is not allowed 

     c) variables should be separated by cmma(,)      d) all of these 

49. Which decision statement creates branches for multiple alternatives? 

     a) if..-else          b) switch         c) Cin          d)  whiie 

50. Which of the following statements forces the next iteration of the loop to take   place skipping any code 

following it? 

     a) Break          b) Switch        c) While      d) Continue 

51. Which of the following is an Intersection of a column and a row? 

     a) Grid             b) Cell        c) Tabis        d)  Data 

52. The command to create a simple table is....... 

    a) Insert -> Table-)- Table           b) Table -Insert –Table   c) Table-Insert         d) Format- Insert-Table 

53.  The width of a document will be more than the length called......... 

      a) Landscape                     b) Portrait      c) Paperformat                     d) Paper source 

54. In startOffice Writer,the default top and bottom margins are........ 

     a) 1 inch          b) 1.25 inch      c) 1.5 inch     d) 0.5 inch 

55. Which was the first electronic spreadsheet? 

       a)  VisiCalc        b) Lotus 1-2-3    c) Quatrapro   d) Ms-Excel 

56. JPEG stands for............. 

a) Joint photographic Expression Group  b) Joint picture Experts group 

c) Joint photographic Experts Group  d) Joint picture Expression Group 

57. In Which yearAVI format sound files are daveloped? 

     a) 1995          b) 1992        c) 1985       d) 1991 

58. Which of the following tags is not used to launch helper applications? 

      a) <embed>       b) <name>      c)<applet>    d) <object> 

59. The technique that provides an environment experienced by users as similai   reality is................. 

a) Virtual reality      b) Vector graphics c) Animations           d) Modeling 

60. Convers'.on of analog sound wavesto a digital format is called as............. 

     a) Echo          b) Sound forge   c) Frequency  d) Sampling 

61. The break statement would exit only the........... 

a) Current loop       b) Current function C) Current program    d) None of these 

62 . in which method, any change in the formal parameter is not reflected back 

the actual parameter? 

a) call by reference    b) call by address c) call by value       d) call by variables . 
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63. which of the following reduces the size of the program? 

  a) Keywords       b) Variables     c) Tokens     d) Functions 

64. which of the following refers to the accessibility of a variable? 

      a) Scope                   b) Stacks      c) Storage classes     d) Functions 

65. which scope are not know outside their own code block? 

     a) Local        b) Function       c) File         d)  class 

66. ATM means............... 

a) Auto Teller Machine                    b) ArithmeticTeller Machine 

c) Automatic Teller Machine        d) AutomatedTelling Machine 

67. How many steps are involved in Medical Transcription? 

a) 2        .     b) 4            c) 3           d) Many 

68. Which of the following IT Enabled Services is a category of pertaining to collec- tion, digitization and 

processing of data? 

     a) Call Centers        b) Data Management      c) E-Governance     d) Web based services 

69. Computer ethics has its roots in the work of............. 

a) Charles Babbage      b) Herman Hotlirith c) Blaise pascal            d) NorbertWiener 

70. Which of the following is a self replicating program that can cause damage to 

      data and files stored on your computer? 

      a) Virus          b) piracy         c) Crime       d) Security 

71. which of the following functions initializes the class object? 

     a) Destructor        b) pointer     c) Constructor    d)0perator overloading 

72. The roost powerful feature of an object oriented programming language         is......... 

  a) clasps              b) polymorphis  c) Inheritance    d) Encapsulation 

73. classes used only for deriving other classes is............ 

a) Abstract        b) Concrete      c) Static       d) Void 

74. The character used between derived and base class name is.. 

       a) :;           b) : (colon)     c)  (semicuion)   d)  S 

75. The device that converts the speech into a letter is............. 

a) Speaker       b) Reck Telephone c) Dictaphone    d) Headphone 
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I. Choose the correct answer                                                                            

1. The statement int is invalid because............ 

(a) only one variable should be given (b) capital A is not allowed 

(c) variables should be separated by comma (d) all of these. 

2. Which of the following statements, marks the end of the function in C++? 

.   (a) Continue      (b) Break        (c) Return       (d) End 

3. In which of the. following methods any change made in the format parameter  is reflected back in 

the>actual parameter? 

    (a) Call by value                    (b) Call by reference    (c) Cail by function                (d) Call by statement 

4.  The function that returns no value is declared as............ 

    (a) Main           (b) Friend        (c) Void          (d) Online       

5. Which of the following is called scope resolution operator? 

     (a)&              (b),*            (c) ::             (d)?: 

6.  Which of the following class access specifiers is optional? 

      (a) Public         (b) Protected     (c) Private       (d) Class 

7.  Data members are called as........... 

    (a) Methods       (b) Attributes    (c) Datatypes     (d) Pointers 

8. Which of the following members can be accessed only from-within the  class?                                

    (a) Private        (b) Public        (c) Protected     (d) Static 

9.  Class product 

{ 

int a, b ; 

float P; 

public: 

void assign_data () 

void display (); 

};                                             . 

void main () 

{ 

product P1, P2 ; 

} 

The number of bytes allotted for the variable P1 is............... 

(a) 12           (b) 10           (c)8            (d)4 

www.Padasalai.Net



PUGAL XII C.S ENGLISH MEDIUM PUBLIC ONE MARK                  
 

                                                      
PREPARED BY: P.CHANDRASEKARAN M.C.A, B.ED.,    MOB:99420 12999 46 

 

10. Which .of the following terms means a name having two or more distinct  meanings? 

     (a) Overloading  (b) Encapsulation (c) Inheritance    (d) Data Abstraction 

11.  How many field types are there in StarOfficeBase? 

(a) 13            (b) 11            (c) 10            (d»20 

12. Which of the following filters is a filter used with a condition? 

       (a) Autofilter       (b) Sortfilter       (c) Filter      (d) Standard filter 

13. DBMS stands for ............. 

(a) DataBase Manage System             (b) DataBase Management System 

(c) DataBase Management Structure  (d) DataBase Message System 

14. To insert a text outine into presentation, choose.............. 

    (a) File —> Insert -> Presentation              (b) File -> Send —> Presentation 

    (c) File —> Insert —> Outline to Presentation     (d) File ~> Send —> Outline to Presentation 

15. Which of the following is a process of joining data from two or more tables     of_dtfferent databases? 

     (a) Searching   (b) Sorting       (c) Merging      (d) Filtering 

16. To move Insertion Point Backward through the cells of a table press...... 

     (a) shift          (b) shift + tab    (c) TAB          (d) Left arrow 

17 . By default  each ceil in a table includes a ........... 

    (a) border       (b) row          (c) column       (d) row and border 

18. The length of a document will be more than the width. This alignment is called as.............                                      

    (a) Landscape    (b) Portrait      (c) Paper format (d) Paper source 

19. In StarOfficeWriter, to display the ruler on the screen, select rule under......... 

(a) File            (b) Edit          (c) Format       (d) View 

20. Visicalc was invented by ............. 

(a) Dan Bricklin   (b) Bob Frankston (c) Bill Gates                     (d) Dan Bricklin and Bob Frankston 

21. CBT Means............... 

(a) Computer Based Tutorials     (b) Common Based Tutorials 

(c) Computer Based Teaching      (d) Computer Based Teacher 

22. Which of the following IT Enabled Sen/ices is a category of "pertaining to 

    collection, digitization and processing of data? 

      (a) Call Centres            (b) Data Management       (c)E-Governance                  (d) Web based services 

23. Which of the following refers to the process of converting a non-digital   material to digital form? 

   (a) Data conversion                 (b) Medical transcription 

   (c) Data digitization                (d) Digital conversion cracking 

24. Which of the following securities refers to the protection of hardware? 
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      (a) Personal       (b) Personnel     (c) Physical      (d) Data 

25. If a software runs on an idle computer without the knowledge of the   organization, it is called as theft of  

 (a) software       (b) organization   (c) computer time(d) hardware 

26. In which of the following mechanisms are the data and functions bound  together within an object 

definition?  

   (a) Polymorphism (b) Inheritance    (c) Encapsulation (d) Operations 

27. The ability of an object to respond differently to different messages is called     as .....................                                            

    (a) Polymorphism (b) Inheritance    (c) Encapsulation (d) Function 

28. Who developed C++? 

   (a) TTBjarne Stroustrup             (b) Dennis Ritcnie   (c) Rick Mascitti        (d) Dan Bricklin 

29. By default, the local variables are  

     (a) Auto           (b) Static         (c) Extern         (d) Register 

30.  What is the fange of int data type ? 

      (a) -32768 to 32767               (b) -32767 to 32768      (c) -32728 to 32727                (d) -32728 to 32729 

31. Name of a destructor begins with................ 

      (a)+                  (b)?                (c)-                (d) ' 

32. Which of the following is a class fr om which other classes are derived? 

     (a) Derived class  (b) Base class   (c) Function class  (d) Superclass 

33. Which of the following is a default visibility mode ? 

    (a) Public          (b) Protected     (c) Private        (d) Class 

34. Classes used only for deriving other classes are called as ......... 

     (a) base          (b) derived       (c) abstract      (d) static 

35. What will be the 85% usage of computer? 

     (a) Word processing               (b) Database       (c) Spreadsheet                         (d) Presentation 

36. Which of the following is, not true related to function overloading? 

(a) Each overloaded function must differ by the number of its formal parameter 

(b) The return type of overloaded functions may be the same data type 

(c) The default arguments are considered by the C++ .compiler, as part of the   parameter list. 

(d) Do not use the same function name for two unrelated .functions 

37. By integral promotions, int data type can be converted .into which of the following? 

      (a) Char           (b) Double        (c) Float          (d) All  of these 

 

38. Which of the following cannot be overloaded?                   
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     (a) Constructors   (b) Destructors   (c) Operators     (d) Functions 

39. Which of the following is automatically executed when the obiecl is created? 

     (a) Constructor   (b) Variables      (c) Operators     (d) Destructor 

40. When a class object goes out of scope, which of the following special functions gets   executed? 

     (a) Destructor     (b) Constructor   (c) Overloading    (d) Pointer 

 41.  MPEG stands for..........                          

       (a) Moving Pictures Experts Group      (b) Mo'del Pictures Expression ^Sroup 

       (c) Moving Pictures Expression Group    (d)Morphing Pictures Experts Group 

42. Conversion of analog sound waves to a digital format is called as........... 

       (a) echo          (b) sound forge   (cf frequency     (d) sampling 

43. Which of the following is a technique to blend two or more images to form a new image? 

       (a) Warping       (b) Morphing    (c) Modelling     (d) Animating 

 44. In which year was real audio format developed? 

        (a) 1982          (b» 1995         (c) 1994 ,       ((ft 1981 

45. Which tag is, used to add in-line sound to a web page? 

   (a) <inline>       (b) <bgsound>   (c) <sound>      (d) <helper> 

46. In SlarOfficeWriter, the flashing vertical bar is called.......... 

    (a) Pointer        (by Marker       (c) Insertion point   (d) Key 

47. Which of the following keys is used to select the entire' document in  Star officeWriter?                                                   

       (a) Ctrt+E         (b) Ctrt+L        Ic) Ctr»+A        (d) Ctrt+D 

48. Which is used to call attention to key ideas or points in a document? 

      (a) Highlighting   (b) Editing        (c) Formatting,    (d) Text color 

49. Which, of the following is the decorative font? 

      a) Fajita         (b) Times New Roman       (c) Arial           (d) Arial Black           

50. Which key is pressed to select the spelling command? 

      (a) F5            (b) F6           (c) F7       .   (d) F2 

51. Which of the following formulae calculates the sum of numbers in the cell 

 A2 of sheet 1 and A1 of sheet 2 ? 

     (a) = sum (sheet 1 . A2 + sheet 2 .A1)     (b)= sum (sheet 1 ; A2 ; sheet 2 : .A1) 

     (c) =s sum (sheet 1 . A2 ; sheet 2 .A1)   (d)= sum (sheet 1 . A2 ; sheet 2 : ,A1) 

52. The term data comes from the word........... 

      (a) Datum        (b) Dat          (c) Datu         (d) Datumus 

53. Each column in a table represents a ............... 
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     (a) Record         (b) Field         (c) File            (d) Database 

54. Spreadsheet is an example of which of the following databases? 

     (a) Flat File      (b) Network      (c) Relational     (d) Hierarchical 

55. Which of the following are called the common fields in a relational database?                                                     

     (a) Keys          (b) Files         (c) Records       (d) Table 

56. Which of the following variables holds a memory address? 

      (a) Static         (b) Pointers     (c) Register       (d) Auto 

57. A preprocessor directive starts with ........ 

(a) $                 (b) #                (c) <                (d) @ 

58. Which of the following statements forces the next iteration of the loop to 

      take place skipping any code following the statement in the body loop? 

     (a) Break         (b) Continue    (c) Switch        (d) For 

59. How many times will the following loop be executed? 

      for (i = 1 ; i < 30 ; i++) 

     (a) 1    .         (b) 29           (c) 30           (d) 31 

60. Which of the following is an entry-controlled loop? 

(a) For            (b) Do-while      (c) Switch         (d) If else 

61. The size of the array is always......... 

(a) Positive       (b) Negative      (c) Float          (d) Double 

62.  How many elements are stored in an array int nim [4] [2]? 

(a) 2                 (b) 4                (c) 6               : (d) 8 

63. Which of the following functions compares the two given strings? 

       (a) strcpy ()      (b) cpystr ()    (c) cmpstr ()     (d) strcmp () 

64. How many copy of the member variable is created if it is static memory? 

     (a) 2             (b) 1        V   (c) 3            (d) 4 

65. A class comprises ................... 

(a) data members         (b) member functions (c) both (a) and (b)               (d) none of these 

66. To change the background of a slide, choose 

 (a) File -> Page —> Background        (b) Format —> Slide —>Background 

   (c) File —> Slide —> Background     (d) Fonnat —> Page -> Background 

67. Which of the following keys is used to start a presentation? 

      ( a)F2            (b)F5           (c) F7           (d) F11 

 

68. Which view allows you to create and edit slides? 
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     (a) Handouts view                 (b) Outline view       (c) Notes view                       (d) Normal view 

69. Which key is used to print a document in StarOfficetm press? 

  (a) Alt + P         (b) Ctrl + P      (c) Shift + P     (d) Shift + Ctrl + P 

70. Which command is used to open Navigator? 

(a) File ~> Navigator    (b) Tools ~> Navigator   (c) Edit —> Navigator   

 (d) Insert-^Navigator 

71. In which format is the date format, entered in a cell in StarOfficeCalc? 

      (a) DD/MM/YY (b) MM/DD/YY (c) YY/DD/MM (d) YY/MM/DD 

72. Which reference operator is named as Intersection? 

 (a) :                (b) *               (c) &               (d) = 

73. Which of the following has shortcut icons for frequently done tasks –in spreadsheet? 

(a) Menu Bar          (b) Formula Bar (c) Function bar & Object bar     (d) Main tool bar 

74. Which command is used to generate a series of data on selected cells? 

       (a) Format        (b) Fill          (c) Insert         (d) Senes 

75. Which icon is used to insert object from other application into a worksheet? 

(a) Insert OLE Object            (b) Insert Floating Frame 

(c) Insert plug-in-                      (d) Insert Applet 

 

            

 

MARCH - 2010 

XII STANDARD-COMPUTER SCIENCE 

1.Choose the correct answer                                                                    

1. The function used to find the square root of a given number is 

   A) sqr()          B) sqrt()       C) sqt()         D) square root(). 

2. Each table column represents 

   (A) Record         (B) Field         (C) Data,         (D) Database. 

3. The hierarchical- database structures were primarily used for 

    (A) super computers               (B) mini computers     (C) mainframe computers         (D) micro computers. 

 4.  In Star Base, which of the filed types is not allowed ? 

     (A) Date       (B)Time         (C) Date/Time   (D) Project.  

5. The expansion of SQL is                      

(A) Spacial Query Language        (B) Special Queue Language 
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C) Structured Query Language   D) Structured Queue Language.    

6. Which one.of the following is object oriented programming language? 

     (A) C             (B) C++         (C) Pascal        (D) Visual Basic. 

7.  A kind of self sufficient 'subprogram' with a specific functional area is called as 

     (A) Object        (B) Class         (C)Program       (D) C++   . 

8. Whicn is not a C++ Keyword ? 

(A) auto           (B) goto          (C) constant      (D) const. 

9.  Which marks the end of a string literal ? 

(A) ' o'           (B) 7 o'          (C) W           (D) 7 n' 

10 Which is the-conditional operator? 

 A) ?            B) ?:          C) :?           D) ; 

11. The members of a class are accessed using the operator 

      (A).             (B) ::            (C) :             (d) ; 

12. Which of the following is not true ? 

(A) Member functions can be of static type.  

(B) The return type of a member function cannot be of object data type 

 C) A non-member function cannot access the private data of a class 

 D) Several different-classes can use the same function name. 

13. Data adstraction is (achieved through 

   (a) encapsulation  (B) polymorphism (C) inheritance    D) data hiding. 

14. In C++, class variables are known as                               

     (A) class       (B) functions     C) members      D) objects. 

15. Which operator cannot be overloaded? 

(A)+           (By++         (C)>           (D):: 

16. Which of the following is not a word processor? 

       (A) Lotus Amipro (b) Word Pro    (C) MS Word     (D) Lotus 123. 

17. To move to the end of the document, press 

       (A) Home        (B) End         (C) Ctri + Home   (D) Ctrl + End. 

18. Which key combination is used to centre a paragraph? 

(A) Ctrl + C        (B) Ctrl + R       (C) Ctrl + E       (D) Ctrl + J. 

19  Each time the Increase indent button is clicked, the paragraph is indented 

to ......:.......from left margin. 

(A) 1 inch         (B)yinch        (C)  inch        (D) 2 men. 

20.'Which key may be pressed to select the spelling command ? 
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        (A)F5                            (B)F7         (C) Ctrl + F5                 (D) Ctrl + F7. 

21. Which bar is, used io display the current cell and its contents? 

(A) Function                      (B) Object (C) Formula                      (D) Scroll. 

22.  Default data format is 

(A) dd /mm /yy                     (B) mm /dd /yy (C) yy /mm /dd             .       (D) dd /yy /mm. 

23. FitI command is available under which menu ?  

(A) File           (B) Format       (C) Edit             (D)    Help. 

24.  Which are predefined formula that are avilabie in StarOfficeCalc ? 

(A) Functions     (B) Wizards     , (C) Cell address  (D) Formats. 

25. Which icon is used to insert objects from other application into a worksheet? 

(A) Insert Formula                  (B) Insert Floating Frame 

(C) insert Applet                     (D) Insert OLE Object. 

26. A filter is afso a type of 

      (A) tabfe       (B) form          (C) report         (D) query. 

27. Which is a printed information that is assembled by gathering data based  on user supplied criteria ? 

 (A) Table          (B) Form         (C) Report       (D) Query. 

28. To insert a calc cell range into a text document choose 

       (A) Edit ~> paste         (B) Edit -> copy        (C) Edit - paste special          (D) Edit —> copy special. 

29.  Which is used to assemble information from data ? 

(A) DBMS        (B) Datum       (C) Information    (d) Sorting. 

30. Which key uniquely indentifies a record in a table ? 

A) Primary       (B) Secondary    (C) Tertiary        (D) Record pointer. 

31.  An array in C++ is 

 (A) user defined data type          (B) built - in - data type 

 c) derived data type                   d) default data type. 

32.  The array subscript always commences from 

  (A)1    (B)-1          (C)0            (D) 100. 

33. Strings are otherwise called as 

      (A) characters     (B) names        (C) literals        (D) constants. 

34. Which binds the data and its associated functions together? 

      (A) Object    (B) Class        (C) Program      (D) Method. 

 

35. Which members can be accessed from outside the class also ? 

(A) Private                         (B) Protected (C) Public                         (D) Static. 
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36. To create a new presentation using a template, press 

(A) Alt + Shift + N                   B) Shift + Ctrl + N C) Shift + N                           C) Alt + F + N . 

37. To start a slide presentation, press 

    (A)F1       (B)F2           C) F11           D) F5. 

38. To change the slide background, choose 

 (A) File -> page —> Background     (B) Format -> Page -> Background 

 (D) Edit -> Page ~> Background      D) View - Page -Background 

39. In StarOffice Impress, to open the style list the key to be pressed is 

       (A)F1         (B)F2           (C)F11           (D)F5. 

40. To print in StarOffice, the key combination to be pressed is 

     (A) Alt + P          (B) Alt + F + P    (C) Ctrl + P        (D) Ctrl + F + P. 

41. Operator functions must be 

(A) member function                (B) friend function   (C) either (A) or (B)  .              (D) function. 

42. intregral promotions are purely 

(A) compiler oriented             (B) computer oriented       

C) data oriented                        D) program oriented. 

43. Which function initializes the class object? 

(A) Constructor'                     (B) Destructor (C) Main ( )                              (D) User defined 

44. Which constructor is executed when an object is passed by reference to constructor?                  ,    . 

A) Default        B) Copy        C) Parameterized   D) Non-parameterized 

45. Which variables are automatically initialized to zero when they are declared? 

       (A) Auto and Static        (B) Static and Extern        C) Static and Register            D) Register and Extern. 

46. Extraction or get from operator is 

(A)>           (B»         (C)<           (D)« 

47. Which of the following is the invalid variable declaration ? 

(A) int a. b ; (B) int a; int b;  (C) int a;  floatb;   D) int a ; b ; 

48. Which creates object files from source code ? 

(A) Computer     (B) C++         C) Compiler     (D) Program. 

49. What is the error thrown by the compiler for the following snippet ? 

if (a > b); cunt Greater else cout  "Lesser"          

       A) Misplaced if       B) Misplaced else       C) Misplaced if... else             D) Misplaced else ... if 

50. Which key combination is pressed to move backward through cells ? 

       A) Tab+F5      B) Shift+F6    C) Shift + Tab   D) Esc. 
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51. If Table-> Table properties command is used, which one of the following dialog box is opened ? 

(A) Table properties       B) Format Table  C) Table Format           D) Cell properties. 

52. If the length of the document is more than the width, the .orientation is      called 

      (A)portrait       (B) default        (C) landscape    (D) both (A) and (C) 

53. The default margins for top, bottom and left, right margins are 

     (A) 1.25" 1"     (B)1", 1.25"    (01" ,1"       (D)1.25" , 1.25" 

54. The intersection of rows^nd columns creates 

     (A) table           (B) cells          (C) address       (D) formula. 

55. Which is an application that allows you to send and receive messages over cell phones? 

       (A) SMS         (B) MRflS        (C) SSM    (D) MSS. 

56. The most common version of e-ieaming packages is 

      (A) CBT / WBT   (B) CBE / WBE (D) CB / WB 

57. GIF is limited to how many bit palettes? 

      (A) 4              (B) 18            (C) 8   (d) 16 

58. AIFF format was developed by 

     (A) Microsoft     (B) AT & T       (C) Apple     (d) Infosys. 

59. Shockwave formal is used to store multimedia components created using 

     (A) Microsoft      (B) Apple         (C) Paint         (D) Flash. 

60. Which statement accomplishes jump from the current loop? 

     (A) Break       (B) Continue      (C) Exit           (D) Quit. 

61. Which induces/the reusability of the code? 

     (A) Objects        (B) Classes      (C) Functions     (D) Variables.  

62. Which functions execute faster but require more memory space? 

      (A) Inline         (B) Strcpy        (C) Strien         (D) Strcmp. 

63. Which option is invalid when related to functions of C++? 

     (A) Actual parameter can be passed in the form of a constant to be formal  parameter of value type                    

(B) The actual parameter can be passed only as variable to the formal parameter    of reference type 

     (C) The default value in the formal parameter is given in the form of variable initialization 

       (D) The default value for an argument can be given in between the argumentlist.                                          

64. What is the scope of the variable a in the following snippet? 

if.(x<y) 

    {                                       

      int a ;                                

     a ++, 
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      (A) locaf (B) function (C) fille (D) class. 

65. Which enables online educational programs leading to diarees and cenffi 

       (A) e - banking                     (B) e – shopping        (C) e - learning                     (D) Tele-medicine. 

66. The expansion of BPO is 

(A) Business Pupil Outsourcing        (B) Business People Outsourcing 

(C) Business Project Outsourcing     (D) Business Process Outsourcirtg   

67. Which refers to the conversion of non-digital material to digital form? 

       (A) Data security  (B) pigitization   (C) ITES  (D) Medical Transcription 

68. Which laws preventcomputer crimes in^ndia? 

        (A) Cyber                        (B) IT         (C) Common                     (D) Cracking. 

69. Computer ethics its roofs in the work of                      

         (A) Charles Babbage    (B) Bla'ise Pascal   (C) Norbert Wiener  (D) BJarne Stroutstrup. 

Note ; Read the following C++ snippet carefully and answer Question Nos. 70 and 71 : 

class simple 

{                           

private;            

 

int;     

public ; 

simple (int y)                   

{       

X y;. 

} 

 simple() 

{ 

} 

 

70. What is the name of the constructor? 

(A) simple                          (B) –simple  (C) private                          (D) public. 

71. What type of constructor is used in this snippet? 

      (A) Non-parameterized              (B) Copy     (C) Parameterized         (D) Default. 

72. Whech is the most powerful feature of an object oriented programming language? 

      (A) Encapsulation (B) Polymorphism (C) Inheritance      (D) Data hiding. 
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73. How the derived class should be indicated? 

      (A) Class der_name : visibility mode base class _id 

      (B) Class der_name:; visibility moide base classJd 

      (C) Class der_name; visibility mode base classed 

      (D) Class der_name, visibility mode, base class _id. 

74. The default visibility mode is 

(A) private        (B) protected      (C) Public         (D) class. 

75. Which unit enables data storage and management? 

(A) Archive                             (B) Memoframe (C) projection TV                     (D) Robot. 

 

JUNE - 2010 

1.  Choose the correct answer                                        

1.  It is interesting to observe that 85% of the computer usage is .............. 

A) word processing              B) database C) spreadsheet                       D) AH of these 

2. We can purchase any product, any brand, any quantity from any where      through  

     (A) e-market      (B) m- shopping (C) e-commerce    (D) e.shopping 

3. Which refers of the conversion of non- digital material to digital form ? 

     (A) Telemedicine                        (B) Digitization      (C) Data management               (D) Teleshopping 

4. The two important aspects that must be ensured by the ITES provider are 

       (A) data security and customer privacy (B) customer satisfaction and needs 

(C) Persona! security and customer satisfaction (D) better look and feel.             

5. Which is the illegal access to the network or-computer system? 

       (A) Cracking                          (B) Virus         C) Piracy                                D) Stealing 

6.  Which is a self replicatkig program that can cause damage to data and file  stored on your computer ? 

(A) Piracy         (B) Cracking     (C) Virus         (D) Ethics 

7. The destructor has the same name as that of .the class, prefixed by which  character?            

(A) +            (B) ~          (C) *        (D) - 

      Note: Read the following C++ program and answer Question Nos 8 to 10: 

 

class A 

{      

int x, y; 

protected; 
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 int s,t: 

public.: 

int u, v ; 

8. The data members that inherit from Class A to Class 8 are ............... 

(A) x, y          (B) s, t          (C) u, v          (D) Both B and C  

9.  u, v data members contain which visibility mode in Class B ? 

(A) Private         (B) Protected .   (C) Public        (D) Either A or B 

10.  s, t data members contain which visibility mode in Class B ? 

A) Private         B) Protected    C) Public         D) ?tatic 

11. In overloaded function, which are not considered by the C++^compiler as  part of the parameter list ?     . 

(A) Dummy arguments             (B) Actual parameters- (C) Formal parameters       (D) Default arguments 

12. Which operator cannot be overloaded ?                                         

       (a)::. size of?  (B) : size of +* C) +-*?:       D) + .? size of 

13. Which of the following cannot have the same name as the class name? 

(a) Constructor                (B) Destructor   (C) Overloaded constructors         D) Member functions 

14. Which constructor Is executed when an object is passed by reference to constructor ? 

(A) Copy constructor                    (B) Parameterized constructor 

C) Non-parameterized constructor   D) Default constructor. 

15. Which of the following is true? 

(A) Constructors can have arguments (B) A destructor can have arguments 

(C) A destructor has a return type (D) Constructor returns int type 

16. Which has scope or visibility within the class but its lifetime is the lifetime of the program ? 

(A) Data members                     (b) Member functions 

(C) Static data members             (d)Constructors 

17. Which of the following is true?                                 . 

(A) Member function can be defined outside the class also 

(B) Member function cannot be defined outside the class 

(C) Member function must all have same name 

(D) A class cannot have more than three member functjQns 

18. when objects are created,, no separate space-is allocated for ............. 

 (A) objects                  (B) member functions  (c)data member     (D) static members 

19. class example 

{ 

int x, 
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20. In polymorphism, tp ccmpler adopts which strategy to match to match 

function cal! statement ? 

(A) Best match                   (B) Worst match    (C) Good match           (D) Next match 

21. Write () is a member function of ........... 

(A) istream.h   B) ostream.h    (C) string.h   (D) All of these   

22. Memory allotted for int num [2] 

(A) 10 bytes (B)0 bytes  (C) 16 bytes  (D) 120 bytes 

23. Array parameters by default behave like which parameter? 

   (A) Reference    (B) Variabie     (C) Constant         (D)   Value 

24. The binding of data and functions together into a single entity is referred to as  

       A) Data Abstraction   (B) member functions     (C) Data hiding   (D) class 

25. Data members are also called as 

      (A) attributes      (B) Encapsulation         (C) methods     (D) Inheritance 

26. A C++ program has primarily how many sections ? 

       (A)4         (B)2          (C)1           (D)3 

27. Which is used to help the compiler to check the data requirements of the function ? 

      (A) Header files  (B) Function prototype (C) Function Definition (D) Function calling 

 28. In which method, the called function creates new variables to store the value  of the arguments 

passed to it ?             

       (A) Call by value                   (B) Call by reference 

      (C) Actual parameter               (D) Formal parameter 

29. In C++, what can be assigned to the formal parameters of a function  orototype ? 

      A) Default values  (B) Default arguments ., C) Values  (D) Program 

30.  Find the output  

Include < iostream.h> 

Include < conio.h>  

Void main () 

{ 

Int ni -= 10, n2 = & n1 

N2 ++: 

Cout < < n1: 

 (A) 10                (B) 11         (C) 12            (D) 13 

31.  What is the value assigned to x ?  

floatx; 
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int a = 7, b = 3; 

x=a  (float) b;         

(A) Error                          (B) 2:33      C) 2.0                                  C) 3.0 , 

32. Which is the insertion or put to operator? 

      (A)»             (B)«            (C)>=            (D)<=. 

33. Which statement is used to skip a part of loop and start the next cycle of loop ? 

       (A) Break         (B) Stop         (C) Continue     (D) Skip. 

34. for(i=0;<10; i++)- how many times is this loop executed ? 

  (A) Only one     (B) Nine times   (C) Ten times    (D) Not executed 

35.  Which is linked with libraries to create an executable file ? 

        (A) Source code                  (B) Object code         (C) Programs                        (D) Compiler 

36. Which application allows you to send and receive messages over celt phones ? 

       (A) Virtual reality                 B) Simulator         C) MMS          D) SMS    

37. GIF stands for ............... 

       (A) Graphic Interface File           (B) Graphic Interchange Format 

       C) Graphic Interchange File        D) Graphic Interface Format 

38. AH digital cameras have the option to save images in ................ 

     (A) Bitmap format           (B) WMF format       (D) GIF format    D) JPEG format 

39. We can add special effects to a sound using the sound editing program 

       (A) Forge sound  (B) Sound forge (C) Sound merge (D) Sound edit 

40. The technique, used to distorting a single image to represent something  else is .................. 

      (A) Animating     (B) Sampling     (C) Morphing     (D) Warping 

41. How many different field types are used in StarOfficeBase ? 

      (A) 19            (B)22           (C)20            (D)13 

42. To sort the records in the ascending order, select the filed and click on 

      (A) Sort Ascending icon          (B) Ascending icon    (C) Sort icon       (D) Sort/Filter icon 

43. Filter used with a condition is called ................. 

(A) Auto Fitter                      (B) Default Filter (C) Query                             (D) Sorting 

44. To remove the fitter, click on which icon ? 

        A) Delete                        B) Remove        C) Delete Filter/Sort        D) Remove Filter/Sort 

45. To copy the selected celt range in text document select which option in the  paste special dialog box ? 

       (A) Paste         (B) DDE link     C) OLE link     D) Link 

46. The command that is used to create a new Impress presentation from within 

       any StarOffice application is ...............           
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       (A) File —> New -> Presentation          (B) File -> New —> Star-Office Impress 

(C) File -> Presentation                   (D) File —> New —> StarOffice Presentation 

47. The shortcut used to create a new presentation using a template is ......... 

(A) Ctrl + N          (B) Alt + Ctri + N  (C) Shift + Ctrl + N               (D) Shift + Alt + N 

48. Which view allows you to view miniature images of all the slides in  presentaion ? 

      (A) Normal        (B) Outline       C) Notes         (D) Slide Sorter 

49. To insert a slide, choose ..................... 

A) Slide -Insert           B) Insert -> Slide  C) Format —> Slide Insert   D) Presentation Slides 

50. To move from siide to slide quickly choose ................ . 

A) File ~> Navigator     B) Format –Navigator  C) Edit —> Navigator   D) View —> Navigator 

51. Which function key is pressed to edit the contents of a cell ? 

       (A) F3            B) F2           C) F7            D) F5 

52. Which of the following comparative operators is meant for'inequality? 

      ( A)<=           (B)>=          (C)<>          (D)= 

53. The cell B4 becomes absolute when you enter .................. 

 (A)$B$4         (B)B$4$        (C)$B4$        (D) B $ $ 4 

54. In StarCalc, to change the column width in a worksheet select ? 

      (A) Format-> Column -> Width        (B) Table--^Column-> Widh 

      (C) Format -> Width --> Column        (D) Tools -> Column -> Width 

55.  A continuous group of ceils in a worksheet is called as ................ 

(A) column        (B) row          (C) range      (D) address 

56. Which is a template for entities that has common behaviour ? 

     (A) Class          (B) Object        (D) Instance       (D) Inheritance 

57. A group of data and operations together are named as ............... 

     (A) object         (B) variable       (C) function        (D) data 

58. Which constant contains a single character enclosed within single quotes? 

      (A) Integer        (B) Character    (C) Float         (D) Double 

59. Ternary operators require how many operands? 

      (A) One          (B)Two          (C) Three        (D) Four. 

60. Relational operators have tower precedence than ............... 

(A) Arithmetic operators           (B) Relational operators 

(C) Logical operators                 (D) Boolean operators 

61. Which icon generates a scrolling screen within a worksheet? 

      (A) Insert Formula                        (B) Insert Floating Frame 
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      (C) Insert Movie and Sound         (D) Insert OLE Object 

62. The term data comes from the word ..................... 

 (A) File        (B) Record      (C) Datum        (D) Fields. 

63. Each row in a table represents a ........................ 

(A) File                              (B) Table   (C) Data                            (D) Record 

64. The common field of fields is / are called ....................... 

(A) Primary key                   (B) Secondary key  (C) Index key                       (D) Keys 

65. To create a new table in StarOfficeBase, the command used is 

       (A) Table -> Insert                         (B) Insert -> Table Design 

       (C) Format —> Table Design         (D) Table -> Table Design 

66. In spell check dialog box, the button to be clicked to add a new word to  the dictionary is ... 

      (A) OK            (B) Add          (C) Insert         (D) Add Dictionary 

67. The simplest way to add a row in the last row of table, press................. 

(A) Alt             (B) Ctrl           (C) Tab           (D) Shift 

68. If the width of the documents is more than the length, then it is called 

      (A) page orientation             (B) portrait       (C) landscape                     (D) paper format 

69. Which Command is used to insert page numbers on every page ? 

     (A) Insert -Filed --Numbers         (B) Insert --Number -.Field 

     (C) Insert —> Filed -Numbers   (D) Insert —>Page Numbers —> Filed 

70. How many columns are there in VisiCalc ? 

(A) 254           (B) 63           (C) 32000        (D) 256 

71. The flashing vertical bar in StarOffice Writer is called .........\...... 

(A) Insertion point   (B) End of document marker   (C) Cursor   (D) Insertion bar 

72. To select the Entire document press ......................... 

      (A) Shift + A      (B) Alt + A       (C) Ctrl + A      (D) Ctrl + Alt + A. 

73. Which type. of font is suited for decoration ? 

(A) Anal                          (B) Times New Roman          (C) Fajita                        (D) Business 

74. The size of the font is measured in ........................ 

       (A) Points         (B) Circles       (C) Rectangles    (D) Numbers 

75. If the value of first tine spin box in the parahraph dialog box is negative, it 

will create ................. 

(A) Indent         (B) Hanging Indent   (C) First line Indent     (D) Left Indent 
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Time : 3 tirs.                                      PART - I(Answer all questions) 

 

I.  Choose the correct answer :. 

1. CBT stands for 

      A) Computer Based Tuition       (C) Computer Based Transaction 

      (B) Computer Based Tutorials       (D) Computer Based Technology. 

2. BPO stands for 

     (A) Business Program Outsourcing      (B) Business Procedure Outsourcing 

     (D) Business Process Outsourcing.      (C) Business Practice Outsourcing 

3.  Which is the key for effective and profitable use of IT in organizations ? 

     (A) Data Digitization                (B)Data Management 

     (C) Data Archiving                   (D) Data Transcription. 

4.  Making and using duplicate hardware and software is called 

     (A) Cracking                     (B) Freeware      (C) Piracy                         (D) Stealing. 

5. Software setups that permit only authorized access to the system is   referred as 

(A) Physical security                (B) Personal security  

C) Personnel security               D) Private security. 

6. How many destructors a class., can have? 

(A)1         (B)2          (C)3           (D)4 

7. The destructor has the same. name as that of, the class prefixed, by the  character                                  

(A);            (B)-        (C)#           (D):: 

8. The most powerful feature of an object oriented! programming language is 

     (A) Encapsulation                   ( B) Polymorphism 

     (C) Data abstraction                (D) Inheritance.            

9.  The class from which other classes are derived is called 

(A) Base class    (B) Main class   (C) First class    (D) Major class. 

10 Classes used only for deriving other classes are called 

A) concrete classes                B) abstract classes C) private classes                   D) Public classes 

11. Which of the following permits banking from the comfort of the home by using internet facilities ?           

(A) e'Banking    (B) e-Shopping (C)e-Commerce  (D) e-Business 
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12. The function operator () is declared in which part of the class? 

(A) public          (B) private         C) protected      D) static- 

13. Which of the following statements is false in case of operator overloading? 

      (a) Only existing operators can be overloaded (B) The basic definition of an operator can be replaced 

      (C) The overloaded operator must have at least one operand of user defined type                                    . 

  D) Binary operators overloaded through member .function take one explicit argument.                  -. 

14. Which of the following functions .gets executed, when an instance of a class comes into scope ? 

     (A) main () function (B)-Constructor C) friend function D) Destructor. 

15. Which of the following constructors is executed when a member function  returns an object?           

      (A) Copy constructor                         (B) Default constructor  

     (C) Compiler generated constructor  (D) Non-parameterized .constructor. 

16. Which members of a class can be, accessed by the members of inherited  class ? 

(A) public        (b) protected     (C) private        (D) static. 

Read the following C++ program carefully and answer the questions from 17to19 

# include<iostream.h 

# include<conio.h 

class item 

{ 

int code, quantity;                    

float price;                                                

void getdata () 

{                                                      

cout"\nEnter code, quantity and price:"; 

cin code quantity price; 

} 

protected: 

void compute ()                          

{  

if (quantity 100) 

tax=2500;          

else                                         . 

tax =1000; 

} 
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public: 

float tax; 

void putdata ( 

cout"\nCode:"code; 

cout"\nQuantity " quantity ; 

cout"\nPrice :"price; 

cout"\nTax :"tax, 

void main ( 

item 

} 

17.Memory allocation for instance is     

     (A) 12 bytes      (B) 10 bytes     (C) 8 bytes       (D) 16 bytes. 

18. public data member in the above class definition is  

      (A) code         (B) quantity      (C) price          (D) tax. 

19. Method that can be accessed by object "i" is . 

       (A) getdata ()     (B) compute () .(C) putdata ()    (D) quantity (); 

20. Which of the following, C++ operators can be overloaded ? 

      (A);   (B)        (C)?:                            (D)+               

21.Determine the number of elements in the following declaration: int a [10] [12]; 

     (A) 22                           (B) 10     {C} 120                         (D)240 

22.To treat spaces as part of string literal, one has to use 

     (A)scanf()              .         (B)cout()      (C)cin ()                          (D)gets () 

23.A character array should be terminated with a 

     (A),\n         (B)/0          (C)\n-            (D)/n 

 

 

24. The private members of a class can be accessed by epecial functions called 

    (A) static functions               (B) private functions     (C) friend functions                  (D) public functions 

25.Member functions of a class are called 

        (A) Procedures                     (B) Methods (C) Attributes                         (D) Sub-programs 

26. The machine readable form of a program is called 
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       (A) source file     (B) object file     (C) executable file (D) assembly file 

27.  Parameters that are associated with function call statement are 

     (A) formal parameters          (B) actual parameters    (C) local parameters                (D) global parameters. 

28. The default returning type of a function in C++ is 

        (A) char        (B) float         (C) int           (D) void 

29. Which of the following is calfed scope resolution operator? 

(A). operator      (B):: operator    (C) : operator     (D), operator 

30. Which of the following is a valid function prototype? 

(A) float average (a,b);             (B) float product(inta, b ); 

(C) int fun (int a, int b, double pi = 3. 14 );            (D) int display (inf a = 2, int b); 

31. The range of 'int'data type in C++ is                           

(A) - 32768 to + 32768             (B) - 32767 to + 32767 

(C) - 32767 to + 32768             (D) - 32768 to +32767 

32. The declarations for the object cin are available in a header file called 

      (A) stdio. h        (B) cbnio.h        (C) istream.h      (D) string.h 

33. Which of the following is called the extraction operator ? 

       (A)<             (B)«           (C)>             i(D)» 

34. Which statement forces the next iteration of the loop-to take place, skipping any cod in the current 

iteration ? 

(A) Brea!^         (B) Continue      (C) Default        (D) Exit. 

35. The apporpriate declaration statement to initialize trie variable 'name' with  the value 'Abdul- Kalam' is 

    (A) char name = "Abdu! Kaiam";      (B) -char [ ] name = "Abdul Kalam"; 

    C) char name []== Abdul Kalam;     (D)   char name {]== "Abdul Kalam". 

36. GIF stands for 

(A) Graphic International Format   B) Graphic Interchange Format 

(C) Graphic Information Format    (D) Graphic Institution Format 

37. Conversion of-analog sound waves into digital format is called 

     (A) Warping       (B) Sampling     C) Morphing      D). Streaming. 

38. The AVi torn'at was developed by 

     (A) Apple         (B) IBM       (D) Macromedia   D) Microsoft. 

39. Which of the .following tags is not used to launch helper applications ? 

      (A) <embed>      (B) <appiet>      (C) <form>        (D) <object> 

40. Fifes in. the Quick Time format have the extension as 
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(A) mov         (B) .wmv        (Q -wav         (D) .swf 

41. A screen that displays data for a single record is called a 

(A) Tabte          (B) Form         (C) Query         (D) Report. 

42. The process of selecting- a desired specific data from a database is called 

      (A) Searching                       (B) Sorting        C) Filtering                           D) Editing. 

43. In StarOffice Base, which of the following icons is used to display the     records in the original order? 

      (A) Standard Filter icon        (B) Remove Filter/Sort icon. 

        (C) Auto Filter icon      (D) Default Filter icon 

44. SQL is expanded as 

     A) Structured Quick Launch        (B) Sorted Query Language 

     (C) Structured Quick Language    (D) Structured Query Language. 

45. To insert Calc cell range into a text document, use the command 

(A) Edit -> Paste Special          (B)   Edit-> Copy Special 

(Q Edit -> Paste                         (D) Edit -> Paste Cell. 

46. How many options are displayed in the first page of the Presentation Wizard in StarOffice Impress? 

         (A) 4             (B)3          C)2            (D)5. 

47. Which view allows you to reorder slides, edit slide titles and headings ? 

      (A) Normal view   (B) Handout view    (C), Notes view    D) Outline view. 

48. To insert a picture in a slide, choose 

(A) Insert ~> Picture ~> From fife   (B). Insert -> Picture 

(C) Insert -~> Picture file-                (D) Insert -> From file -> Picture 

49. In StarOffice Impress, the menu used to open Media player  window is 

      A) Tools                         B) Insert .       c) vfew                           D) Format. 

50. Which window allows us to quickly jump from one slide to other slide or  move between open files? 

A) Styles and Formatting window   B) Custom Slide show window 

C) Navigator window                       D) Slide design window. 

51. Which of the following is an exponentiation operator in StarOffice Calc? 

       (A) %                             B) A         C) »         .                     D) / 

52. A continuous group of cells in a worksheet is called a 

(A) Tabte         (B) Column      (C) Range        (D) Row. 

53. A cell address can be made absolute by using the sign 

      (A) #             (B) $            (C) @            (D) %. 

54. in StarOffice Calc, the command used to change the column width of the selected columns is                                

       (A) Format -> Column Width         (B) Edit ~> Column Width 
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       C) Format -> Column ~> Width    (D) Edit -> Column -> Width. 

55. Which of the following refers to the files that you create with spreadsheet  software ?                     

     (A) Text document (B) Database     (C) Data sheet   (D) Worksheet 

56. A kind of self sufficient subprogram with a specific functional area is called 

       (A) Class         (B) Object        (C) Structure      (D) Array. 

57. Which of the following reduces software complexity in Object Oriented Programming? 

       ( A) Encapsulation (B) Polymorphism (C) Inheritance    (D) Abstraction. 

58. C++ was developed by 

 (A) Dennis Ritchie    (B) Norbert Weiener (C) Bjarne Stroustrup         (D) James Gosling. 

59. Which of the following in an invalid identifier ? 

(A) test       .   (B) sum 12      (C) new       (D) reg-no 

60. Which of the following modifiers increases the bytes for a particular data type ?     
 

       (A) Snort          (B) Long .      (C) Unsigned      (D) Signed. 

61. Which of the following icons is used to insert objects from other application into a worksheet ?                            

      (A) Insert Plug-In icon              (B) Insert OLE object icon 

      (C) Insert Applet icon            . (D) Insert Floating Frame/icon.  

62. A set of processed data is called 

      (A) Datum         (B) Information    (C) Database     (D) Procedure. 

63. A repository of collections of related data or facts is called a / an 

      (A) Datum         (B) Pile           (C) Database      (D) Information. 

64. Which database structure, is characterized by parent - child relationships 

      among record types? 

(A) Flat File database              (B) Relational database 

(C) Hierarchical database        (D) Network database. 

65. Which of the field properties is used to specify the maximum characters 

       that can be entered in the field in StarBase ? 

       (A) Length                         (B) Width        (C)Size         .                    (D) Limit. 

66. The command used to create a table in a, text document is 

(A) Table -> Insert -> Table       (B) Table -> InsertTable 

(C) Table > New -> Table          (D) Table-Create -> Table 

67. In StarOffice. Writer, the key combination used t© move backward through the cells of a table .is 

      (A)Alt + Tab      (B) Shift + Tab    (C) Tab           (D) Ctrl + Tab. 

68. The default value for left arid right margins of StarOffice writer document is 
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    (A) — inch                        (B) 1 inch    (C)1.25 inches               (D) 1.5.-Inches. 

69. In StarOffice Writer, the command to open the Page Style dialog box is 

      (A) File -> Page             (B) Edit -> Page      c) View -> Page            D) Format -> Page 

70. The spreadsheet package 'StarOffice Calc' was developed by 

       (A) Microsoft Corporation            (B) Borland International 

       (C) Lotus Corporation                  (D) Sun Microsystems. 

71. The thick horizontal line in the page area is called 

(A) End - of- paragraph marker      (B) End-of-page marker 

(C) End-of-document marker          (D) End-of-line marker 

72. In StarOffice Writer, the menu used to switch between multiple documents      is                               

        (A) File           (B) Edit        (C) View         (D) Window. 

73. The keyboard shortcut for the centre alignment of selected paragraph is 

       (A) Ctrl + L        (B) Ctrl + R'      (C) Ctrl + E       (D) Ctrl + J. 

74. In StarOffice Writer, the menu used to apply different styles for the bullets  and numbers is 

     (A) Edit          (B) View        (C) Insert       (D) Format. 

75. 'In StarOffice Writer, to create AutoCorrect entry, the command used is 

  (A) Edit -> Autocorrect             (B) Tools-> Autocorrect 

C) Format-> Autocorrect         D) .Insert -> Autocorrect 

 

 

JUNE-2011 

I.  Choose the correct answer :                                                                 

1. Which operator is used to refer range in StarOffice Calc? 

 A) :                           (P)!  (C)&                          (d)^ 

2.  Which is a type of query in StarOffice Base ?                       

     (A) Table                           (B) Forms       C) Filter                           (d) Report. 

3.  Each column is StarOffice Base table represents 

(A) File                             (B) Table         c) Field                           (D) Record. 

4. Which database is primarily used on Mainframe Computer? 

     (A) Flat File                         (B) Relational     (C) Hierarchical                    (D) Object oriented. 

5.  Which of the following is not a step in Data Processing ?     . 

     (A) Collection                       (B) Network      C) Verification                       D) Validation. 
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 6.  In C++ the ability of an object to respond differently to different messages  is called as 

(A) Inheritance                     (B) Polymorphism (C) Object           (D) Encapsulation. 

7. Which of the following is an object oriented programming ? 

(A) C++    .                      (B) C                    (C) BASIC                      (D) FORTRAN. 

8. Where was C++ developed ? 

(A) AT & T Bell Lab        (B) Microsoft  (C) Sun Micro System             (D) Apple. 

9. Value of 1 + Pow (3. 2) is        

 (A) 7                             (B)6   (C)10                            (D)13.  

10.  Which are also called variables ? 

A) String Literals                   B) Tokens C) Identifiers                         D) Keywords. 

11. Which of the following is a user defined data type? 

(A) Public         (B) Private        (C) Protected      (D) Class. 

12. The members defined within the class behave like which functions?. 

      (A) Static         (B) Friend        C) Inline         D) Derived. 

13. The static member variable is initialized to 

(a) 0           . (B)1            (C)2            D) 3 

14. The body of the class .is terminated by      

    (A)(comma)                            (B): (colon)     C) ; (Semi - colon)                 (D) () (parenthesis) 

15. Which of the following operators can be overloaded'?' 

      (A) Size of ()                      (B): : (C) ++                                (D) (.) membership operator: 

16. In StarOffice Writer the flashing vertical bar is called 

     (A) Pointer                             (b) Marker      (C) Insertion Point                  (D) Key. 

17. Which key is used to move the insertion point to the beginning of the document ? 

    (A) Home      (B) Page up     (C) Ctrl + Home     (D) Shift + Tab. 

18. An inch is equal to 

     (A) 75 points      (B) 74 points    (C) 80 points      (D) 72 points. 

19 Which is a decorative Font? 

(A) Times New Roman    B) Fajita   C) Wingdings   (D) Symbol. 

20. Which key is used to select the spelling check dialog box? 

      (A) F6                            (B) F7       (C) F5                            (D) F4. 

21. Default format for date in StarOffice Calc is 

(A) dd / mm / yy            (B) mm / dd / yy      (C)mm/yy/dd                    D)yy/mm/dd. 

22. In StarOffice Calc the formula starts with 

(A)$           (B)&          (C)=             (D)! 
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23. Which is the default type of cell address used, by StarOffice Calc ? 

     (A) Relative cell addressing          (B) Absolute ceil addressing 

     (C) Primary cell addressing          (D) Relational cell addressing. 

24. Which is the most commonly used function in StarOffice Calc? 

       (A) SQRT ()     (B) SUM ()     (C) AVERAGE ()   (D) POW ("). 

25. Which symbol is used to make a cell address absolute? 

        (A)'.                            (B)#        (C) $                            (D) &.  

26. How many types of databases does StarOffice Base have? 

       (A) 4            (13)2           (C)8           (D)5. 

27. Which command 1s used to open StarOffice Base ? 

(A) File -> New -> Database        (B) New - File -> Star Base 

(C) View -> Database                  (D) File - StarOffice Base. 

28. SQL means 

(A) System Query Language          (B) Structured Query Level 

(C) Structured Query Language      (D) Specific Query Language, 

29. Which of the following is not a valid field type in StarOffice Base ? 

      (A) Text (fix)       (B) Project       (C) Time         (D) Integer. 

30. The set of processed data is called 

(A) Data                     (B) Data Processing      (C) Dababase                      (D) Information. 

31. Which of the following is called as literals? 

(A) Strings        (B) float         (C) int            (D) char. 

32. The size-of array should always be 

[A) negative        (B) positive       (C) float           (D) double. 

33. The array subscripts always commence from 

(A) one            (B)two           (C) three          (D) zero. 

34. Data members are called as 

(A) attributes      (B) methods      (C) class         (D) object. 

35. In C++ the class variables are known as 

        (A) Members     b) Objects      (C) Methods    (D) Attributes. 

36. Which among the following is used to display various transition effects that   can be attached to a slide ? 

(A) Custom animation               (B) Slide transition  C) Animation effects  D) Slide sorter 

37. The keyboard shortcut to create a new presentation using template is 

       (A) Ctrl + N                  .      (B) Ctrl + F + N       C) Alt +N                            D) Shift + Ctrl + N. 
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38. Which view allows to create and edit slides ? 

      (A) Notes                          (B) Handouts           (c) Normal                          D) Slide sorter. 

39. Which is used for performing calculations in presentation ? 

     (A) Insert formula                   (B) Insert OLE object 

     (C) Insert Applet                    (D) Insert object. 

40. Which key is pressed to start a presentation ? 

     (A)F2                           (B)F5         (C)F7                          (D)F11. 

41. In how many ways is polymorphism achieved in C++?  

     (A) 2           (B)3           (C)1           (D)4. 

42. How many explicit argument(s) is/are taken by binary operators overloaded 

      through a member function ? 

      (A) one           (B) Two          C) Three         D) Six. 

43. Which of the following has no return type and cannot be overloaded ? 

      (A) Constructor    (B) Destructor    (C) Function      (D) Operator. 

44. The memory space is allocated to an object using 

     A) Constructor   (B) Destructor    (C) Overloading    (D) Function. 

45. The destructor is prefixed by which character? 

(A) #           (B) &           (C)%           (D)- 

46. How many types of storage specifiers are there in C++ ? 

      (A) 3             (B»2            (C)5            (D)4. 

47. Which of the following is called the insertion operator? 

      (A)«           (B) »          (C)>            D) <       

48. A preprocessor directive starts wit 

(A) <                             (B) #  (C)«                             (D) » 

49. Which of the following is called exit-check loop? 

     A) do..While                       B) for      C) while                             D) switch. 

50. Which statement would exit the current loop ?                       

      A) Break         B) Continue      C) Quit          D) Exit. 

51. Which command is used to add the erross and its correction in the Auto  correct list ?                                            

.     (A) Tools -> Auto Correct           B) Tools -> Auto Spell-Check 

     C) Format-> Spell Check            D) Tools -> Spell Correct. 

52. Which command is used to delete the selected table ? 

(A) Format -Delete -> Table       (B) Format -> Column -> Delete 

(C) Format -> Row -> Delete        (D) Table -> Delete ->Table  
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53. To move forward through -the cells press 

       (A) Tab            (B) Shift + Tab    (C) Ctrl + Tab     (D) Alt + Tab. 

54. The default left and right margins in StarWriter are 

      (A) 1 inch         (B) 2.25 inches  (C) 1.25 inches    (D) 3.25 inches. 

55. Dan BricHin and Bon Frankston invented                  

      (A) StarOffice Catc (B) LOTUS 1-2-3 (C) Quatro Pro    (D) Visi Cafe. 

56. Files in qu'cktime format have the extension 

(A) qtf            (B) .mov         (C) .qft           (D) .swf 

57. Snd format was- developed by  . 

(A) Apple        (B) IBM         (C) MPEG       (D) Microsoft. 

58.Which techmque is used to blend two or more images to form a new image? 

(A) Rendering     (B) Warping      (C) Morphing      (D) Animating. 

59. Frequency is a'so called as                   

(A) Pitch          (B) Crest         (C) Sampling      (D) Sound, 

60. GIF is limited to how many palettere ? 

      (A) 16 bit         (8)8 bit         (C) 32 bit        (D)64 bit 

61. The machine readable form of a program is cajled as 

      (A) source code   (B) object file    (C) compiler      (D) executable file. 

62. The function that returns no value is declared as 

(A)int            (B)char          (C) float          (D) void. 

63. Parameter associated with call statement is called 

(A) actual         (B) dummy       (C) function       (D)fomnal. 

64. The function name may include a set of parameters, enclosed in parenthesis separated by                            

       ( A);              (B),             (C):            (D):: 

65. How many types of scopes are  there in C ? 

(A) 3            (B)5           (C)4           (D)6. 

 

66. Computer Ethics - has its roots in the work of 

(A) Donn Parker       (B) Rick Mascitti  (C) BjameStroustrup               (D) Norbert Wiener 

67. Which enables data storage and management? 

       (A) Emotion containers            (B) Memo frame 

       (C) Data monitors                   (d) Archive unit. 

68. BPO means 

(A) Business Process Outsourcing   (B) Business Process Office 
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   (C) Business Process Output          (D) Business Program Output. 

69. Which amongst the following i6 computer crime ? 

(A) Telemedicine      (B) Call centre    (C) Cracking                           (D) e-Banking 

70. Ten commandments of Computer Ethics was written by 

(A) Computer Ethics Institute      (B) AT & T Bell Laboratory 

(c) Microsoft Corporation            (D) Sun Micro Systems. 

71. The constructor without parameter is called 

(A) Method constructor              (B) Operator constructor 

(C) Default constructor              (D) Function constructor 

72. Which is the process. of creating new class, from the existing or base 

class? 

(A) Inheritance    (B) Encapsulation (C) Polymorphism                   (D) Constructor. 

73. The objects are not declared for which class'? 

(A) Parent        (B) Bass        (C) Abstract      (D) Derived. 

74. Which of the following is executed in the reverse order of inheritance ? 

 (A) Constructor    (B) Destructor    (C) Function       (D) Operator 

75. The expanded form of CBT is y. 

A) Computer Based Tutorials        b) Computer Based Tutor 

     (C) Comupter Based Teaching      (D) Computer Based Teacher. 

 

 

 

 

 

 

 

OCTOBER -2011 

Choose the correct Answer:                                                                         

1.  Which creates object tiles from source code in C++? 

     A) Variable                    . B) Translator      C) Object                         D) Compiler. 

2.   Which of the following about functions is false? 

A) Functions provide date security           B) Functions reduce the size of the program 

C) Functions induce reusability of code.  D) Functions are executable segments in a program. 
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3.  A function can be called or invoked from another function by using its 

      A) address                      B) object        C) class                          D) name.          

4. Which executes faster but requires more memory space?  

     A) Functions                  B) Inline functions      C) Objects                      D) Classes. 

5.  In which method any change in formal parameter is not reflected back to the actual parameter? 

A) Call by reference              B) Function call  C) Call by value        D) Call statement 

6.  When the first object of its class is created, what value is initialised to static member variable?          
 

     A) 1                              B) 0      C) -1                             D) Null. 

7.   In C++, objects of a class are also called as 

A) constants                     B) instance  C) tag                               D) datatype. 

8.  Members of a class are accessed using which operator? 

     A) colon                                B) dot     C) scope resolution               D) semicolon. 

9.Which is the key feature of object oriented programmhg? 

     A) Encapsulation      B) Data hiding      C) Polymorphism       D) Inheritance. 

10.Polymorphism is achieved through 

     A) function overloading     b ) operator overloading      C) both (A) and (B)           D) encapsulation 

11.Which language is used to query the database? 

     A) C++                    B) SQL     C) HTML                  D) DBMS. 

12.Which key is used to uniquely identify a record in a database table? 

         A) Primary key          B) Standard filter         C) Tertiary key            D) Unconditional filter. 

13.  Filter used with a condition is calted 

        A) Auto filter        B) Conditional filter         C)Secondary key         D) User key. 

14.  Which amongst the following consists of usable sets of data? 

      A) Form                            B) Field      C) Information                   D) Record. 

15.Example for flat-file database is 

     A) word processor                B) presentation      C) animation                         D) spreadsheet. 

16.Which is very useful for correcting the spelling of the commonly misspelled  words? 

     A) Auto spell check icon          B) Replace all 

     C) Change all                          D) Autocorrect option. 

17.Table — Table properties command displays which dialog box? 

     A) Table                              B) Table properties     C) Table format                  D) Table insert. 

18.Which key is pressed to move forward through the cells? 

      A) Tab                          B) Shift + Tab       C) End                          D) Home. 

19.The default left and right margins in StarOffice Writer is 
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      A) 1 inch                           B) 1.25 inches      C) 2.25 inches                   D) 1.5 inches. 

20.The conversion of analog sound waves to a digital format is  

     A) Sampling      B) Multimedia      C) Animation      D) Compression. 

21.AVI format was developed by 

     A) IBM                                B) Apple      C) Macromedia                  D) Microsoft- 

22.Helper application is also called as 

     A) Plug-in                       B)     C) video                        D) 

23.Text document can be created using 

      A) StarOffice Calc               B)        C) StarOffice Base               D) 

24.To move the insertion point to the beginning of the line press 

     A) End key                      B) Home key     C) Up Arrow key              D) Down arrow key. 

25.Which of the following is true, to change the fonts in StarOffice Wh'ter? 

     A) Format —  Character          B) Insert — Font      C) View—Font                         D) Format—Font. 

26.One wayTo set off a list of points or topic in a document is 

     A) Line Space                   B) Paragraph Alignment      C) Bulleted List                 d) Q Styles.            

27.To skip all occurrences of the misspelt word in spell check which button is   clicked? 

    A ) Change all                        B) Ignore all      C ) Not in dictionary               D) Skip all. 

28.Which command is used to generate a series? 

    A) File -> Fill ~-> Series            B) Edit -> Fill -> Series 

    C) Tools -> Fill -> Series          D)..View ~> Fill -> Series. 

29.Facility by which users can define their own sophisticated data type is 

     A) Primitive data type           B) Built-indata type  C) User defined data type         D) Derived data type. 

30.Each row and column in a table represent 

     A) Record, Field                 B) Data, Field   C) File, Field                       D) Data, Record. 

 

31.Which is the process of arranging the data in a table in some specific order?                                                            

.    A) Merging                      B) Filtering    C) Searching                    D) Sorting. 

55. Which is a printed information that is assembled by gathering data based on user  supplied criteria? 

  A) Form                      B) Report   C) Chart                      D) Formula. 

56. How many storage specifiers are there in C++ ? 

      A) 2                            B) 4       C) 3                            D) 5.                

57. Which is a predefined object that corresponds to standard input stream? 

       A) istream                    B) cout       C) cin                         D) header. 

58. In C++, which should be declared or defined before they are used in a program? 
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A) Datatype                    B) Variable C) Objects                       D) Class. 

59. In C++, which is a multiple branching statement? 

      A) for                                 B) if       C) switch                         D) while. 

60. The variable used in for loop is called                 

      A) static variable                  B) counting variable     C) control variable                D) for variable, 

61. In C++, array is of which data type? 

A) Built-in                           B) User defined   C) Predefined                    D) Derived. 

62. cin»num[3]; reads which element? 

A) Fourth                       B) Third    C) Second                       D) First 

63. Which function returns the number of characters stored in an array? 

A) striet()                         B) strcpyQ    C) strlen( )                       D) stremp(). 

64. The members that are declared as, what can be accessed only from within the class are 

A) public                           B) private C) protected                      D) public, private. 

65. Which operator is used to define function outside a class? 

       A) ;                              B) : C) ::                             D) ?: 

63.The keys used to create a new presentation using template 

      A) Cfrl+N                      B) Shift+CM+N       C) Shift+N                    D) AH + Ctrl + N. 

67. Which view in StarOffice impress that allows you to view miniature images  of all the slides?             .                          

.A) Normal          .         B) Outline C) Notes                       d) Slide Sorter. 

68. Which can be used to specify basic background information to be included      in all the slides?                              

A) Layouts                    B) Master page  C) Custom animation             D) Slide transition. 

69. Which key is used to assign presentation stvles? 

      A)' F5                           B)F7       C) F11                          D) F9. 

70. Which amongst the following helps the user to move from slide to slide  quickly? 

A) Home +Arrow keys  B) Automatic         C) Navigator         D) Slide sorter. 

71. Which is a Spreadsheet program? 

     A) StarOffice Impress         B) Improve      C) Lotus Amipro                 D) Flash. 

72.  The date format in Spreadsheet is 

       A) DD/MM/YY      B) YY/MM/DD       C) MM/DD/YY       D) DD/MM. 

73. The Syntax of formula in the formula bar begins with 

      A) =                           B) .       C) .                            D) / 

74. The reference operator in StarOffice Caic is 

      A) -                           B) ,       C) •                          D) % 
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75. A continuous group of cells in a worksheet is called 

      A) formula                     B) range       C) rows                         D) columns. 

 

 

 

 

 

 

 

Choose the correct Answer: 

1. Which menu is used to switch between documents in StarWriter? 

     A) File       B) Edit         C) Window     D) Insert 

2. What is theshortcut key to cut text in StarWriter? 

A) Ctri+C      B) Ctri+V      C)Ctri+M      D) Ctrl + X 

3.   How many points to an inch for font size in StarWriter? 

A) 72          B) 64        C) 73          D) 48 

4.  The named set of defaults for formatting text in StarWriter is 

       A) Indenting                       B) Style        C) Highlighting                   D) Hanging indent 

5. Which key is pressed to select the spelling command in StarWriter? 

     A) F7          B) F1          C) F2          0) F6 

6.  Which displays any alternate spelling in the spell check dialog box in StarWriter? 

A) Choices                         B) Not in dictionary C) Dictionary            .   D) Suggestions 

7.  Which key 1.3 used to move backward through cells in a table in StarWriter? 

     A) Tab          B) Shift + Tab   C) Enter        D) Ctrl + Tab 

8.  In StarWriter. the simplest way to add a row in the last row of the table in the    document is 

     A) Ctrl          B) Tab         C) Shift + Tab   0) Alt. 

9.  In StarOfficeWriter, the command to insert page numbers in the footer area  of the document is                         

       A) Insert -> Page number        B) Format -> Page Number 

       C) Insert-> Fields Number     D) Insert- Fields -> Page Number 

10. The number of rows in Visicalc is    

A) 64          B) 256        C) 254         D) 255 

11. Which amongst the following' is used to display the current cell and its  content in StarCalc? 

      A) Formula bar B) Function bar C) Status bar   D) Object bar 
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12. Which is the reference operator in StarOffice Calc? 

A) %           B) &           C) 
A
          D) ! 

13. The predefined formulae available in StarOffice Calc is called 

      A) function      B) autoformat   C) address      D) autofill 

14. In StarCalc. which menu contains Auto Format? 

A) File          B) Edit         C) Format       D) Style 

15. In StarCalc, to begin with in a worksheet, the celt pointer is always in 

      A) BA          B) A1          C) AB          D) 1A 

16. In StarCalc, amongst arithmetic operators which one of the following is  executed first in the rules of 

precedence? 

   A) Exponentiation           B) Negative    C) Multiplication & division         D) Addition & subtraction 

17. In StarBase. the process of limiting the information that appears on the      screen is 

       A) sorting       B) querying     C) searching    D) filtering 

18. Which database contains only one table in StarBase? 

      A) Hierarchical   B) Relational    C) Flat-file       D) object-oriented 

19. In StarBase, filter used with a condition is called 

      A) Autofilter      B) Default filter C) Query filter   D) Condition filter 

20. In StarBase, how many field types can be used? 

A) 20       B) 14         C) 18          D) 15 

21. SQL is an acronym for  

A) Structured Quick Language     B) Structured Query Language 

C) Sorted Quick Language           D) Sorted Query Language 

22. The screen that displays the fields of a record in a well spaced out manner in StarBase is 

     A) Report       B) Filters     C) Query       D) Form 

23. In StarBase, each column in a table represents 

     A) Record       B) Field        C) File          D) Database 

24. In StarBase, which one of the following is not a process in editing the database? 

A) Adding new record             B) Changing format of the database 

C) Calculating result              D) Deleting existing data 

25. In StarBase, a small triangle on the left-most column of the table is called 

       A) insertion point                 B) field-pointer        C) table pointer                   D) record pointer 

26. GIF is limited to 

 A) 4-bit palette   B) 6-bit palette  C) 8-bit palette   D) 16-bit palette 
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27. Which file format supports full colour and produces relatively small size files? 

      A) GIF          B) NxView      C) JPEG       D) BMP 

28. Which tag is used to add inline sound? 

     A) <bgsound>   B) <bgobject>  C) <embed>    Q) <applet> 

29. The conversion of analog sound waves to digital format is called 

   A) morphing     B) rendering    C) modeling    D)sampling   

30. Reducing (he frame count to less than how many frames per second causes the video to, look jerky?                           

    A) 7           B) 15         C) 28        D) 30 

31. How many options are displayed in the first page of the presentation wizard to create an empty 

presentation?                    

    A) 4            B) 2           C) 3            D) 5  

32. Which button is to be clicked to create a new presentation using a template? 

       A) Shift+Ctrl+0 . B) Shift+Ctrl+N C) Shift+0      D) Shift+N 

33. Which key a used to stop the presentation before the end? 

      A) Enter       B) Backspace  C) Escape      D) F5 

34. Which key is used to open style list in presentation? 

A) F2          B) F5         C) F6          D) F11 

35. Which view allows you to create and edit slides? 

     A) Notes     B) Outline      C) Normal      D) Handouts 

36. Which is a kind of a self-sufficient "subprogram" with a specific functional area in C++ ? 

A) Object       B) Encapsulation C) Data hiding . D) inheritance 

37.  Which is a template for entities that have common behaviour in C++ ? 

A) Object       B) Class       C) Behaviour   D) Polymorphism 

38. Which one of the following is not a keyword in C++ ? 

A) Inline         B) This         C) Struct        b) Test 

39. 0.5864E1 represents 

       A) 5.864    B) 0.05864     C) 58.64       D) 0.5864 

40. Which amongst the. following called  address of operator in-C++ ? 

       A) ::        .   B) #           C) &         D) * 

41. Data types can be classified into how many types in C++? 

      A) 2 '       B) 3 -     C) 4 .         D) 5          
:
 

42. The invalid variabie declaration statement in. C++ in the following is 
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        A) inta.b;                       B)inta = 10; float b;    

        C) inta;b;                       D) inta, float b  10; 

43. Which of the following is the extraction or get from operator in C++ ? 

     A) «        B) »          C) <>         D) # 

44. Which is a mu'tiple branching statement where, based on a condition, the 

    control is transferred to one of the many possible points? 

    A) if            B) switch       C) do           D) for 

45.Which one of the following ss exiUcheck loop in C++ ? 

      A) do while    B) while loop   C) for          D) switch   

46. Which statement is used to terminate the loop irrespective of the expression in C++ ?                             

      A) exit          B) continue     C) while       D) break 

47. Which of the following is starting point for the execution of a program? 

       A) main ()      B) function      C) #include     D) header 

48. Declaration of a function in C++ is made through 

A) function call .                         B) passing parameters . 

C) .function prototype                D) argument 

49. Which amongst the following can on!y be passed to f9rmal parameters of reference type in C++? 

A) Constants                       B) Variables  C) Expressions                   C) Values 

50. Which variable is defined within a block in C++ ? 

A) local          B) function    C) file           D) class 

51. A character array or string should be terminated by                 . 

      A) '\b'            B) '\n'           C) '\o'         . D) '\f' 

52. Which amongst the following is used to copy source string to target string in C++? 

      A) strcopy ()    B) strcpy ()     C) strcat ()     D) strcmp () 

53. In the array, int safes [2] [4]; the first row and second column is 

      A) sales [1] [2]   B) sales [2]'[1]   C) sales [0] [1]   D) sales [1]  

54. The body of a class is terminated by 

A) i          B) {            C) !            D) & 

55. If visibility label is not mentioned, the class member is treated "as 

      A) private       B) public       C) protected   D) static 

56. Which one of the following is called the scope resolution operator in C++ ? 

      A) ::            B) :            C) .           D).:?       

57. Which statement can -be reas as stud is an instance of object of the Class student?                                
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A) stud student;             B) class student stud;        C) class student (stud);            D) student stud;. 

58.The members of a class can be accessed using which operator? 

         A) +            B) size of    C) new         D) (dot) 

59.Data members of a class are also'called as 

     a) functions     B) objects       C) attributes     D) values  

60. In C++, polymorphism is achieved through                . 

      A) overloading   B) prototyping   C) inheritance   D) encapsulation 

61. In C++, each overloaded function must differ either by the number of 

     A) function name                   B) actual parameter 

     C) default parameter             D) formal parameter  

62. The mechanism of giving special meaning of an operator in C++ is called 

      A) function overloading           B) operator overloading 

       C) function prototype             D) argument overloading 

63. Which function returns nothing in C++? 

     A) conio.n       B) friend        C) constructor   D) istrearri.h 

64. In C++, the destructor has the ciassname prefixed by which character? 

      A) #            B) &           C) *         D) - 

65. The construction add ( add & a) is 

A) default constructor                       B) non-parameterized construction 

C) compiler generator constructor    D) copy constructor 

66.How many destructors can a" class contain? 

A) 1           . B) 2           C) 3          D) 4 

 

67.Which is executed-in the order'of inherited class? 

A) member functions             B) destructor  C) constructor                       D) data members 

68.When a derived class inherits only from one base class, it is called 

A) multiple inheritance       B) hybrid inheritance C) single inheritance              D) multilevel inheritance 

69. Access specifier is also calted as 

     A) specifier     B) visibility mode   C) abstract      D) instance 

70. Electronic pet is   

A) Kara-oke     B) Robot       C) E-mail       D) E-Pet 

71. The expansion for CBT is 
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A) Calculator Based Tutorials      B) Common Business Toot 

C) Computer Based Tutorials      D) Computer Based Tool 

72. How many steps are there in medical transcription? 

A) 1            B) 3           C) 4       D) 5 

73- Which is a special device that converts users speech into aJet^r? 

A) Kara-Oke                B) BFSI         C) Data Management               D) Dictaphone 

74. Making and using duplicate hardware and software is 

        A)cracking      B) piracy        C) virus         D) illegal access 

75. ITES stands for 

A) IT Environmental Studies       B) IT Enabled Services 

C) IT Evolution Studies                D) IT Enabled Studies 

 

JUNE -2012 

Choose the correct Answer:                                                        

1.   Which consists of several applications?            

    A) StarOffice Base               B) StarOffice     C) StarOffice Writer              D) StarOffice Calc. 

2. The shortcut key used to move to the beginning of a document is 

   A) Shift+Home B) Home+Enter C) Ctri+B      D) Ctrl+Home. 

3.  Which key is used to delete the characters to the right of the insertion point? 

     A) backspace    B) delete       C) spacebar    D) enter. 

4.   In StarOffice Writer the size of the font is measured in 

A) points        B) inches       C) bytes        D) size. 

5.  Which includes a dictionary and a spellcheck program? 

    A) StarOffice Calc                  B) StarOffice Writer 

    C) StarOffice Impress            D) StarOffice Base. 

6.  Which of the following is a grid with a specified number of columns and   rows in StarOffice Writer? 

     A) Cell        B) File       C) Border       D) Table 

7.  In a table, when the text is wrapped in a cell, it grows 

     A) wider         B) taller        C) wrap         D) border. 

8.  What is the default top margin of a page? 

 A) 1.25 inches   B) 1 inch       C) 1.50 inches  D) 1.20 inches 
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9. Which are some references and remarks added at every page of the document of the top and bottom 

margins respectively? 

    A) Header and footer              B) Top and bottom 

    C) Title and reference             D) Heading and page number. 

10. Which,one of the following is a spreadsheet? 

A) StarOffice Base      B) StarOffice-Cal     C) StarOffice Excel     D) StarOffice Writer. 

11. A grid of cells with a programmable calculator attached to each cell is 

       A) Computer    B) Visicalc     C) Spreadsheet D) datasheet.  

12. Which operator is not an arithmetic operator (in StarCalc)? 

      A) %            B) *            C) 
A
            D) <> 

13. Which refers to the first cell in a spreadsheet in StarCalc? 

A) 1A          B) 1           C) A           D) A1. 

14. In StarCalc, which menu is usedJo change the column width? 

     A) Edit         B) File         C) Insert       D) Format. 

15. Which is used to make data easier to understand? 

       A) Chart        B) Formula     C) Functions    D) Object. 

16. In StarOffice Calc, which one of the following operator combines two text? 

       a) +            B) &           C) |t           D)= 

17. DBMS is an acronym for 

A) Database Managing System        B) Database Management System 

C) Database Manipulation System   D) Database Mailing System. 

18. The process of joining data from two or more tables of the same or different 

     database is called 

     A) merging      B) searching    C) rows        D) filtering. 

19. Which of the following is an example for a flat file database? 

    A) StarBase sheet                B) StarOffice sheet    C) Spreadsheet                     D) Information sheet. 

20. The key that uniquely identifies a record in a database is 

     A) primary key    B) secondary key C) record key   D) table key. 

21. Which is a way of limiting the information that appears on screen? 

      A) Searching    B) Filtering     C) Merging     D) Sorting. 

22. Which term comes from the word'datum'? 

      A) Field        B) Number     C) Data        D) Record. 

23. Which is a group of related data conveying some meaning? 
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     A) Variable      B) information   C) Table        D) File. 

24. How many types of databases are there in StarOffice Base? 

    A) Three        B) Four        C) Five        D) Six. 

25. Which datatype accepts only whole numbers? 

    A) char         B) decimal      C) integer       D) float.. 

26. Which is a computer based presentation technique that incorporates text,  graphics, sound and video 

elements? 

A) MMS        B) Animation   C) Multimedia   D) TV. 

27. Which is an application that allows.you to send and receive messages over cellphones? 

    A) MMS        B) SMS        C) WMS       D) CMS. 

28. Which graphics help in rendering the image effectively on the screen? 

    A) Scalar graphics                B) Vector graphics    C)' Linear graphics                D) Dynarhic.graphics 

29. Which is not well fitted for photographic works? 

A) GIF        B) JPG       C) NxView     D) BMP. 

30. The sound that we hear.are of which wave patterns? 

   A) Analog       B) Amplitude   C) Frequency   D) Wave pitch. 

31. The command used to hide a selected slide is 

A) Slide show -Hide / Show slide B) Slide show  Show / Hide slide 

C) Slide  Hide slide                      D) Slide -> Hide. 

32. Which allows to view miniature images of all slides in a page? 

      A) Normal      B) Notes       C) Slide sorter  D) Outline. 

33. Which determines the text formatting style for title, outline and the 

    background design for single or all slides? 

A) Master page B) Master text  C) Master slide D) Master format. 

 

34. To insert a slide in a presentation, choose       

A) Insert-Slide               B) Slide- New slide   C) Insert - New slide            D) Insert -Object. 

35. Which key is used to select multiple slides? 

A) Ctrl           B) Alt           C) Shift         D) Tab. 

36. Which amongst the following is an object oriented programming language? 

      A) C++         B) C       C) Basic       D) FORTRAN  

37. Which data type allows programs to organize as objects that contain both   data and functions?                             

A) int           B) class        C) string        D) object. 
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38. C++ was developed by   . 

A) James Gosling               B) Bjarne Stroutstrup C) John Kemeny                D) Thomas Kurtz. 

39. The basic types are collectively called as                

     A) variables     B) operators    C) tokens       D) identifiers. 

40. What is the other name for variable ? 

      A) Constant     B) Identifier    C) Keywords    D) Numbers. 

41. What is the prefix character that used to represent escape sequence? 

       A) \            B) *         C) +           D) / 

42. if a = 5 and b = 8, what is the value of expression a+ b/2 * 4:7 

       A) 20           B) 36          C) 21           D) 24. 

43. How many storage specifiers are there in C++?                  

A) 3            B) 4           C) 5           D) 2. 

44 . in C++, which is called as exit check loop? 

A) do-while      B) while      C) for        D) if 

45. Which operator is the extraction or get from operator? 

A)»           B) «          C) >           D) < 

46. The multiple branching statement in C++ is 

A) if             B) switch       C) for           D) while. 

47. The default values can be included in the function prototype from 

      A) ending       B) beginning    C) middle       D) anywhere. 

48. Which looks like a normal function in the source file but inserts the-functions code directly into the 

calling program? 

A) Static        B) Insert        C) Inline     . D) Return. 

49.   In the following code, the scope of the variable 'a' is 

if(x<y) 

{                          

inta;                                                 . 

a++; 

 A) local scope   B) function scope C) title scdpe    D) class scope. 

50. What is the scope of a variable used in entire program called? 

      A) Local scope                      B) File scope        C) Function scope                D) Operator scope. 

51. What is a collection of variables of the same datatype that are referred by a  common name?                                          

.     A) Variable      B) Constant    C) Array        D) Data. 
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52. cin  nuroberf4J; which element is read? 

       A) Fourth       B) Fifth        C) First     

53. Matrices can be represented through 

A) single dimensional array        B) 2-D array    C) 3-D array       D) 4-D array. 

54. The most important feature of C++ is 

       A) integer       B) float         C) class        D) arrays. 

55. In a class data members are also called as                           

      A) methods     B) instance     C) functions     D) attributes. 

56. Which of the following is not a valid class access specifier? 

       A) Private       B) Public        C) Protected    D), Pointer. 

57. Class declaration is'terminated by 

     A) , (comma)    B) . (dot)       C) : (colon)     D) ; (semi-colon). 

58. Class comprises of 

A) data members, member name   B) data functions, system functions 

C) data members, member functions D) data-name, member type. 

59. Class belongs to which datatype in C++? 

A) User defined datatype          B) Built-in datatype  

C) Derived datatype                  D) Array 

60. In C++ polymorphism is achieved through 

   A) inheritance   B) encapsulation C) overloading  D) abstraction. 

61. Identify the operator that cannot be overload? 

A) + (binary)     B) -(unary)     C) *            D): 

62. The-mechanism of giving special meaning to an operator is called 

      A) operator overloading           B) function overloading 

      C) Inheritance                          D) object. 

63. The constructor function name has the same name as that of           

      A) scope       B) class        C) function     D) instance. 

64. Which is executed when a class goes out of scope? 

    A) Destructor  B) Constructor C) Overloading D) Declaration. 

65. The constructor without parameters is called as 

 A) parameterized constructor      B) default constructor 

C) copy constructor                      D) overloading constructor. 

66. Which overloading can be applied to constructor? 
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A) Operator     B) Procedure   C) Function     d) Class 

67. Derived class inherits what from its base class? 

A) Properties    B) Size        C) Name       D) Scope 

68. The default visibility mode is 

      A) public        B) private       C) protected     D) protect. 

69. Which amongst the following is executed in the order of inheritance? 

     A) Destructor    B) Constructor C) Class        D) Object. 

70. Which enables online educational programs leading to degrees and certifications? 

    A) Banking      B) e-Shopping C) e-Banking    D) e-Learning. 

71. A facility that allows the user to speak into a special device is called  

     A) computer    B) e-mail       C) dictaphone   D) tele-medicine 

72. Which .refers to the conversion of non-digital material to digital form? 

      A) Data         B) Document   C) Digitization   D)Tele-medicine. 

73. 85% of computer usage is 

A)  Presentation                  B) Word processing   C) Database                        D) Spreadsheet 

74. 'Cracking'comes under 

A) data security            B) computer crime   D) Password                        D) website service,. 

75. BFSI and pension services are high growth areas of 

       A) Call centers           B) ITES         C) Public telecom                D) Medical transcription. 

 

 

 

 

 

 

OCTOBER -2012 

 

Choose  = 75  • 

1.  Which enables online education programs leading to degrees and certifications?                                                         

     a) e-shopping   B) e-learning    C) e-banking    D) e-governance. 

2.  A category of IT enabled services pertaining to collection digitization and    processing of data coming 

from various sources is                        

A) Data Management          B) Tele-medicine  C) Data Digitization       D) Website Services 
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3.  How many steps are involved in medical transcription? 

A) 1           B) 2           C) 3            D) 4 

4.  The set of rules for determining moral standards or what is considered as socially acceptable behaviour is 

called                                    

A) Leisure                      B) Compute r_C rime  C) Cracking                     D) Ethics                          

5.  Making and using duplicate hardware and software is called                

      A) virus         B) ethics       C) piracy        D) cracking         

6.  When the control reaches the end of the class scope, which function is executed automatically?                                                 

      A) constructor                        B) destructor      C) default constructor             D) copy constructor. 

7.   Classes used only for deriving other classes are called? 

     A) base class    B) derived class C) abstract class D) constructor 

8.  The base class member which is not inherited in derived classes is 

     A) general      B) public       C) protected    D) private 

9.  A class is derived from a class which is a derived class itself, then this is  referenced to as 

A) multiple inheritance B) multilevel inheritance C) single inheritance D) double 

inheritance 

10. Which enables data storage and management? 

A) Archive unit                  B) Data hiding         c) Data abstraction      D) Digitization 

11. During the integral promotion, a double data tpe can be converted        into .. 

        A) float or integer                 B) float or void        C) integer or char                D) float or char. 

12.  Which of the following operators can be overloaded'in C++? 

       A) +            B) ::           C) .           D) ?: 

13. In C++  which functions return nothing? ' 

 A) inline functions                    B) friend functions 

C) overloaded functions           D) constructor and destructor 

14. Which of the following is default constructor? 

A) add()                            B) add(intst)  C) add(ints1, ints2)           D) add ( add & a)' 

.15. Which of the following must have the same name as that of the class name? 

         A) variable      B) string literal C) constructor   D) constant. 

16. If a visibility level is not mentioned then by default the class members will be treated as 

      A) Private       B) Public       C) Protected    D) General 

17. Instruments allowing only selected access of components to objects and to 

      members of other classes are called 
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       A) inheritance                       B) constructors        C) data abstraction               D) encapsulation 

18. Class product 

{ 

int code, quantity; 

float priced 

void main () 

{ 

product p1;                                        

}                      

Thenumberof memory allotted for the object p1 is 

A) 2 bytes      B) 4 bytes      C) 6 bytes      D) 8 bytes 

19. Which member variable is initializer only once, when the first object of its 

      class is created? 

       A) static         B) private       C) public        D) protected 

20. fn C++ polymorphism can be achieved through 

A) inheritance
 
                    B) data hiding 

C) overloading                   D) data abstraction 

21. The array subscript always commences from 

A) 0             B) 1            C) 2            D) -1  

22. Which one of the following functions returns the number of characters 

    stored in the array?                     

     A) strcpy ()     B) strcmp ()    C) strcat ()     D) strlen () 

23. How many methods are available to display the contents of string in C++? 

       A) 1            B) 2           C) 3       . D) 4 

24. The most important feature of C++is 

A) state         B) behaviour   C) method    D) class 

25. In C++, the functions are also called as 

       A) variables     B) classes      C) methods     D) arrays 

26. Which is multiple branching statement in C++? 

A) if            B) while        C) switch        D) fo. 

27. In computers machine-readable form of a program is called 

       A) source code  B) object file    C) compiler     D) executable file. 

www.Padasalai.Net



PUGAL XII C.S ENGLISH MEDIUM PUBLIC ONE MARK                  
 

                                                      
PREPARED BY: P.CHANDRASEKARAN M.C.A, B.ED.,    MOB:99420 12999 90 

 

28. The actual parameters can be passed to format parameters of reference type only as 

A) constants     B) variables    C) expressions D) value 

29.  The function that returns no values declared as 

A) main         B) friend        C) void          D) static 

30. Which one of the following is called as scope resolution operator? 

       A) .             B) :            C) ;            D) : 

31. Which qualififer specifies that the valaue of a variable will not change during 

     the run time of a program? 

      A) size of       B) static        C) unsigned     D) const. 

32. How many methods are available for assigning data to the variables in C++?                                                       

      A) 1            B) 2           C)3           D) 4 

33. Which one of the following is the insertion operator, or put to operator in 

      C++?                               

     A) <           B) «         C) >        D) » 

34. Which is an assignment operator in C++? 

A) +        B) -           C) =           D) == 

35. What is the output of the following snippet? 

        intb=10>20; 

if(b) 

{                            

cout"True Block"; 

} 

else 

{ 

cout"Else Block"; 

 }                                                              

 

A) Else Block                              B) True Block 

C) "True Block Else Block          D) Else Block True Block 

36. GIF format is limited to a palette of 

A) 5 bit        B) 6 bit           C) 7 bit           D) 8 bit 

37. In multimedia, the pattern of the sound that you hear is 
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     A) Analog wave B) Digital wave C) Hybrid wave D) Frequency 

38. The technique of distorting a single image to represent something else is 

      A) Morphing     B) Warping     C) Sampling    D) Modelling 

39.  File in the AfFF format have the extension 

A) .avi          B) .aif          C) .aud         D) .wav 

40. The shockwave format was developed by         

A) IBM         B) Microsoft    C) Macromedia D) Apple. 

41. The command used to save the database table is 

A) File - Save                   B) File -> Tools -> Save 

C) Edit -Save                   D) Edit - Fill -Save 

42. How many types of filters are used in StarOffice Base? 

A) 1            B) 2           C)3        D) 4 

43. How many number of field types are there in StarOffice Base? 

      A) 15          B) 13        C) 20         D) 18            

44. In StarOffice Base, a printed information that is assembled by gathering   data based on user supplied 

criteria is called                          

      A) report        B) query        C) table        D) form 

45. The command used to transfer each heading together with its accompanying   paragraphs in the text 

document into a presentation is                   

       A) File -Send ->Auto Abstract to presentation                

B) File -Copy ~Auto Abstract to presentation                        

C) File -+ Edit -Auto Abstract to presentation                            

D) Edit -Send - Auto Abstract to presentation                          

 

46. Which dialog box appears when Shift + Ctrl + N buttons are clicked from  StarOffice Impress? 

A) Academic presentation        B) Templates   C) Documents   D) Templates and Documents 

47. Which option allows you to manually control the transition of slides using  options such as mouse click? 

      A)Show logo    B) Effect       C) Automatic    D) Default 

48. In StarOffice Impress, the key pressed to start slide show is  

     A) F1           B) F5          C) F6          D) F11 

49. The command used to hide the slide(s) in the slide show is 

       A) Hide - Slide                             B) Slide Show -Hide 

      C) Slide show - Show/Hide slide  D) Slide Show --+ Hide slide 
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50. Which key combination is used to print the slides in StarOffice Impress? 

       A) Ctrl + A       B) Ctrl + P      C) Al + Ctrl + P D) Ctrl + Alt + P 

51. Which is text operator in StarOffice Calc?                          . 

       A) +            B) !            C) &            D) % 

52. In StarCalc. how cells A1, B1, C1, D1, El & F1 can be referred to as range  in a worksheet? 

     A) A1:F1       B) A1.F1      C)A1?F1      D) Al ; F1          

53. In StarCalc, the symbol used to change the cell address into absolute cell  address is 

     A) !             B) $           C) &           D) : 

54. In StarOffice Calc, the command used to generate a series is 

      A) Sum         B) Format      C) Edit         D) Fill 

55. In StarOffice Calc. the command used to change the width of the column is 

     A) Format - Row -> Width       B) Format --Column - Width 

   C) Format -> Width - Row         D) Format - Width -+ Column 

56. Which among the following makes it easy to represent real systems in software programs? 

A) Object                          B) Control statements   C) Computer         .          D) Data hiding 

57. Which is template for entities that have common behaviour? 

      A) Class      . B) Object       C) Variables . D) Attributes 

58. which of the following is an escape sequence for new line / line feed? 

       A) :a        B) \n           C) \t           D) \b 

59. What is the value in c when the following snippet is executed? 

       int a, b, c; 

a =8;                      

  b = 3;                         

c = a/b; 

c = +-i-c; 

cout c; 

A) 1            B) 2           C)3           D) 4 

60. Which of the following is not a storage specifier? 

A) auto          B) static        C) register      D) switch 

61. In StarCalc. the icon used to insert objects from other applications into a  worksheet is 

A) Insert Chart                    B) InsertApplet   C) Insert Formula               D) Insert OLE object 

62. In Computers, the value assigned to a variable is called . 

       A) Key         B) Information  C) Data        D) Report 
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63. In StarOffice Bsse, each row in a table represents 

      A) File          B) Record      C) Field         D) Database 

64. A key that uniquely identifies a record in a database table is 

       A) a data       B) afield       C) a record     D) a primary key 

65. A collection of related table is what in StarOffice Base? 

      A) A form       R) A report      C) A database   D) A record 

66. In StarWriter, while correcting the spelling mistakes, the button clicked to skip all occurences of the 

word is 

A) Ignore       B) Ignore all    C) Change     D) Change all 

67. The key pressed to move forward through the cells of the table in StarOffice Writer is 

A) Tab          B) Shift + Tab   C) Ctrl + Tab    D) Ctri+Shift+Tab 

68. In StarOffice Writer, which of the following dialog boxes appears when Table Table properties 

command is used? 

       A) Table property            .   B) Table properties     C) Table format                  D) Table wizard 

69. In StarOffice Writer, the area at the bottom of the page is 

      A) portrait       B) landscape   C) header      D) footer 

 70. Which one of the following spreadsheet packages was developed by Sun Microsystems? 

      A) Visicalc      B) Excel       C) Improve     D) StarOfficeCalc. 

71. Which key should be pressed to inserts blank line in a StarWriter documents? 

       A) Home       B) End        C) Delete      D) Enter 

72. In StarWriter, which keyboard shortcut is used to select the entire  documents? 

      A) Ctrl + A      B) Ctrl + B      C) Ctrl + C      D) Ctrl + S 

73. The command used to open character dialog box is 

A) Edit - Character              B) Format – Character  C) View - Character  D) Tools - Character 

74. In StarWriter, the size of a font is measured in 

 A) points        B) inches       C) centimeters  D) lines 

75. Which key is used to get the spellcheck dialog box for spelling correction in  the Starwriter document? 

     A) F1           B) F5          C) F7      D) F10 
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